Picture Thumbnail Generation rework (1 Viewer)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,583
    10,403
    France
    Home Country
    France France
    Hi,

    Related to this Mantis : -->> 4322 <<--
    Branch related -->> here <<--
    Link for Full Installer : -->> here <<--

    Actual Thumbnail Picture Generation is quite slow, we try to speed up it and that need some testing and report.

    2013.04.12 : Attached bin can be used on 1.3Final.
    • Configuration.exe / Configuration.exe.config / Core.dll / fontEngine.dll / Microsoft.WindowsAPICodePack.dll / Microsoft.WindowsAPICodePack.Shell.dll -->> Should go to "C:\Program Files (x86)\Team MediaPortal\MediaPortal"
    • WindowPlugins.dll -->> "C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\Windows"

    What need testing :
    • See if generation works from MP Config / GUI Setting / from MyPictures
    • See if Video/Picture thumbnail works.
    Thanks :)
     

    Attachments

    • Pictures_V5_and_Tree_Folder.rar
      2.7 MB
    Last edited:

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    48
    ::1
    Home Country
    Netherlands Netherlands
    Created thumbs from Config:
    [2013-04-14 16:25:28,341] [Config ] [PicturesScan] [DEBUG] - Pictures Configuration : Creation of selected thumb for '2512' files, took 19,7520002 seconds (y)
     
    Last edited:

    burzelmann

    MP Donator
  • Premium Supporter
  • September 21, 2010
    88
    8
    Home Country
    Germany Germany
    Thank you for reworking this part of MP. It was indeed quite unuseable before. Now here is my log entry after generating thumbnails.
    Code:
    2013-04-19 14:29:18.062043 [Debug][PicturesScan(7)]: Pictures Configuration : Creation of selected thumb for '53958' files, took 269,3335176 seconds
    Thumbs were generated from a folder on my NAS (connected via Gbit).
     

    skorz

    MP Donator
  • Premium Supporter
  • December 19, 2011
    242
    40
    Deutschland
    Home Country
    Germany Germany
    Not sure if this is the right place, but there is a problem creating thumbs for album in the music section. logs attached, mostly this:

    Code:
    [2013-04-26 12:01:24,279] [Config ] [9		] [INFO ] - MusicDatabase: Could not extract thumbnail from D:\Musik\Frank Sinatra - Best Of\026 - Frank Sinatra - Come Rain Or Come Shine.flac
    [2013-04-26 12:01:24,279] [Config ] [9		] [INFO ] - GUIPictures: No thumbnail created for -- C:\Users\Mike\AppData\Local\Temp\bykjnmiv.wsx
    [2013-04-26 12:01:24,279] [Config ] [9		] [INFO ] - MusicDatabase: Could not extract thumbnail from D:\Musik\Frank Sinatra - Best Of\026 - Frank Sinatra - Come Rain Or Come Shine.flac
    [2013-04-26 12:01:24,279] [Config ] [9		] [ERROR] - Util: FileDelete(string strFile) error: Der Prozess kann nicht auf die Datei "C:\Users\Mike\AppData\Local\Temp\bykjnmiv.wsx" zugreifen, da sie von einem anderen Prozess verwendet wird.
    [2013-04-26 12:01:24,310] [Config ] [9		] [INFO ] - GUIPictures: No thumbnail created for -- C:\Users\Mike\AppData\Local\Temp\we3h14cr.31x

    I have to say, i have installed the 1,4 test version from scythe42 // https://forum.team-mediaportal.com/threads/scythe42s-fixes-for-1-4-0.118345/

    So, is there a dirty fix or i have to wait for merge this fix with the 1.4 testfile?
     

    Attachments

    • Unbenannt.png
      Unbenannt.png
      46.8 KB
    Last edited:

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    Home Country
    United Kingdom United Kingdom
    Not sure if this is the right place, but there is a problem creating thumbs for album in the music section. logs attached, mostly this:

    Code:
    [2013-04-26 12:01:24,279] [Config ] [9		] [INFO ] - MusicDatabase: Could not extract thumbnail from D:\Musik\Frank Sinatra - Best Of\026 - Frank Sinatra - Come Rain Or Come Shine.flac
    [2013-04-26 12:01:24,279] [Config ] [9		] [INFO ] - GUIPictures: No thumbnail created for -- C:\Users\Mike\AppData\Local\Temp\bykjnmiv.wsx
    [2013-04-26 12:01:24,279] [Config ] [9		] [INFO ] - MusicDatabase: Could not extract thumbnail from D:\Musik\Frank Sinatra - Best Of\026 - Frank Sinatra - Come Rain Or Come Shine.flac
    [2013-04-26 12:01:24,279] [Config ] [9		] [ERROR] - Util: FileDelete(string strFile) error: Der Prozess kann nicht auf die Datei "C:\Users\Mike\AppData\Local\Temp\bykjnmiv.wsx" zugreifen, da sie von einem anderen Prozess verwendet wird.
    [2013-04-26 12:01:24,310] [Config ] [9		] [INFO ] - GUIPictures: No thumbnail created for -- C:\Users\Mike\AppData\Local\Temp\we3h14cr.31x

    I have to say, i have installed the 1,4 test version from scythe42 // https://forum.team-mediaportal.com/threads/scythe42s-fixes-for-1-4-0.118345/

    So, is there a dirty fix or i have to wait for merge this fix with the 1.4 testfile?

    First question - does this work fine with 1.3.0 ?

    Second question - why are you trying to generate thumbs from C:\Users\Mike\AppData\Local\Temp ?

    Third question - can MP play a .wsx file, and is there a thumb in the file? Not sure why GUIPictures is trying to create a thumb. Have you added the folder as a picture share?

    Fourth question - what is a .31x file ?

    And finally, can MP extract thumbs from .flac files, and are you sure there is a thumb in there to extract?
     

    skorz

    MP Donator
  • Premium Supporter
  • December 19, 2011
    242
    40
    Deutschland
    Home Country
    Germany Germany
    1) Never had Problems with 1.30 final
    2) have no plan :)
    3) dont know why it generates .wsx or .31x files..
    4) never seen before..
    5) all flacs are tagged fine and it worked before (i did install the testversion)

    i did noticed, thumbnail creation also did not work for the last pictures..
     
    Last edited:

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    Home Country
    United Kingdom United Kingdom
    1) Never had Problems with 1.30 final
    2) have no plan :)
    3) dont know why it generates .wsx or .31x files..
    4) never seen before..
    5) all flacs are tagged fine and it worked before (i did install the testversion)

    i did noticed, thumbnail creation also did not work for the last pictures..

    Your log has

    GUIPictures: No thumbnail created for -- C:\Users\Mike\AppData\Local\Temp\bykjnmiv.wsx

    so it seems that MP is trying to create a thumb for the .wsx file in the folder, not trying to save to the folder. Something is definitely wrong.

    Please post your 'MediaPortal.xml' file.
     

    elliottmc

    Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    Home Country
    United Kingdom United Kingdom
    Okay, I can see no reason why MP would be looking in C:\Users\Mike\AppData\Local\Temp

    You have

    [2013-04-26 12:00:38,742] [Config ] [MusicScan] [INFO ] - MusicDatabase: adding share D:\Hˆrspiele for scanning - available disk space: 38911 MB

    I wonder if the special character in the folder name is causing a problem. Try removing this share and see if it makes a difference.

    Apart from that, try mp3 files, or maybe post one of the flac files here to see if it works for someone else.
     

    Users who are viewing this thread

    Top Bottom