[fixed] Pictures currentSlideIndex resetting to -1 [Mantis #4461] (1 Viewer)

markus_g

Portal Pro
August 12, 2006
104
42
Australia Australia
Country flag
Hi,
I have noticed when viewing pictures the currentslideindex that is stored when viewing a picture is changing to -1 when escape is pressed to step back. After this the selection bar is located at the top and not on the last viewed file. Is this correct behaviour or a bug.

Regards,
Markus

Edit by Sebastiii : Adding installer for testing the fix -->> HERE <<--
 
Last edited by a moderator:

mbuzina

Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Germany Germany
    Country flag
    I can confirm this and it should not be like that. Will log it as a bug.
     

    mbuzina

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Germany Germany
    Country flag
    I used keyboard - do not have remote on this machine at the moment. Can you reproduce the issue?
     
    Last edited:

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    I don't have access atm. Can test on sunday evening.

    But a question how to reproduce:
    Go to pictures -> Select a picture -> Back -> First picture in the list/coverflow/filmstrip is selected instead of the previously watched one in fullscreen?
     

    mbuzina

    Retired Team Member
  • Premium Supporter
  • April 11, 2005
    2,839
    726
    Germany
    Germany Germany
    Country flag
    If select means: Show Picture in FullScreen (aka Enter/OK on it) then yes.
    So Steps are:
    1. Open Pictures
    2. Select a folder with pictures & open it (most people do not have pics in root folder ;-)
    3. Move to a picture down the list (or right)
    4. Open Picture in FullScreen (Enter/OK)
    5. Go Back (ESC/Back)
    6. RESULT: First entry is selected, not last watched picture (btw. when moving while in full screen with left/right the selected index should also move)
     

    markus_g

    Portal Pro
    August 12, 2006
    104
    42
    Australia Australia
    Country flag
    Bug 0004461 minor new 2013-05-24 Pictures currentSlideIndex resetting to -1

    Are you using remote or keyboard? Is there a different behaviour?
    Hi,
    I can confirm it happens with a remote or a keyboard.

    Thankyou for setting it as a bug as the picture viewer is almost unusable currently if there are a lot of pictures in the one directory.

    Regards,
    Markus
     
    Last edited:

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Hi Guys,

    I have try to fix that (yep it's late) lol
    Can you try attached bin to test ?
    Please do full testing to spot any regression (slideshow / recursive slideshow / while and without playing music / while and with video/picture mixed and while / without playing music etc.
    Thanks.
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    horned_reaper [solved] Mixed artist pictures Fanart Handler 397
    F Picture on folder Feature Requests 9
    M.Hulot Moving Pictures lässt sich nach Windows-Update nicht mehr öffnen Plugins & Erweiterungen 1
    cerberus Moving Pictures zeigt Film Spezifikationen nicht richtig Plugins & Erweiterungen 12
    P Configuration Moving Pictures Support d'installation et de configuration 0
    emphatic Pictures in the cloud - would a plugin be possible for services like Google Photos MediaPortal 1 Plugins 1
    R [solved] Moving pictures importer wont add files from a removable drive. Is there a work around ? Moving Pictures 8
    badboyxx [solved] Moving Pictures and MediaPortal 1.23 Regeszter Edition Moving Pictures 93
    caveman [solved] Moving Picture 97% CPU Moving Pictures 9
    T Moving Pictures...seem to have 'lost' ability to display Movie info. (eg Resolution/Audio) Moving Pictures 2
    A Video clips do not work in the Pictures folder General Support 10
    N [Finished] [MP2-789] MCE remote control Recorded TV and My Pictures buttons do not work MediaPortal 2 17
    raffe [solved] Export tool and import support from MP-TVSeries & Moving Pictures to MP2 General 22
    Cowboy Playback Problem with CTD or sometimes BSOD watch/edit Videos 0
    haaitje Pictures error .net framework MPTagThat 0
    M.Hulot Moving pictures startet nur im hintergrund und falscher version Allgemeines Supportforum 5
    volumia Q: thumbnail creation for Pictures plugin MediaPortal 1 Plugins 3
    T Neuinstalation - Moving Pictures probleme Installationsprobleme? 19
    B Display pictures to 4K TV View Pictures 0
    G MadVR, black TV Picture 1.20 Pre Release 1
    S Problem wit .ISO files in Moving Pictures Moving Pictures 3
    olli14 Inhalt der Moving Pictures Datenbank in die Plex Datenbank kopieren MediaPortal Café 69
    T Moving Pictures Icon disappeared...and the program....??? Watch / Listen Media 1
    T Moving Pictures error after update to 1.19 Final...logs included! Watch / Listen Media 6
    J View pictures in date order? View Pictures 0
    Similar threads

























    Top Bottom