Play ISO's in external player! (1 Viewer)

luci5r

Portal Pro
May 30, 2011
207
11
Home Country
United States of America United States of America
I was baffled today to realize MP-TVSeries doesn't seem to use external player to launch ISO's.

I have the virtual drive & tmt5 launch options setup & all my disc images (ISO's, etc) get automatically mounted & launch on TMT5 when using Moving-Pictures for my movies.

However, I recently ripped my Season 1 blu-ray discs of 'Walking Dead', a tv show, and when I launch them from MP-TVseries, it only uses the internal player. There is no "use external player" argument in settings like Moving-Pictures.

So -> how do you get ISO's for tv show to launch in external player, like movies in Moving-Pictures, in MP-TVSERIES?

Thanks!
 

kiwijunglist

Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,751
    New Zealand
    Home Country
    New Zealand New Zealand
    Have you tried:

    MP Configuration (Advanced) -> DVD Discs/Images -> DVD Discs/Images Player -> [X] Use external player (replaces internal player)
     

    luci5r

    Portal Pro
    May 30, 2011
    207
    11
    Home Country
    United States of America United States of America
    Have you tried:

    MP Configuration (Advanced) -> DVD Discs/Images -> DVD Discs/Images Player -> [X] Use external player (replaces internal player)

    Yes, most certainly. MP-TVSeries seems to disrespect it. I've always had that option setup & it works for "Videos".

    You can run a quick test if you want. Just use any iso you have, make a copy & rename it to an episode of any series you have in mp-tvseries. See if you can get it to launch as mounted iso in external player. I've tried everything!
     

    luci5r

    Portal Pro
    May 30, 2011
    207
    11
    Home Country
    United States of America United States of America
    Hello There!

    Just checking in to see if anyone had a chance to look this over.

    Thanks.
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,751
    New Zealand
    Home Country
    New Zealand New Zealand
    It may take him a week or two to respond, he is a busy man.[DOUBLEPOST=1442297679][/DOUBLEPOST]In the interim you could search the forum, to see if there have been previous discussions around this issue.[DOUBLEPOST=1442298179][/DOUBLEPOST]https://forum.team-mediaportal.com/...k-solution-external-player.93725/#post-724094

    ^ suggests that my videos plugin must be enabled for my tv series to play iso in external player?

    You can confirm that the exact same file loads in external player when mounted using my videos plugin (not MOVING PICS), however when mounted using my tv series plugin it opens in the internal player instead of the external player? ... correct?
     
    Last edited:

    luci5r

    Portal Pro
    May 30, 2011
    207
    11
    Home Country
    United States of America United States of America
    It may take him a week or two to respond, he is a busy man.[DOUBLEPOST=1442297679][/DOUBLEPOST]In the interim you could search the forum, to see if there have been previous discussions around this issue.[DOUBLEPOST=1442298179][/DOUBLEPOST]https://forum.team-mediaportal.com/...k-solution-external-player.93725/#post-724094

    ^ suggests that my videos plugin must be enabled for my tv series to play iso in external player?

    You can confirm that the exact same file loads in external player when mounted using my videos plugin (not MOVING PICS), however when mounted using my tv series plugin it opens in the internal player instead of the external player? ... correct?

    No worries; I understand.

    I did actually browse through that thread during my research phase - and I have indeed scoured the forum, with no luck.
    Yes, I can confirm all 3 conditions mentioned in that thread are met on my end; namely:
    - Virtual Drive is setup properly (Moving-Pictures uses it successfully currently)
    - DVD Discs/Images Player is also set to "use external player" correctly.
    - "Videos" plugin is enabled in Plugins configuration.

    And of course ".ISO" is added to the list of allowed extensions.

    Thanks.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,745
    7,174
    Sydney
    Home Country
    Australia Australia
    I dont have time right now to look into this but if you provide log files after attempting to play an ISO in tvseries it will help when I do have time.

    It is possible that something has changed in MediaPortal and now needs adjusting to work, im pretty sure this worked once upon a time. To make things easier in the future I would suggest converting each episode to mkv.
     

    luci5r

    Portal Pro
    May 30, 2011
    207
    11
    Home Country
    United States of America United States of America
    I dont have time right now to look into this but if you provide log files after attempting to play an ISO in tvseries it will help when I do have time.

    It is possible that something has changed in MediaPortal and now needs adjusting to work, im pretty sure this worked once upon a time. To make things easier in the future I would suggest converting each episode to mkv.

    Thank you for giving this your time; I appreciate it. Please take your time.

    Logs attached.

    Screenshot showing DVD Discs / Images Player setup correctly:
    mp1.PNG


    Screenshot showing Virtual Drive setup correctly:
    mp2.PNG


    Screenshot showing Videos plugin enabled:
    mp3.PNG


    Thanks again!
     

    Users who are viewing this thread

    Similar threads

    Hi. This is true, but as many people have requested this feature you can create the images share to accept videos too. This way you can watch anything on the SD card of your camera in one place. Yes, this definitely is possible in MP2 too. You need to activate this during creation of the images share. If you already have created...
    Hi. This is true, but as many people have requested this feature you can create the images share to accept videos too. This way...
    Hi, Two questions about MP2 V2.3: - Is it possible to set an external video player for movies? in MP1, it was possible but I do...
    Replies
    8
    Views
    1K
    When using the internal Blu-ray Player the subtitles appear too early. No matter if I play the movie/series using the menu or picking the stream from the MP menu. When the internal Blu-ray Player is off, the subtitles appear correctly. Has anyone a suggestion how to fix that? Thanks in advance. Gesendet von meinem BlackBerry KEYone...
    When using the internal Blu-ray Player the subtitles appear too early. No matter if I play the movie/series using the menu or...
    When using the internal Blu-ray Player the subtitles appear too early. No matter if I play the movie/series using the menu or...
    Replies
    0
    Views
    415
    • Sticky
    Good job, nice release as usual (y)
    Good job, nice release as usual (y)
    We are proud to present MediaPortal 2.4 MediaPortal 2.4 is a full-blown media center software that addresses most common user...
    Replies
    5
    Views
    2K
    Many people found the Lentoid decoder better optimised than LAV for software decoding. If you want to try it, download it from the link below, run reg.bat as an admin to install it and change the HEVC Video settings in MediaPortal Configuration/Codecs and Renderer...
    Many people found the Lentoid decoder better optimised than LAV for software decoding. If you want to try it, download it from the...
    For some unknown reason I can't play HEVC encoded video with MP1 on my system. I have tried every trick I know, but nothing works...
    Replies
    10
    Views
    2K
    Hi, I have just updated my MediaPortal 1.22 HTPC from Windows 7 to Windows 10 Home, and now cannot play DVD or Blu Ray discs with the internal player. As soon as MediaPortal tries to read the DVD or Blu Ray it locks up. If I set MediaPortal to use an external player (VLC) it works fine within VLC. I am using EVR and LAV filters...
    Hi, I have just updated my MediaPortal 1.22 HTPC from Windows 7 to Windows 10 Home, and now cannot play DVD or Blu Ray discs with...
    Hi, I have just updated my MediaPortal 1.22 HTPC from Windows 7 to Windows 10 Home, and now cannot play DVD or Blu Ray discs with...
    Replies
    0
    Views
    759
    Top Bottom