"Play Recording From Beginning" - not working correctly

Discussion in 'fixed TV-Server / Client Bugs' started by garry, March 11, 2007.

  1. garry

    garry Portal Pro

    Joined:
    December 11, 2005
    Messages:
    227
    Likes Received:
    17
    Location:
    California
    Ratings:
    +17 / 0
    Home Country:
    United States of America United States of America
    MediaPortal Version: 3/8/2007 SVN of MP & TV3
    MediaPortal Skin: BuueTwo
    Windows Version: Windows 2003 R2
    CPU Type: Pentium D 805
    HDD: 160GB SATA
    Memory: 2GB DDR2
    Motherboard: Dell DXP051
    Motherboard Chipset:
    Motherboard Bios: A05
    Video Card: GeForce 7300LE
    Video Card Driver: 91.47_forceware_winxp2k_english_whql.exe
    Sound Card: onboard
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: PVR-500
    1. TV Card Type: analog
    1. TV Card Driver: latest
    MPEG2 Video Codec: PureVideo
    MPEG2 Audio Codec: PureVideo
    Satelite/CableTV Provider: DirecTV
    Remote: MCE
    TV: old Sony 32" CR
    TV - HTPC Connection: s-video




    If I'm watching a channel using one tuner and have another tuner in the middle of a scheduled recording then change to the channel that is being recorded selecting "Play Recording From Beginning" I end up at the beginning of the timeshift buffer for the first tuner. This makes it impossible to watch a recording in progress from the beginning.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. ASiDiE
    • Premium Supporter

    ASiDiE Retired Team Member

    Joined:
    January 14, 2005
    Messages:
    902
    Likes Received:
    5
    Occupation:
    Computer Tek/Tester for MP
    Location:
    USA
    Ratings:
    +5 / 0
    Currently... the last I knew... this was work in progress.
     
  4. garry

    garry Portal Pro

    Joined:
    December 11, 2005
    Messages:
    227
    Likes Received:
    17
    Location:
    California
    Ratings:
    +17 / 0
    Home Country:
    United States of America United States of America
    Excellent, please let me know if there is anything I can do to help! I'm a c# developer but have not had much time to contirbute to MP other than some plugin work.
     
  5. mdsflyer

    mdsflyer Portal Pro

    Joined:
    November 14, 2005
    Messages:
    283
    Likes Received:
    6
    Ratings:
    +6 / 0
    Home Country:
    New Zealand New Zealand
    I'm just checking in that this isn't just my system. My problem is if i am recording a channel (i use mpg rather than ts) and the recording is say half way through i have no way of watching. Neither the play recording from live point nor the play recording from beginning options work for me. I am able to play the recording once it is finished. If i discover i'm the only one with this issue then obviously i've got some digging to do but from what i read above it seems like this is an area which is being worked on.

    If anyone can shed some light i'd be grateful

    Cheers
    m
     
  6. gemx
    • Premium Supporter

    gemx Retired Team Member

    Joined:
    October 31, 2006
    Messages:
    1,972
    Likes Received:
    541
    Ratings:
    +541 / 0
    Home Country:
    Germany Germany
    Show System Specs
    This is really a bug.
    I am looking into it at the momement :)
     
  7. gemx
    • Premium Supporter

    gemx Retired Team Member

    Joined:
    October 31, 2006
    Messages:
    1,972
    Likes Received:
    541
    Ratings:
    +541 / 0
    Home Country:
    Germany Germany
    Show System Specs
    It occures only with mpeg recordings not with .ts recordings.
    The problem is the tsfile source (async) filter.
    Either MediaPlayerClassic nor Windows Media Player are able to play the file while being recorded -> Message: "File is in use".
    VLC plays fine.
    So no problem with MP itself.
    Checking the microsoft knowledge base
     
  8. gemx
    • Premium Supporter

    gemx Retired Team Member

    Joined:
    October 31, 2006
    Messages:
    1,972
    Likes Received:
    541
    Ratings:
    +541 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Nothing on the microsoft sites BUT
    replaying the file via the tsfilesource filter works even during playback :)
    So we just have to change the method where the graph is built to use TSFileSource instead of "File Source (async.)"
     
  9. The_Stig
    • Premium Supporter

    The_Stig Retired Team Member

    Joined:
    April 5, 2005
    Messages:
    2,176
    Likes Received:
    288
    Ratings:
    +426 / 5
    Hi gemx,

    thats sounds nice. Thanks for your work!

    Regards,

    The Stig (aka paloema)
     
  10. gemx
    • Premium Supporter

    gemx Retired Team Member

    Joined:
    October 31, 2006
    Messages:
    1,972
    Likes Received:
    541
    Ratings:
    +541 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Ok. Found the bug :)
    TSFileSource is already used for mpeg files but the CheckMpgFile() method of the PlayerFactory class raises an exception because it can't access the file. So it returns "false" which means that it is not a valid mpeg file.
    So the playerfactory creates a Videoplayer which uses the microsoft file source which can't replay the file.
     
  11. gemx
    • Premium Supporter

    gemx Retired Team Member

    Joined:
    October 31, 2006
    Messages:
    1,972
    Likes Received:
    541
    Ratings:
    +541 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Alright, fixed it :)
    It should be working in the actual snapshot rev. 13518 ;)
    Please provide some feedback if it's really working as desired.
    Thanks.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!