Playing recorded *.TS files does't work with internal "TsReader.ax" (2 Viewers)

hoborg

Portal Pro
June 13, 2008
4,413
1,644
Nový Jičín
Czech Republic Czech Republic
TV-Server Version:
MediaPortal Version: RC2
MediaPortal Skin: Monochrome
Windows Version: Win XP SP3 EN
CPU Type: MD Athlon 64 X2 4050+ EE
HDD: SSD OCZ Core Series V2 - 30GB system disk+Western Digital Caviar GreenPower 3.5" 1TB WD10EACS
Memory: 2GB
Motherboard: ASUS M3A78-EMH HDMI
Video Card: on board
Video Card Driver: Catalyst 8.4
Sound Card: on board
Sound Card AC3:
Sound Card Driver:
1. TV Card: AVerTV Hybrid Speedy
1. TV Card Type:
1. TV Card Driver:
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: PoverDVD 8.0
MPEG2 Audio Codec: MpaDecFilter.ax 1.1.604
h.264 Video Codec: MPCVideoDec.ax 1.1.604
Satelite/CableTV Provider:
HTPC Case: Antec Fusion V2 (silver)
Cooling: Passive
Power Supply:
Remote:
TV: Hyundai Q320
TV - HTPC Connection: HDMI

Look on it here:
https://forum.team-mediaportal.com/offtopic-57/stand-alone-filters-htpc-44614/index3.html#post304989

I renamed *.ts file to *.MP4/*.MKV - this will disable TsReader.ax and TS file are processed by Haali - it works OK.
TsReader.ax cannot play this *.ts file.
 

tourettes

Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    If TsReader is disabled then no wonder its not working :). Currently .ts files require TsReader (no Haali support on MP side for .ts).
     

    hoborg

    Portal Pro
    June 13, 2008
    4,413
    1,644
    Nový Jičín
    Czech Republic Czech Republic
    If TsReader is disabled then no wonder its not working :). Currently .ts files require TsReader (no Haali support on MP side for .ts).
    TsReader is not disabled! (Just did fresh instal of MP + latest build).
    No luck to play this ts file: http://www.megaupload.com/?d=9TIJ68KM
    I need to rename ts to MP4/MKV to disable "TsReader.ax" and make it work thrue Haali.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    If TsReader is disabled then no wonder its not working :). Currently .ts files require TsReader (no Haali support on MP side for .ts).
    TsReader is not disabled! (Just did fresh instal of MP + latest build).
    No luck to play this ts file: MEGAUPLOAD - The leading online storage and file delivery service
    I need to rename ts to MP4/MKV to disable "TsReader.ax" and make it work thrue Haali.
    Works here with TsReader without any issues. PDVD8 video codec + ffdshow audio codec. Please make sure that other .ts files are working correctly (that would rule out that the TsReader is not registerd or is from different SVN version than MP itself.)

    Its possible that MPC-HT h264 decoder is not connecting to the TsReader's video output pin.
     

    pvkleeff

    Portal Member
    July 18, 2007
    32
    5
    46
    Roosendaal
    Netherlands Netherlands
    The MPC-HC standalone codec has never worked with the tsReader for H.264 video. Simply because this type of video gets a GUID of {8D2D71CB-243F-45E3-B2D8-5FD7967EC09B} which the codec doesn't accept as an input.

    I've asked Casimir (developer of MPC-HC) to add this GUID to the list so the file would be able to play. Today I tested a version of the coed which accepts this GUID. The file starts playing but at a very low framerate (in sw mode).
    When I activated DXVA the file starts skipping frames like crazy and ultimately stops.

    I hope that Casimir can find the problem and we can simply start using one codec (with HW accell) for all video files.
    But I think that some properties of the video file are not correct in tsReader as well. For instance, the aspect ratio is incorrectly detected, The video pin out gives me values of dwAspectRatioX 10, dwAspectRatioY 9, but the file is 1280x720 (correctly detected), 16:9 ratio !

    So, all in all I think the problem lies on both sides.

    To be continued...
     

    hoborg

    Portal Pro
    June 13, 2008
    4,413
    1,644
    Nový Jičín
    Czech Republic Czech Republic
    The MPC-HC standalone codec has never worked with the tsReader for H.264 video. Simply because this type of video gets a GUID of {8D2D71CB-243F-45E3-B2D8-5FD7967EC09B} which the codec doesn't accept as an input.

    I've asked Casimir (developer of MPC-HC) to add this GUID to the list so the file would be able to play. Today I tested a version of the coed which accepts this GUID. The file starts playing but at a very low framerate (in sw mode).
    When I activated DXVA the file starts skipping frames like crazy and ultimately stops.

    I hope that Casimir can find the problem and we can simply start using one codec (with HW accell) for all video files.
    But I think that some properties of the video file are not correct in tsReader as well. For instance, the aspect ratio is incorrectly detected, The video pin out gives me values of dwAspectRatioX 10, dwAspectRatioY 9, but the file is 1280x720 (correctly detected), 16:9 ratio !

    So, all in all I think the problem lies on both sides.

    To be continued...
    Thanks for info.:D
     

    gemx

    Retired Team Member
  • Premium Supporter
  • October 31, 2006
    1,972
    539
    Germany Germany
    The MPC-HC standalone codec has never worked with the tsReader for H.264 video. Simply because this type of video gets a GUID of {8D2D71CB-243F-45E3-B2D8-5FD7967EC09B} which the codec doesn't accept as an input.

    I've asked Casimir (developer of MPC-HC) to add this GUID to the list so the file would be able to play. Today I tested a version of the coed which accepts this GUID. The file starts playing but at a very low framerate (in sw mode).
    When I activated DXVA the file starts skipping frames like crazy and ultimately stops.

    I hope that Casimir can find the problem and we can simply start using one codec (with HW accell) for all video files.
    But I think that some properties of the video file are not correct in tsReader as well. For instance, the aspect ratio is incorrectly detected, The video pin out gives me values of dwAspectRatioX 10, dwAspectRatioY 9, but the file is 1280x720 (correctly detected), 16:9 ratio !

    So, all in all I think the problem lies on both sides.

    To be continued...
    Would be cool if you could upload a sample video to check what tsreader detects or why it detects the wrong aspect ratio.

    Nevertheless all other h264 decoder filters work with TsReader afaik
     

    pvkleeff

    Portal Member
    July 18, 2007
    32
    5
    46
    Roosendaal
    Netherlands Netherlands
    Would be cool if you could upload a sample video to check what tsreader detects or why it detects the wrong aspect ratio.

    Nevertheless all other h264 decoder filters work with TsReader afaik
    I'll try to upload a sample of the file I use for testing (need to cut it though since the file is more than 5 Gb :) tonight.

    The problem is purely between TsReader and the MPC-HC codec, and I still can't figure out why.
    When I create a graph using Haali as file splitter and MPC as codec the file plays fine.
    When I create a graph using TsReader and Cyberlink or Arcsoft as codec the file plays fine.
    Only when I create the graph using TsReader and MPC it doesn't work.

    Maybe the other codecs simply ignore the flags TsReader gives them (like the aspectratio etc) and check the file on their own, whereas the MPC codec relies on these flags ?
     

    kiwijunglist

    Super Moderator
  • Team MediaPortal
  • June 10, 2008
    6,746
    1,749
    New Zealand
    New Zealand New Zealand
    Country flag

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    OP Similar threads Forum Replies Date
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    A Server going to sleep whilst playing recorded TV General Support 4
    N [confirm] Playing a recording, then pressing stop does not leave cursor on the recording MediaPortal 2 21
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    framug RED DOT recording state doesn't appear in video fullscreen playing 1.21 256
    porky996t Still Unable to play Live or Recorded TV General Support 4
    D [solved] Initital testing with second client - cannot play recorded TV General 33
    P Video and audio stutters after playing TV recording for few minutes 1.19 0
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    2BitSculptor MP 1.23.. music stops playing General Support 6
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    Similar threads

























    Top Bottom