[Plugin] MPSync - MediaPortal multi-seat Synchronization | Page 8

Discussion in 'MediaPortal 1 Plugins' started by m3rcury, March 17, 2013.

  1. bob808
    • Premium Supporter

    bob808 MP Donator

    Joined:
    June 14, 2008
    Messages:
    295
    Likes Received:
    16
    Gender:
    Male
    Location:
    Hampshire
    Ratings:
    +17 / 0
    Home Country:
    United Kingdom United Kingdom
    I installed v 0.0.5 yesterday and managed to sync all my databases and my thumbs ok from my master pc. That worked fine (auto syncing not through settings panel).



    Today I installed 0.0.6 on one of my client machines - it seems to sync on but when it finishes it crashes - this happens in mediaportal itself if left to auto run, or if I manually run from settings panel. I just get a media enter had stopped responding error and if I click ok it closes.

    With 0.0.5 on the client I only tried in settings and it ran with no end just the spinner - I assumed that this was the bug you fixed in v6 but that doesn't seem to be the case.

    Anyone else getting this? Do you need logs (if so what ones)


    Final query - I have a main box that is a client and server and 3 clients - should I set all to a 2 way sync to ensure that any views on a machine are pushed to the rest as it looks like if I setup as per guidance then it's a one way update only?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    522
    Gender:
    Male
    Ratings:
    +620 / 4
    Home Country:
    Malta Malta
    Show System Specs
    bob808, if possible, can you upload your MPSync.xml and MediaPortal.log.

    As to the spinner when running from the plugin, it does go to Not Responding, depending on the size of your DB and thumbs folders, but eventually it finishes, at least, it does on my setup ;).

    For the 2 way sync, at the moment am looking at how to fine-tune it as I don't like it the way it is coded. One way sycn is fine, but am a bit uncertain on the 2 way one :unsure:.
     
  4. alturismo

    alturismo Portal Pro

    Joined:
    July 28, 2009
    Messages:
    121
    Likes Received:
    7
    Ratings:
    +9 / 2
    Home Country:
    Germany Germany
    may a little question before i try further tracking down why theres nothing happening here

    my setup looks like this

    Server PC with MP and TV Server installed, all media is there ... running MP there only for MPExtended to get to my shares for mobile watching
    2 clients used for watching tv and media

    main intention is i would like to stop a movie on client 1 and continue on client 2 at the last point without skipping manually to there,
    example, i start a movie and after 25 mins i move to bedroom, there i would like to continue with manually jumping to 25 min ...

    so i thought this addon could be a nice solution cause the "bad multi seat setup" likes to crash ;)

    if that should be supported with this central db plugin may a hint what could be the reasen theres nothing copied to "server" database folders ...

    eithere i use \\server adressing nor direct adressing ...

    configuration.log when i start manually inside plugin configuration

    2013-03-27 07:01:00.910699 [Info.][Config Main(1)]: MPSync: process plugin initialisation.

    thats it

    my xml looks like

    <?xml version="1.0" encoding="utf-8"?>
    <profile>
    <section name="Plugin">
    <entry name="version">0.0.0.6</entry>
    <entry name="databases">True</entry>
    <entry name="thumbs">True</entry>
    </section>
    <section name="DB Path">
    <entry name="client">C:\ProgramData\Team MediaPortal\MediaPortal\database</entry>
    <entry name="server">D:\Mediaportal\MPSync\database</entry>
    <entry name="direction">0</entry>
    <entry name="method">0</entry>
    </section>
    <section name="DB Settings">
    <entry name="sync periodicity">15</entry>
    <entry name="sync periodicity value">minutes</entry>
    <entry name="pause while playing">False</entry>
    </section>
    <section name="Thumbs Path">
    <entry name="client">C:\ProgramData\Team MediaPortal\MediaPortal\thumbs</entry>
    <entry name="server">D:\Mediaportal\MPSync\thumbs</entry>
    <entry name="direction">0</entry>
    <entry name="method">0</entry>
    </section>
    <section name="Thumbs Settings">
    <entry name="sync periodicity">15</entry>
    <entry name="sync periodicity value">minutes</entry>
    <entry name="pause while playing">False</entry>
    </section>
    </profile>

    also when i let mediaportal run for some time nothing happpens

    may a hint where to look whathappens ?

    thanks ahead ;)
     
  5. bob808
    • Premium Supporter

    bob808 MP Donator

    Joined:
    June 14, 2008
    Messages:
    295
    Likes Received:
    16
    Gender:
    Male
    Location:
    Hampshire
    Ratings:
    +17 / 0
    Home Country:
    United Kingdom United Kingdom
    OK - updated my main pc to .0.0.6 today and it now crashes mediaportal like on my client... so seems to be something in this new code... logs attached.
     

    Attached Files:

    • MPSync.xml
      File size:
      1.2 KB
      Uploaded:
      March 27, 2013
      Views:
      67
  6. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    522
    Gender:
    Male
    Ratings:
    +620 / 4
    Home Country:
    Malta Malta
    Show System Specs
    All, an updated version MPSync v0.0.0.7 Beta has just been released which contains enhanced error trapping and slight synchronization improvements when inserting a record and it already exists.

    You can download from repository link in post #1.

    Thanks
     
    Last edited: March 27, 2013
    • Like Like x 1
  7. dyamant

    dyamant Portal Pro

    Joined:
    July 31, 2007
    Messages:
    401
    Likes Received:
    32
    Location:
    Castrop-Rauxel
    Ratings:
    +36 / 1
    Home Country:
    Germany Germany
    Show System Specs
    I try now the latest version (0.7). There is no crash anymore. the Programm reports after a few second its finished. But if i look in the destination folder there is nothing copied. Hmmm. I run this test under Win7 (64) and Win8 (64).
     

    Attached Files:

    • MPSync.xml
      File size:
      1.1 KB
      Uploaded:
      March 27, 2013
      Views:
      63
  8. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    522
    Gender:
    Male
    Ratings:
    +620 / 4
    Home Country:
    Malta Malta
    Show System Specs
    dyamant, a stupid question from my side but folder D:\mp\DATABASE does contain the *.db3 files?

    Regarding the thumbs issue, I think I found what the problem is. Will upload a new version that fixes this in a couple of minutes. In the meantime can you check regarding the databases pls.

    Thanks
     
  9. dyamant

    dyamant Portal Pro

    Joined:
    July 31, 2007
    Messages:
    401
    Likes Received:
    32
    Location:
    Castrop-Rauxel
    Ratings:
    +36 / 1
    Home Country:
    Germany Germany
    Show System Specs
    No my Source DB Folder is C:\Programdata\TeamMediaPortal\MediaPortal\Database\
    I ve do anything wrong ?
     
  10. m3rcury
    • Team MediaPortal

    m3rcury Development Group

    Joined:
    August 12, 2010
    Messages:
    954
    Likes Received:
    522
    Gender:
    Male
    Ratings:
    +620 / 4
    Home Country:
    Malta Malta
    Show System Specs
    Ok, and the setup in the xml is correct, but at the moment, the plugin expects that the 2 folders both contain the *.db3 files. Will do an enhancement in the next version to copy over the Dbs if these are missing as it is an issue being encountered quite often.
     
  11. dyamant

    dyamant Portal Pro

    Joined:
    July 31, 2007
    Messages:
    401
    Likes Received:
    32
    Location:
    Castrop-Rauxel
    Ratings:
    +36 / 1
    Home Country:
    Germany Germany
    Show System Specs
    I understand. I test it with database inside the destination.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!