1.12.0 - Recording not acepted

Discussion in 'Archive' started by Brudertac, July 25, 2015.

  1. Brudertac
    • Premium Supporter

    Brudertac MP Donator

    Joined:
    October 26, 2006
    Messages:
    978
    Likes Received:
    117
    Gender:
    Male
    Location:
    Augsburg
    Ratings:
    +277 / 1
    Home Country:
    Germany Germany
    Show System Specs
    MediaPortal Version: 1.12.0

    Description
    Hi all,

    MP 1.12 is installed. Using Titanius Skin.

    This happens sometimes:

    Open the TV Guide and press Record on a Show.
    The Recording Window opens and shows the Show (or more than on of its a Serie)
    Press OK or Record Button on the Show and nothing happens.

    If i reminds me correct after a restart it works again. (Can´t test this right now because the PC is in use :)



    Log are attached.

    EDIT: Note to Siteadmin, the Bugreport Form does not allow to Upload Files.

    EDIT 2: Should added mor Details when this Happens or not? :)
    Please see the Logfiles today (25.07.2015) at 19:19:05

    The Error is:

    Code (Text):
    1. [2015-07-25 19:19:05,712] [Log    ] [MPMain   ] [DEBUG] - TVProgammInfo.OnRecordProgram - programm = Helena Fürst – Kämpferin aus Leidenschaft(ID:12811646) on 361 26.07.2015 19:05:00 - 26.07.2015 20:15:00
    2. [2015-07-25 19:19:05,742] [Error  ] [MPMain   ] [ERROR] - OnMessage exception:System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    3.    bei TvPlugin.TVProgramInfo.OnRecordProgram(Program program)
    4.    bei TvPlugin.TVProgramInfo.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
    5.    bei MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    Thanks!
    Brudertac

    Steps to Reproduce:
    See Description itself.
     

    Attached Files:

    Last edited: July 25, 2015
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hello! :)

    I needed your MediaPortal.xml to confirm, but I think the reason was that MediaPortal did not have a "current channel"...

    Regards,
    mm
     
    • Like Like x 1
  4. Brudertac
    • Premium Supporter

    Brudertac MP Donator

    Joined:
    October 26, 2006
    Messages:
    978
    Likes Received:
    117
    Gender:
    Male
    Location:
    Augsburg
    Ratings:
    +277 / 1
    Home Country:
    Germany Germany
    Show System Specs
    Good Morning! :)

    XML is added to first Post. If you are right, what can i do? :)

    Brudertac
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Thanks :)

    I think I may have been wrong, because:
    Did you view a channel after attempting to start the recording?
    Is the problem still happening?
     
  6. Brudertac
    • Premium Supporter

    Brudertac MP Donator

    Joined:
    October 26, 2006
    Messages:
    978
    Likes Received:
    117
    Gender:
    Male
    Location:
    Augsburg
    Ratings:
    +277 / 1
    Home Country:
    Germany Germany
    Show System Specs
    We watched another Channel while we tried to set the Recording.

    Have tested it right now and now it works.

    - Test to setup a Record without another Channel running is fine.
    - Test to setup a Record while watching another Channel is also fine.

    But this was also the Problem in the Past. This happens just sometimes...
     
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hmmm, I suspected this.
    Next time it happens, please go to the TV home section and check if there is a channel selected. I suspect there will not be. Then if you select a channel (ie. start watching any channel), the problem will go away.
     
  8. Brudertac
    • Premium Supporter

    Brudertac MP Donator

    Joined:
    October 26, 2006
    Messages:
    978
    Likes Received:
    117
    Gender:
    Male
    Location:
    Augsburg
    Ratings:
    +277 / 1
    Home Country:
    Germany Germany
    Show System Specs
    You mean if a Channel is already running at the Time it should work? That was the Situation yesterday.... Watched one Channel, going into the Guide while watching that Channel and trying to setup a Recording...
     
  9. alexfon
    • Premium Supporter

    alexfon MP Donator

    Joined:
    July 10, 2011
    Messages:
    96
    Likes Received:
    15
    Ratings:
    +23 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I have had exactly the same issues a few times now.
     
  10. Brudertac
    • Premium Supporter

    Brudertac MP Donator

    Joined:
    October 26, 2006
    Messages:
    978
    Likes Received:
    117
    Gender:
    Male
    Location:
    Augsburg
    Ratings:
    +277 / 1
    Home Country:
    Germany Germany
    Show System Specs
    At last i am not alone with this. :)
     
  11. sunflower

    sunflower Portal Pro

    Joined:
    February 28, 2007
    Messages:
    184
    Likes Received:
    4
    Location:
    Cologne
    Ratings:
    +7 / 0
    Home Country:
    Germany Germany
    Show System Specs
    No, you're not. ;)I got the same problem from time to time.
    A - somewhat strange - solution: If nothing happens when you press the OK or record button, use the menu, choose 'advanced recordings', then 'only once' and - wow - the red ball indicates that the recording has been successfully scheduled.
    This might be a hint for someone who knows the internals better than I do.
    (I experienced this with Titan, Default Wide und now with Streamed MP.)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!