Recordings not working BUT Video is OK (1 Viewer)

joEhSuper

MP Donator
  • Premium Supporter
  • June 2, 2011
    768
    332
    Austria Austria
    Country flag
    I am very confused :confused::confused::confused:
    When I try to playback recorded TV --> I only get bricks and squeakings
    22-08-17.png
    When I do play the SAME file with Video-Module --> The file is being played perfectly....

    Example (LOG):
    First I tried to play the recorded File --> Fußball (LIVE) - ORF eins within TV-Module
    than same file within Video-Module...

    edit:
    of course important: File is stored on TV-Server, I'm trying to playback from client...
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    When I do play the SAME file with Video-Module --> The file is being played perfectly....
    It looks like the difference between RTSP (TV plugin) - which is true streaming - and UNC (video plugin) - which is more regular playback.

    TsReader log file shows lots of continuity errors when you play the recording with the TV plugin, and none when you play it with the video plugin.

    Looks like you may be using a wireless network connection between server and client. Perhaps buffer configuration could do with a tweak:
    [2017-07-26 22:07:33,229] [1b4b5438] [22f0] - --- Buffering delay = 0 ms

    The other thing to check is that security software on the server side is not causing trouble for TV Server's file access.
     

    joEhSuper

    MP Donator
  • Premium Supporter
  • June 2, 2011
    768
    332
    Austria Austria
    Country flag

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    where can I change this?
    It's probably a registry setting.

    @Owlsroost ?

    ...but my advice would be to check that the server side is okay first.

    Given that there are continuity errors, it seems like data is actually lost not just late. That seems more like what I've seen with security software config problems.

    So, like I said: check that security software config on the server side is not causing file access problems for TV Server's streaming server component. UNC (video plugin) uses ["direct"] file access via network share (SMB/SAMBA) whereas RTSP needs the streaming server to read the file and send it to the client.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    It's probably a registry setting.
    It's at: HKEY_CURRENT_USER\Software\Team MediaPortal\TsReader\BufferingDelayInMilliSeconds

    Default value is 0, range is 0 to 5000 (in milliseconds). Make sure you view the setting in decimal in Regedit. I'd suggest trying 500 then 1000, but if you are getting continuity errors with RTSP it usually indicates packet loss in the network, so extra buffering may not help (and it will increase channel change times).

    You can also run multi-seat TV in 'UNC paths' mode (like how remote video file playback works) if you want to try it - see Advanced Options - MediaPortal 1 - MediaPortal Wiki (the 'Multi seat setup: use UNC paths' option).
     

    joEhSuper

    MP Donator
  • Premium Supporter
  • June 2, 2011
    768
    332
    Austria Austria
    Country flag
    Testing Multi Seat Setup with UNC-Paths - so far works great!:D:D:D
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,219
    New Zealand New Zealand
    Country flag
    @joEhSuper
    Great that you have a solution... but I'd strongly suggest you still try to get RTSP working. It's not that RTSP is better. Rather, if the source of the problem is security software config, it may cause other side effects like corrupted recordings. Therefore in my opinion it's important to really solve the problem, not just apply a workaround.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    B MP 1.23 First time click TV or Recorded TV fails, 2nd ... it will work General Support 5
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    N [Finished] [MP2-789] MCE remote control Recorded TV and My Pictures buttons do not work MediaPortal 2 17
    A "upcoming episodes" arrow key set recording - Ok/rtn doesn't work General Support 9
    Wampus [MP2-752] Record-Button not working on the fly General 7
    J Recorded TV to NAS no longer working after Windows build 1803 1.19 6
    D wintv doesn’t stop recording on time Newcomers Forum 1
    P Blocking TV recordings on client? General 5
    1gkar [solved] LiveTV Records Causing 100% Drive Activity Television (MyTV frontend and TV-Server) 10
    toricred Recordings Change : to _ in Series Name General 0
    P Recording films that have an "intermission" General 3
    H MP2 database won't keep in synch with recordings General 8
    toricred Only Show Actual Recordings General 1
    ajs How recreate Recording thumbs TV-Server 4
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    CyberSimian [Proposal] Tool to display time of next recording MediaPortal 1 0
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    R [solved] Unable to delete single recording General 2
    R Correct setting for recordings on shared folder General 0
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    S Shortcuts MP1 My Recorded & TV Guide General 10
    F How to reset tv recordings database General 5
    P Recordings not showing up unless re-imported and not possible to delete General 0
    X Recording import hängt Allgemeines Support- und Diskussionsforum 0
    Similar threads

























    Top Bottom