Resume from Standby Last Module TV Showing TV Server Settings (2 Viewers)

John0502

Portal Member
May 2, 2011
28
6
Country flag
Hello,

I have MP 1.22 freshly installed on a Windows 10 x64, Ver 1903. This was an upgrade from WIndows 10 x32. When I setup the Resume from standby, with last module running (do not recall the exact name), I press the remote button to put the HTPS profiled (Single seat setup) computer to sleep. When I wake it up, it tries to start up the TV (the last module running before going to sleep), however, I get the TV server configuration screen requesting to confirm settings. If I quickly select the current, listed settings, I get the same screen pop up. Waiting around 10 or so seconds, and going to TV, it starts the TV fine. This also happens when turning on the computer first and starting MP, if the last saved module was TV, it does the exact same thing. The issue is not restricted to start from resume only. I have tried a loopback address adapter for TV and TimeShift is on a local disk.

I have turned off many plugins (do not have that many), but the issue persists. If I start MP, when stopped on a non-TV module (Movies screen etc), then it comes back Ok on that screen.

It appears that the TV service take a little longer to be picked up by Mediaportal on any startup, if TV was the last module when shutdown, then it will try to startup on TV and fails. After some seconds TV works fine.

Is there something I have missed in my configiration that wil contribute to this issue? I also have to use the feature 'FCU fix for black screen...' since on WIndows 10 (since migrating from Windows 7 SP1) never restarts on a MP screen - only a black screen without this option set.

I am happy to post logs, not near the computer now, but happy to do so later. Will the MP and TV logs help?

Regs,
John
 

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,105
    1,305
    Southampton
    United Kingdom United Kingdom
    Country flag
    however, I get the TV server configuration screen requesting to confirm settings.
    I can confirm that this happens :(. On Windows 7 using MP 1.22f+ with my "ClassicWide" skin I get this panel:

    tv_server_settings.jpg

    On the "Startup/Resume Settings" panel in "MP Config", there are these settings (identified in red):

    startup_resume_4.JPG

    However, a delay of 5 seconds did not change behaviour, and neither did a delay of 10 seconds. In both cases there is a "long" wait with a black screen. For the 10 second delay, the black screen lasted about 15 seconds on my system. I think that this is poor usability :(. As a user, I would rather that the MP "Home" panel appeared immediately and I then navigated manually to the "TV Home" panel and started live TV. But you are allowed to have a different preference :D.

    Whatever your preference, I am not aware of any workaround for this problem, and I think that it is unlikely to be fixed in the near future. So you will need to decide which compromise is the "least worst" for the people who use your system. I would probably disable the "Show last active module when resuming" setting :unsure:.

    -- from CyberSimian in the UK
     

    John0502

    Portal Member
    May 2, 2011
    28
    6
    Country flag
    Hi CyberSimian,

    I have concluded the same thing. Disabled "Show last active module when resuming" and go to TV after starting up in the Home screen.
    Would be nice if it could start on TV (if that's where MP was when put to sleep), just like my older Panasonic PVR. But this workaround is reasonable.

    I will add that sometimes, even starting on the Home screen and waiting a few seconds, it sometime goes to that TV config screen. But that is rare. Now, when I start TV from the resumed to home screen, it often goes briefly to TV and drops out to the TV screen where you can set up recordings etc and have the smaller TV screen right of those options - with the TV off. I start the TV and go to full screen without issue when this occurs.

    Happy to keep using this way.

    John
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    HTPCSourcer [fixed] [MP2-815] User not logged in when resuming from standby MediaPortal 2 17
    S Resume Playback Annoyance Newcomers Forum 4
    joecrow MP 1 Hangs on resume fro sleep (TV) Watch / Listen Media 2
    joecrow 1.25.0 Radio Time plugin fails after Resume from Sleep with MP 1.25 Bugreports 10
    F After resume, TV Server connection screen is shown General Support 4
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    P MP2 Client Screen Flickering on Resume General 2
    R Media portal resumes with wrong screen resolution General Support 3
    B resume from within a folder Watch / Listen Media 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    R Weird sleep/resume loop General Support 4
    joecrow Further problem on resume from sleep (MP Crash) 1.21 5
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    D [further infos missing] Problems switching to live tv channel after resume 2.2 Archive 1
    stirlinghart [duplicate] Mp not focused on after resuming from sleep 2.2 Archive 7
    P Multiple clients - share resume/watched data General 1
    M MP2 PROBLEME Standby Allgemeines Support- und Diskussionsforum 1
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    H no standby at night Installation, configuration support 7
    J Mediaportal Standby prevented by Mediaportal system/ active ports General Support 13
    H TV nach Standby 1.21 5
    H TV nach Standby 1.21 Pre Release 2
    A Keine Aufnahmen nach Standby Allgemeines Supportforum 12

    Similar threads

    Top Bottom