Scrolling (patch included in MediaPortal RC2) | Page 2

Discussion in 'Moving Pictures' started by leftfield, February 15, 2010.

  1. armandp
    • Premium Supporter

    armandp Retired Team Member

    Joined:
    April 6, 2008
    Messages:
    990
    Likes Received:
    584
    Gender:
    Male
    Occupation:
    Application Designer
    Location:
    Zoetermeer
    Ratings:
    +616 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Re: Scrolling

    @ leftfield

    i do see something that might slowdown the scrolling and was not intended.. from the logs it looks like it is recomputing the filehash for every ISO when selected.

    Can you do a quick test for me?
    Create a category without ISO's in it and see if scrolling is faster then.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mat123

    mat123 Portal Pro

    Joined:
    February 28, 2009
    Messages:
    102
    Likes Received:
    19
    Gender:
    Male
    Ratings:
    +19 / 0
    Home Country:
    Slovenia Slovenia
    Show System Specs
    Re: Scrolling

    Hi, armandp,

    I can attach logs, if you can tell me how to start Mediaportal in Debug mode?

    EDIT: Here are the logs, if it helps.
     
  4. TheBiGW

    TheBiGW Portal Member

    Joined:
    October 1, 2009
    Messages:
    43
    Likes Received:
    5
    Ratings:
    +5 / 0
    Home Country:
    United Kingdom United Kingdom
    Re: Scrolling

    I also have this problem. I'm using an Asrock ION 330. My TV Series and scrolling around the other menus all work flawlessly and it is smooth as silk. However, as soon as I go into Moving Pictures there is a lag of ~1 second or so between pressing the button on the remote (or keyboard) and the menu item updating.

    What logs do you want me to capture? I'm even happy to record a quick youtube video of the problem if that will help with the troubleshoot.

    Running the latest 1.1.0 RC, latest StreamedMP RC and the latest Beta 3 of Moving Pictures
     
  5. mat123

    mat123 Portal Pro

    Joined:
    February 28, 2009
    Messages:
    102
    Likes Received:
    19
    Gender:
    Male
    Ratings:
    +19 / 0
    Home Country:
    Slovenia Slovenia
    Show System Specs
    Re: Scrolling

    I've found out that HTPCinfo plugin somehow interferes with MovPic, because it slows down scrolling a lot.
    I removed HTPCinfo and now the scrolling is much better and at least useable, but still not as fluid as with stable MovPic version.
    And I've also gone back to the recommended SVN rev24669 of MediaPortal.

    Just wanted to post this, maybe it helps someone.
     
  6. Micropolis

    Micropolis Portal Pro

    Joined:
    July 22, 2009
    Messages:
    1,586
    Likes Received:
    1,768
    Gender:
    Male
    Occupation:
    Senior Consultant
    Location:
    Bavaria
    Ratings:
    +1,947 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Re: Scrolling

    mat123,
    the HTPCInfo plugin does NOT interfere with this plugin, on my system both plugins live in best freedom.
    To avoid scrolling issues inside MediaPortal or other plugins, please configure the HTPCInfo performance options inside the appropriate configuration dialog, for more informations please consult the manual before.

    Cheers, Micropolis
     
  7. mardup

    mardup Portal Pro

    Joined:
    October 24, 2007
    Messages:
    153
    Likes Received:
    8
    Location:
    Toulouse
    Ratings:
    +8 / 1
    Home Country:
    France France
    Re: Scrolling

    Hello to All
    I also have en Asrock ION 330. Alls scrollings in MP are smooth ( TV series, Myfilms, Music, ... ) except in MovingPictures where it seems to load every info movie (one by one) when I scroll (fast) in list view. Tested with Blue 3 wide et Black Glass > same problem :-(

    ( sorry for my english )
     
  8. leftfield
    • Premium Supporter

    leftfield MP Donator

    Joined:
    July 23, 2008
    Messages:
    29
    Likes Received:
    0
    Ratings:
    +0 / 0
    Re: Scrolling

    Sorry for the delay. Answers below:

    Same problem with 1.0.2. I had tried that already.
    Same problem with Blue3Wide (although ever so slightly less noticable)
    Advanced delay settings - 350

    It is definitely still not a smooth scroll. I would suspect that possibly some people may think that they have a smooth scroll on theirs when I would disagree. I've had people look at mine and not spot an issue. Granted, they are the same people that can't really spot a huge difference with HD over standard def but it just demonstrates that some people accept less quality as satisfactory. Other people have agreed instantly that it's not smooth.

    Trying to understand why TV Series seems to work better and I am now wondering whether it is something as simple as the scroll speed. For instance if two images are moving 5 pixels each frame, one does 5 'moves' a second and the other does 10 'moves'. The 5 one will be noticably more jerky. TV Series scrolls fast, Moving Pictures is slower. Does it just trick the eye better simply for that reason? :confused:

    I have a category that is purely Divx, with no ISOs. Unfortunately same problems.

    A point to note is it isn't just the scrolling but the animations as well. When a DVD cover is highlighted it zooms bigger. Moving Pictures seems to try some kind of animation where the cover goes bigger and slightly to the left before settling a bit to the right (I hope that makes sense!). You can see it best when you first go into your MP category and you navigate between the leftmost 3 covers without causing the the whole list to scroll across. MP TV Series just zooms the DVD cover without any animation I think which just seems to work better.
     
  9. sclaws
    • Premium Supporter

    sclaws MP Donator

    Joined:
    February 7, 2009
    Messages:
    63
    Likes Received:
    4
    Location:
    Chicago western suburbs
    Ratings:
    +4 / 0
    Home Country:
    United States of America United States of America
    Re: Scrolling

    I did not have this issue untill updating to both Mediaportal 1.1.0.0 RC and the latest MovingPictures...but it only happens on my system with an ATI vid card (4650). The system with nVidia GTX 280 has no issues with smooth scrolling in filmstrip view. Not sure where to troubleshoot this one. I tried to go back to the stable Mediaportal and MP 0.7.5 but when i tried to access MovPic's pluging settings it would constantly crash (that didnt happen before...no clue why its doing it now).

    So I'm using the Mediaportal RC and latest MovingPictures because they work, but am not sure how to get my smooth scrolling filmstrip mode back :(
     
  10. FlexQ

    FlexQ Portal Pro

    Joined:
    July 20, 2009
    Messages:
    52
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Denmark Denmark
    Re: Scrolling

    Just want to say that i have the exact same issue.

    Henrik
     
  11. mardup

    mardup Portal Pro

    Joined:
    October 24, 2007
    Messages:
    153
    Likes Received:
    8
    Location:
    Toulouse
    Ratings:
    +8 / 1
    Home Country:
    France France
    Re: Scrolling

    Hello,
    the problem is not only in filmstrip view. As mentionned in my last post, is also in list view.
    If i press "quickly" 10 times the down arrow, about 5 or 6 info movies (and graphics) will be displayed before the 10th movie
    ( In MP TV Series only just the 10th is displayed ... quickly )

    I use Mymovies RC
    In the setup of my movies, i limited the size of covers and artwok
    Perhaps the solution is to find the good parameters in "Artwork Loading Delay" and "Details loadind Delay", but i don't find the good ones.
    Can anybody who don't have my problem in browing movies can give me his parameters

    Thanks !
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!