Selected Different DB, now can't load MP-TVSeries configuration (1 Viewer)

ScottK

New Member
July 20, 2011
2
0
United States of America United States of America
I'm fairly new to the whole MP universe. I tried installing the MP-TVSeries plugin and running the configuration without reading this forum, and apparently managed to screw it up pretty fatally.

I was trying to get it to run against videos that had been added to my MP video library, so I changed the database it was pointing at to VideoDatabaseV5.db3. But then when I closed the configuration and restarted it, it now runs for about a minute or two before crashing. I managed to find the following in the MediaPortal.log file, repeated thousands of times whenever I try to load the configuration screen:

2011-11-23 18:41:57.046875 [Info.][(1)]: SQLiteClient: VideoDatabaseV5.db3 cmd:sqlite3_prepare16:pvm=null err:ERROR detailed:no such table: options query:select value from options where property = 'TraktPassword'

I understand what it's saying - just have no clue how to fix it. I've tried uninstalling and reinstalling the plugin several times. Even tried installing the Trakt plugin separately, thinking it may be the real culprit and allow me to fix the database reference from it's configuration. No luck.

I've dug through the file system, but can't find anywhere that this configuration gets saved. Can anyone point me to what I need to fix, adjust or delete to allow MP-TVSeries to be configured properly. I promise to read the instructions before trying again. :)

Thanks.
 

ltfearme

Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,687
    7,062
    Sydney
    Australia Australia
    Country flag
    Try this:

    1. Close down configuration.
    2. Delete the registry entry HKCU\Software\MPTVSERIES
    3. Delete the file C:\ProgramData\Team MediaPortal\MediaPortal\database\VideoDatabaseV5.db3
    4. Delete the file C:\ProgramData\Team MediaPortal\MediaPortal\database\TVSeriesDatabase4.db3
    5. Now re-open configuration and point your Import Paths to your tv episodes.
     

    ScottK

    New Member
    July 20, 2011
    2
    0
    United States of America United States of America
    Ah, the registry. Didn't even think of that. Turns out the only entry in there is just what I needed - the setting for the db file. I just changed that key back to TVSeriesDatabase4.db3 and that did the trick.

    Thanks for the help. Off to read the directions. :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    L Mediaportal 1.21 and Windows 10: user schedules de-activated when powerscheduler plugin is selected General Support 1
    DHosein MP-TV no longer holding fanart selections My TVSeries 2
    S [fixed] [MP2-611] Teletext subtitles language selection 2.2 Archive 20
    rexdog unhandled exception error, and, no sound on first TV channel selected - fine afterwards General 2
    M Epg selection plugin? Feature Requests 2
    J Bluray playback: How to revert back to Select Play Mode after stopping playback? Watch / Listen Media 2
    ajs LMH need help! Help plz ... How select episodes in Online Rating sort order My TVSeries 21
    J [fixed] Importer confused on specific movies with the same title, different years and different NFO's Submit: Bug Reports 3
    R Files moved to different location - Easy way to update database? Moving Pictures 2
    A Different audio outputs Feature Requests 0
    P Recordings using different tuners? General Support 1
    J Different video and audio streams. OnlineVideos 8
    A resuming series on a different client - no resume option General 2
    B A different TV server configuration error Newcomers Forum 0
    B loading input devices hang General Support 3
    sve1 Invalid DateTime when loading configuration tool Trakt 5
    B [MP2-772-773] improve busy cursor and settings loading Testing Area 10
    Top Bottom