Server service on the service monitor keeps stopping randomly. Client can't see server status.

Discussion in '2.2 Archive' started by Bob C, September 28, 2018.

Thread Status:
Not open for further replies.
  1. Bob C

    Bob C Portal Member

    Joined:
    February 6, 2016
    Messages:
    9
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    MediaPortal 2 Version: 2.2



    Description
    I have had this problem since I installed about 6 Months ago. I think I botched the original setup some how of the server client relationship. I am currently running the 2.2 But this problem existed with at least 2 other versions that I started with.
    So on the Client I can see service monitor in the tray icon when right clicked the start and stop service are grayed out. On the server they show normally and I can start or stop the service.
    The other problem is the server stops this service on its own. And with the service stopped it doesn't record and the client doesn't have access to the server libraries until I restart it.
    Any help is appreciated.
    The auto start is enabled on both systems.

    the 12.40.11 is from the client.
    the 12.42.34 is a client and server setup

    Steps to Reproduce:
    It does seem that if the client locks up for any reason I will find the server service stopped.
     

    Attached Files:

    Last edited by a moderator: October 5, 2018
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,513
    Likes Received:
    1,106
    Gender:
    Male
    Ratings:
    +2,374 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Did you ever try to reinstall? You could do an uninstall, which keeps your databases, and then reinstall both server and client.

    Where do you see this? There is no indication of the server service being stopped in the event logs.

    What could be a real problem is your analogue TV card. Analogue cards are known to cause trouble and the observed instability could simply be a driver issue.

    Last not least there could be some UPnP network trouble:
    Since you've been having these issues a long time now, you could test the behavior with a clean install:

    1. Server/Client
    • From the TV configuration export your TV channels/groups/etc.
    • Stop the MP2 Server service
    • Go to your ProgramData folder and move the TeamMediaPortal section of MP2 to another location
    • Uninstall MediaPortal
    • Reinstall MediaPortalpre
    • From the TV configuration import the previously saved TV channels/groups/etc.
    • You will need to recreate any share that you have been using
    2. Remote Client
    There is not much that you can save on the client but you lose your watched status.
    Uninstall the software
    Move the MP2 section in ProgramData away so that you can retrieve it if required later
    Reinstall MP 2.2pre

    You should be done in less than 20 minutes. Check out if this cures the service monitor thing.
     
  4. Bob C

    Bob C Portal Member

    Joined:
    February 6, 2016
    Messages:
    9
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Okay I did a complete Uninstall and reinstall with above directions. From the client I see this upload_2018-10-1_16-33-2.png Is this normal client operation?

    I wont know for awhile if the server stop service happens so I have to use this window from the server to start the service.

    I will run for a day or 2 and upload new logs if the service stops on its own.

    Thanks for the help.
     
  5. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,513
    Likes Received:
    1,106
    Gender:
    Male
    Ratings:
    +2,374 / 21
    Home Country:
    Germany Germany
    Show System Specs
    Yes, it is.

    The MP2 Server service should start automatically together with Windows. Verify its settings in the Windows service overview.
     
  6. Bob C

    Bob C Portal Member

    Joined:
    February 6, 2016
    Messages:
    9
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    So far so good. No random stops after the new install.

    The MP2 Service is running and set to automatic.
    upload_2018-10-4_16-1-43.png
     
    • Like Like x 1
  7. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,513
    Likes Received:
    1,106
    Gender:
    Male
    Ratings:
    +2,374 / 21
    Home Country:
    Germany Germany
    Show System Specs
    In a different thread a solution for sudden service stop was to assign a fixed IP to the server PC and then set it up in the MP2 server settings instead of the "auto" entry. Something that you could try if the issue reappaears.

    Meanwhile I'll mark this thread as solved.
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!