Service using excessive CPU

Discussion in 'MPExtended' started by DragonQ, July 3, 2013.

  1. DragonQ

    DragonQ Portal Pro

    Joined:
    August 30, 2011
    Messages:
    644
    Likes Received:
    61
    Ratings:
    +74 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Twice now I've remoted into my Windows Server 2012 machine, which is running MP TV-Server, and found MPExtended.ServiceHosts.CoreService using 70+% CPU. Stopping and starting the MPExtended service fixes this but I don't know how long for.

    Considering the MPExtended logs show absolutely nothing for the past few days, where do I even start troubleshooting this? I very rarely use MPExtended or WebMediaPortal, only really for setting up recordings remotely, but I haven't done that in at least a week.


     
    Last edited: July 3, 2013
    • Agree Agree x 1
    • Missing System Logs and/or Specs Missing System Logs and/or Specs x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Lyfesaver74
    • Team MediaPortal

    Lyfesaver74 Public Relations

    Joined:
    September 25, 2010
    Messages:
    1,544
    Likes Received:
    890
    Location:
    Texas
    Ratings:
    +1,093 / 3
    Home Country:
    United States of America United States of America
    Show System Specs
    Please include your logs =)
     
  4. DragonQ

    DragonQ Portal Pro

    Joined:
    August 30, 2011
    Messages:
    644
    Likes Received:
    61
    Ratings:
    +74 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    OK but I really can't see anything.
     
  5. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Interesting, that shouldn't happen. Do you have a date and time of when this happened? Does the event log say anything? Does it happen after you do something specific or just random? Next time, it'd be useful if you could post the information the task manager gives as well (I'm mainly interested in thread count).

    The best way to troubleshoot this is to attach Visual Studio to the process and check what is happening, but that is hard to do if you're not a developer. If I can reproduce it myself, then I can do that though...
     
    Last edited: July 14, 2013
  6. DragonQ

    DragonQ Portal Pro

    Joined:
    August 30, 2011
    Messages:
    644
    Likes Received:
    61
    Ratings:
    +74 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    All I know is it happened some time between 30/06/2013 and 03/07/2013 and I cannot think of anything unusual I did during that time. I connected via VPN and it made several recordings but this happens regularly (and has happened today yet hasn't caused the issue again). I did not note the thread count in Task Manager.

    No idea what to even look for in Event Viewer - a search for "extended" produces no results except stopping and starting of the MPExtended service. There's only one warning during the period stated above and that's to do with name resolution of "kastatic.com".
     
  7. DragonQ

    DragonQ Portal Pro

    Joined:
    August 30, 2011
    Messages:
    644
    Likes Received:
    61
    Ratings:
    +74 / 2
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Happened again. Thread count was 240, CPU usage was ~80% and I noticed that when I stopped the service, the number of TCP connections dropped from nearly 500 to ~50.
     
  8. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    Interesting. I'm going to see if I can find a way to get some more diagnostics out of it.
     
  9. zetus

    zetus Portal Member

    Joined:
    August 1, 2008
    Messages:
    33
    Likes Received:
    2
    Ratings:
    +4 / 0
    Home Country:
    Denmark Denmark

    My situation is the same as DragonQ, exept that my system is running server/client on the same mashine, and I am using Argus-TV.
    I have had this issue several times, but I thought it was because off some 'other' SW that I had installed. I just restored my system, (without analyzing further, problem gone). But today, with a system untouched for a month, it suddenly happened again, MPExtended.ServiceHosts.CoreService using 60+% CPU.

    (I installed the AirServer several times, which pre-requisites 'Bonjour Print Services'. This setup could provoke the above issue, and I thought this was "the problem", but after reading about the same issue in DragonQ's post, I am not sure anymore......)
     
    • Agree Agree x 1
  10. zetus

    zetus Portal Member

    Joined:
    August 1, 2008
    Messages:
    33
    Likes Received:
    2
    Ratings:
    +4 / 0
    Home Country:
    Denmark Denmark
    Which OS are you using?
    I'm running Windows 7 64bit.
    If you suspect Bonjour, you can disable the Bonjour-integration for MPExtended in the configuration.
    Okey, I will try that.

    I've had some other reports of it, but I've no clue what causes this (and don't experience it myself either), so I'm afraid I can't help here.
    Okey, I will disable 'Bonjour', and see what happen.

    I like your 'MPExtended' a lot, to stream my videos and music. As mentioned in an earlier post, I'm using Argus-TV, so if you implement compability for that, we call it even...:) (y)
     
  11. Oxan
    • Team MediaPortal

    Oxan Retired Team Member

    Joined:
    August 29, 2009
    Messages:
    1,730
    Likes Received:
    1,024
    Gender:
    Male
    Ratings:
    +1,115 / 2
    Home Country:
    Netherlands Netherlands
    I've split the issues regarding excessive CPU usage out to a new thread, since discussing this inline in another thread isn't that efficient.

    I haven't had time to deep dig into this due to the 0.5.4 release, but now that it's out, I'm going to look at this bug. Expect news in a week or so ;)
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!