Solution for ALL/most Software-encoder based TV-Cards

gossman

New Member
May 24, 2014
11
1
50
I have not been able to get the encoders to install I put the MPEG Encoder Package in the program files folder (tried C:\Program Files\MPEG Encoder Package (win 8) and C:\Program Files (x86)\MPEG Encoder Package). Didn't appear to work when I did the install. I clicked on the install button for each of the encoders. I have also installed the drivers for my AverMedia m791 card. But MP does not load the encoders. Says none of the software encoders are installed.

ahhhh .... just for others, I got them to install b putting the MPEG Encoder Package in C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server\MPEG Encoder Package

now I see the software encoders listed in TvServer but the setup of m AverMedia card still fails.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    @gossman
    Refer to my reply in the other thread to understand why your AVerMedia card is still failing. It still has nothing to do with software encoders. I'm only commenting here to let you know that moving the encoder folder around is not a good idea, especially after installing it. Select any folder you like (it does not have to be a sub folder of any Team MediaPortal folder), install the package, then restart the TV service... and after that they should be recognised. The key is that TV Server won't recognise them until the service is restarted. That's a Windows thing; there's nothing we can do about it.
     

    gossman

    New Member
    May 24, 2014
    11
    1
    50
    Ohhh... ok.

    Got it recognized now.. onto defining channels and getting the EPG working.
     

    marttoma

    MP Donator
  • Premium Supporter
  • March 24, 2014
    282
    28
    Praha
    Because there's still a huge request (PM) for the package (private hosted on my server):
    http://fabian.m-tschopp.ch/MPEG Encoder Package.zip
    The repack is completely legal, all software can also be obtained freely elsewhere but mixing it together is a mess, and most people don't seem to be able to do it themselves...
    Hello naibaf7,
    thanks for MPEG encoder package, it is difficult to find any on web nowadays as far as I know. It works perfect under Windows 7 - i.e. installation of mpeg encoders from your package -> I did not have any problem to install any SW encoder. In my case of Avermedia A827 just ATI was working fine.

    Now I change the OS to Windows 8.1Pro and I can not install any SW encoder - simply it does not install any SW encoder and I dont get any error from instalation.

    Do you have any feedback from others how it works under Windows 8.1 Pro?
     

    PRW

    MP Donator
  • Premium Supporter
  • January 5, 2012
    8
    3
    MPEG encoder package exe must be run as Administrator.

    Thanks naibf7
     

    osksa

    MP Donator
  • Premium Supporter
  • September 18, 2015
    43
    8
    Thanx a lot for this package naibaf7! I am not satisfied with my software encoding card (Hauppauge HCR 1100) since switching from windows media center to MediaPortal. Image looks jerky in sequences with lots of motion/fast motion. I noticed that my hardware decoding card (Hauppauge PVR-150) outputs about 8 mbit in highest quality mode, my software encoding card about 5 with original codec. With your codecs I got picture from ATI and Hauppage. ATI gave about 3 mbit and the Haupauge codec about 5, as my existing Haupage codec but mine says HCW. The CPU usage was about three times though.

    What I wanted to ask is: Does anybody know how to control the data rate of software encoders? I think that if I could crank up the bitrate on a software encoding to 8 like my other card, image would look better. I though that a software encoder should give more room to experiment, since my CPU is at about 8-14 % when encoding, maybe I could use a lot more. Would be nice to try some real high data rates.
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag

    osksa

    MP Donator
  • Premium Supporter
  • September 18, 2015
    43
    8

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Hmmm.... Can't find how to access it by googling now...
    If you know how to fiddle with codec merits (encoders are codecs too) then it shouldn't be hard to figure out. I don't know what software you were using to fiddle, but I'd be surprised if it doesn't also support viewing the property pages (if available - some codecs don't have property pages). I'd expect it would just be another option or button somewhere in there. I use GraphStudio or GraphStudioNext where it looks like this:

    upload_2015-10-10_10-8-26.png


    upload_2015-10-10_10-8-47.png
     
    Top Bottom