[fixed] - [SOLVED]Latest SVN - TVServer DB exceptions | Page 4

Discussion in 'MediaPortal 1.2.0 ALPHA' started by OnkelChris, January 7, 2011.

  1. OnkelChris
    • Premium Supporter

    OnkelChris Retired Team Member

    Joined:
    October 17, 2007
    Messages:
    764
    Likes Received:
    59
    Ratings:
    +59 / 0
    Home Country:
    Germany Germany
    AW: Latest SVN - TVServer DB exceptions

    Jay_UK:
    are you running ms sql 2008 express sp1?
    what i saw is that it can't work on ms sql, because it tries to delete columns which are needed for the index... so dropping is not possible -> column exists on -> tvserver can't save things to the db...

    romuz:
    what do you mean... "now it should be the same"? you mean MS and mySQL databases are now the same?

    i am kind of f#$%ed up in my brain.. lost 4h with these failures... :mad:


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Jay_UK
    • Team MediaPortal

    Jay_UK Test Group

    Joined:
    October 6, 2009
    Messages:
    1,781
    Likes Received:
    250
    Occupation:
    Enterprise Architect
    Location:
    Derby
    Ratings:
    +271 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi there,

    Know how you feel...annoying things like this can really mess with ya mind! :(

    From my little SQL knowledge, having an index that is not valid, just means it potentially affects performance (but the SQL should still execute), and again, not dropping a column should not stop SQL from executing.

    Anyway.. main thing is that you have fixed it :D

    Yep..I'm running MS SQL 2008 express

    J.
     
  4. OnkelChris
    • Premium Supporter

    OnkelChris Retired Team Member

    Joined:
    October 17, 2007
    Messages:
    764
    Likes Received:
    59
    Ratings:
    +59 / 0
    Home Country:
    Germany Germany
    AW: [SOLVED]Latest SVN - TVServer DB exceptions

    did you do a clean install of the svn or an upgrade? i saw the upgrades not throwing exception on failing the upgrade, but clean installs throw messageboxes on running the tvserver config without having the service running... ok.. weird... this sounds crazy... in short:

    after clean installation -> tvserver started -> running tvserver config -> executes

    after clean installation -> tvserver stopped -> running tvserver config -> failure

    after upgrade i can't get the "upgrade failed" message...


    the problem is not that the index is wrong.. the problem is that there are dependencies on columns in the index... so the column can't be dropped... for me, it does not allow to save anything to the database

    Jay_UK:
    have you tried to do a channel scan afterwards? does it create/update the channels right?
     
  5. Mr Hipp
    • Premium Supporter

    Mr Hipp Retired Team Member

    Joined:
    April 2, 2006
    Messages:
    1,261
    Likes Received:
    187
    Location:
    Malmö
    Ratings:
    +187 / 0
    Home Country:
    Sweden Sweden
    Re: AW: Latest SVN - TVServer DB exceptions

    Patch applied to svn. Thanks OnkelChris!

    Mr Hipp
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!