Streamed MP 1.9.1 Stable [14 May 2013] [Supports MP 1.3] (1 Viewer)

Status
Not open for further replies.

ltfearme

Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    StreamedMP for MediaPortal v1.3 is now ready. This release is considered stable, thanks to all those who have helped improve the product whilst in beta.

    I have tried to get most of the new MP 1.3 skin features into this release, the biggest change is that all MediaPortal settings are now available in the GUI. See below and previous Beta releases for a complete list of changes since the last stable release.

    Requirements
    MediaPortal 1.3

    MediaPortal 1.4 is NOT supported by this release.

    StreamedMP depends on MovingPictures and it's libraries. Ensure this is selected during installation if you also select the BasicHome (menu) editor, if your locally installed version is newer it will not be overwritten. If you don't use the MovingPictures plugin, you can disable it from the MediaPortal plugin configuration dialog.

    Upgrades
    Users can upgrade from any earlier version of StreamedMP by simply downloading the executable file and running it, the steps are no different that clean installs. All previous skin settings chosen will persist.

    Custom Skin Modifications
    It's highly recommended that skin modifications are now done using Themes instead of directly modifying the skins files. Themes can easily be shared with community members.

    Translations
    StreamedMP is fully translatable, community members can help translate from Transifex. More information about how to do this can be found in the main translations thread here.

    DOWNLOAD
    Be sure to disable any Anti-virus programs before download begins and before installation. Alternatively create a rule to allow StreamedMP. There has been reports of Kapersky interfering with download/install.

    Change Logs
    v1.9.1
    • Fixed TV Guide when colour settings were disabled. It should now look like it did before StreamedMP 1.3.
    • Fixed some alignment issues in mvCentral, thanks Shangostar (Shane).
    • Added a Backup / Restore MediaPortal Skin Settings on upgrade e.g. TV Guide colours.
    • Added new localized skin properties for AirDay / AirTime in Trakt Calendar.
    • Added new 'Hide Watchlisted' toggle button to Calendar GUI.
    • Added filtering support to Trakt Trending GUI.
    • Added a new skin setting to hide the My Video Watched Progress labels in the List Facade.
    • Added a temporary workaround for right aligned fade labels disappearing text when longer than width. Only added workaround to OnlineVideos.
    • Removed 'Score' label from MovingPictures when score is zero.
    • Replaced ToggleButtons with CheckButtons in StreamedMP Configuration plugin.
    • Updated Trakt skin Settings and Rate Dialog to be compatible with new release of Trakt v2.9.0.
    • Updated TVSeries skin Playlist, FanartChooser and Rate dialog to be compatible with new release of MP-TVSeries v3.5.0.
    • Updated GlobalSearch skin to be compatible with v1.8.0.
    • Updated SleepControl skin to be compatible with v1.2.0.
    • Updated PowerControl skin to be compatible with v1.2.0.
    • Updated Trakt plugin library to v2.9.0.
    • Updated MP-TVSeries plugin library to v3.5.0.
    • Updated GlobalSearch plugin library to v1.8.0.
    • Updated WorldWeather plugin library to v1.2.2.
    v1.9.0 (since v1.8.2)
    • Fixed #currentmodule being empty when entering window for first time.
    • Fixed #header.label property in OnlineVideos (v1.5.0).
    • Fixed Loading Parameters not working for some plugins if they were also the 'Default' menu item.
    • Fixed 'Daylight' translations in WorldWeather (v1.1.0). New Skin translations available.
    • Fixed 'RememberLastFocuedItem' and 'Skin Animations' not working in StreamedMP GUI Settings.
    • Fixed long translations in MediaPortal Settings overlapping toggle/checkmarks.
    • Fixed 'Auto Update' button in OnlineVideos Site Manager (Thanks Sebastii).
    • Fixed some navigation and default selection issues in Setting windows.
    • Fixed texture in My TV Guide groups button.
    • Added 'Next/Previous' button to Trakt Shouts window (v2.6.0).
    • Added 'Likes' and 'Reply' counts to Trakt Shouts window (v2.7.0).
    • Added support for MovingPictures Importer GUI in (v1.5.1).
    • Added 'Movie Importer' button to MovingPictures hidden menu (v1.5.1).
    • Added extended info to OnlineVideos YouTube site. List Layout only (v1.5.0).
    • Added Header Image (Site Banner) to OnlineVideos site category view (v1.5.0).
    • Updated 'NextPage' image in OnlineVideos.
    • Updated layout in OnlineVideos Site Updater GUI.
    • Updated StreamedMP translations to be compatible with Transifex.
    • Updated support for Update Control plugin.
    • Updated TVSeries plugin library to v3.4.2.
    • Updated MovingPictures plugin library to v1.5.1.
    • Updated WorldWeather plugin library to v1.1.0.
    • Updated Trakt plugin library to v2.7.0.
    • Updated Latest Media Handler plugin library to v1.6.0.9.
    • Updated GlobalSearch plugin library to v1.7.6.
     
    Last edited:

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    • Thread starter
    • Moderator
    • #2
    WARNING: If you have custom TVGuide colours defined from MediaPortal 1.3 Beta/RC please backup SkinSettings.xml before upgrading. I just realized these are not preserved. This will be fixed in next release.

    Ok, with original colors i have to do nothing... ?
    That's right, it's only if you put in effort to define different colours.
     
    Last edited:

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    • Thread starter
    • Moderator
    • #3
    New release including patch available (v1.9.1). See first post for changes.

    Going forward there might be 1 or 2 more minor maintenance releases for MediaPortal 1.3. I'm now going to start working on support for MediaPortal 1.4 so stay tuned for testing that when it's released by the MediaPortal team.
     
    Last edited:

    TiboTv

    Portal Pro
    June 22, 2009
    244
    39
    Home Country
    Belgium Belgium
    Seems that my post in 1.9.0 thread has been deleted... or moved on a archive place?

    So I ask again my question : Is it normal that plugins installed by StreamedMP installer are not shown in 'MediaPortal Extension Installer" ?

    Thanks for information!
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,475
    4,645
    48
    ::1
    Home Country
    Netherlands Netherlands
    So I ask again my question : Is it normal that plugins installed by StreamedMP installer are not shown in 'MediaPortal Extension Installer"?
    For now it is (probably because the .dlls are distributed instead of the .mpei packages).
    If i understood correct, ltfearme is working on this so that all installed plugins also show up in MPEI.
    (Correct me if i'm wrong Damien) :D
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    • Thread starter
    • Moderator
    • #6
    Last edited:

    Dr Tone

    Portal Pro
    October 29, 2008
    157
    5
    Calgary, AB
    Home Country
    Canada Canada
    Installed 1.9.1 and now mediaportal just starts minimized and it's unresponsive and won't let me maximize. Don't particularily want to have to completely reinstall mediaportal.

    I'm running 1.3

    Any ideas before I completely uninstall?
     
    Last edited:

    emphatic

    Design Group
  • Team MediaPortal
  • August 25, 2006
    3,712
    1,171
    Alingsås
    Home Country
    Sweden Sweden
    Installed 1.9.1 and now mediaportal just starts minimized and it's unresponsive and won't let me maximize. Don't particularily want to have to completely reinstall mediaportal.

    I'm running 1.3

    Any ideas before I completely uninstall?

    This sounds like a missing font issue. First, delete the contents in the cache folder, restart your computer and start MediaPortal again. If that fails, re-install StreamedMP (or use the repair option if it's available).

    Emph
     

    Atomic7431

    Portal Pro
    June 17, 2011
    497
    71
    Home Country
    United Kingdom United Kingdom
    is this 1.4 compatible out of interest?
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    • Thread starter
    • Moderator
    • #10
    is this 1.4 compatible out of interest?
    No, this will only work on MediaPortal 1.3.

    Unfortunately I forgot to add detection on the installer to prevent some-one installing it on MediaPortal 1.4 :(

    Anyway, there will be a StreamedMP 2.0 out soonish that will have support for MediaPortal 1.4.
     
    Status
    Not open for further replies.

    Users who are viewing this thread

    Top Bottom