Swedish sites: SVT, TV4, Dplay Premium, UR, Viasat channels + Movie & Series sites

Ministerk

Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    93
    Uppsala
    Home Country
    Sweden Sweden
    Country flag
    The version of your .dll is 1.0.0.3064.
    That's the latest public version.

    If you go to online videos config (in plugins in mp config), go to the sites tab, click the import icon at top left, and choose "global". Can you find dreamfilm in that list? If not then I don't know what to do next.
     

    pnyberg

    Portal Pro
    August 21, 2006
    405
    18
    Stockholm
    Home Country
    Sweden Sweden
    Don't know what has happened. But i checked the onlinevideos.xml I had in my MP2 installation and copied the site info for dreamfilm into the one in MP1... So know it works in mp1 as well.

    Thanks anyway. Merry Christmas to you all.
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    93
    Uppsala
    Home Country
    Sweden Sweden
    Country flag
    Merry Christmas
    Merry Christmas!

    And great! (Well Dreamfilm is down a lot right now - that's not that great...)[DOUBLEPOST=1387809555][/DOUBLEPOST]
    If someone can use this information and create a way to use login credentials then this would be perfect
    I can take a peek at that later on, celebrating christmas with the in laws.
     

    Aros62

    MP Donator
  • Premium Supporter
  • September 23, 2012
    51
    8
    Home Country
    Sweden Sweden
    Don't know what has happened. But i checked the onlinevideos.xml I had in my MP2 installation and copied the site info for dreamfilm into the one in MP1... So know it works in mp1 as well.
    Can you please publish your MP 1 onlinevideos.xml file here in the thread? I need it for my installation. Thanks!
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    93
    Uppsala
    Home Country
    Sweden Sweden
    Country flag
    @weekendowel - I've made a util to test.

    In context menu you can enter username and password.
    • If one of them is left blank, skip the login.
    • If both fields are filled the util tries to log in the user, but if it fails a message is shown to the user stating "Wrong username or password".
    I tried to search for a tv series and voila, episodes appeared in the search result and they did play ok.

    Place the dll in the {MediaPortal install dir}\plugins\Windows\OnlineVideos directory and change this:
    Code:
    <Site name="Swefilmer" util="GenericSite" agecheck="false" enabled="true" lang="sv">
    to this:
    Code:
    <Site name="Swefilmer" util="Swefilmer" agecheck="false" enabled="true" lang="sv">
    Feel free to modify your regexes as you please or add tv series specific regexes, this util only overrides the GetCookies() method in the GenericSiteUtil.

    I have renamed the attached file, just remove the .zip extension.

    Edit:

    New version 1.0.0.1 here: https://forum.team-mediaportal.com/threads/swedish-sites-tv4-premium-ur-tv3-tv6-tv8-tv10-kanal-5-and-9-dreamfilm.121326/page-5#post-1049258
     
    Last edited:

    weekendowel

    Portal Member
    September 5, 2005
    31
    8
    Stockholm
    Home Country
    Sweden Sweden
    @weekendowel - I've made a util to test.

    In context menu you can enter username and password.
    • If one of them is left blank, skip the login.
    • If both fields are filled the util tries to log in the user, but if it fails a message is shown to the user stating "Wrong username or password".
    I tried to search for a tv series and voila, episodes appeared in the search result and they did play ok.

    Place the dll in the {MediaPortal install dir}\plugins\Windows\OnlineVideos directory and change this:
    Code:
    <Site name="Swefilmer" util="GenericSite" agecheck="false" enabled="true" lang="sv">
    to this:
    Code:
    <Site name="Swefilmer" util="Swefilmer" agecheck="false" enabled="true" lang="sv">
    Feel free to modify your regexes as you please or add tv series specific regexes, this util only overrides the GetCookies() method in the GenericSiteUtil.

    I have renamed the attached file, just remove the .zip extension.

    I tried it but it didn't work. I found it strange that browsing to this url didn't log you on (replace user&pass):

    http://www.swefilmer.com/login.php?username=XXXXXXXXXXX&pass=XXXXXXXXXX&remember=1&ref=&Login=Logga+in

    It just shows the login page again.
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    93
    Uppsala
    Home Country
    Sweden Sweden
    Country flag
    @weekendowel - I've made a util to test.

    In context menu you can enter username and password.
    • If one of them is left blank, skip the login.
    • If both fields are filled the util tries to log in the user, but if it fails a message is shown to the user stating "Wrong username or password".
    I tried to search for a tv series and voila, episodes appeared in the search result and they did play ok.

    Place the dll in the {MediaPortal install dir}\plugins\Windows\OnlineVideos directory and change this:
    Code:
    <Site name="Swefilmer" util="GenericSite" agecheck="false" enabled="true" lang="sv">
    to this:
    Code:
    <Site name="Swefilmer" util="Swefilmer" agecheck="false" enabled="true" lang="sv">
    Feel free to modify your regexes as you please or add tv series specific regexes, this util only overrides the GetCookies() method in the GenericSiteUtil.

    I have renamed the attached file, just remove the .zip extension.

    I tried it but it didn't work. I found it strange that browsing to this url didn't log you on (replace user&pass):

    http://www.swefilmer.com/login.php?username=XXXXXXXXXXX&pass=XXXXXXXXXX&remember=1&ref=&Login=Logga in

    It just shows the login page again.
    You have to post the form, a get does not work.

    Does the util work without login? Do you get a failed login message?

    Edit: I see others have downloaded the dll, does it work for you?
     

    weekendowel

    Portal Member
    September 5, 2005
    31
    8
    Stockholm
    Home Country
    Sweden Sweden
    I get wrong username or password, unable to login. If I don't write something in username and password textboxes I get no error, but then I obviously can't see stuff that are behind login.
    Can I in some way see some more error messages? Can I see if the cookie is received properly somewhere?
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    93
    Uppsala
    Home Country
    Sweden Sweden
    Country flag
    I get wrong username or password, unable to login. If I don't write something in username and password textboxes I get no error, but then I obviously can't see stuff that are behind login.
    Can I in some way see some more error messages? Can I see if the cookie is received properly somewhere?
    I got some ideas why it does not work for you when it actually works for me. I'm away from computer right now, but tonight I can take a peek.

    We could do this in two ways Either I do a new (fixed?) version of the util with debug logging and if it still does not work you post your logs.
    Or you pm me your credentials and I debug with them.

    The latter one is the most simple solution, but I understand if you're not to keen to give your user and pass to a total stranger…

    God fortsättning.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom