TBS: CI/CAM support and other improvements | Page 76

Discussion in 'General Development (no feature request here!)' started by mm1352000, December 6, 2011.

  1. BrianShu

    BrianShu Portal Member

    Joined:
    September 21, 2015
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 0
    Home Country:
    England England
    Show System Specs
    Go into GitHub - MediaPortal/MediaPortal-1: Home Theater and Digital Video Recording solution for Windows. and, on the right hand side there is a green button labelled 'clone or download' this will download a Zip file of the branch (in this case 'master') called 'Mediaportal-1-master.zip'. These instructions are on the mediaportal WiKi page.

    I can do the same with the TVEngine3-TBS_support_1.6.0 branch dowloading a file called 'MediaPortal-1-eadf83490ea346dbb934537ce75fca7c2dc80d2b.zip'.

    I haven't tried to compile the files yet which is why i'm asking if this is reasonable. I need everything downloaded because I may not have internet access all of the time, which I believe Git needs.



    BrianShu
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. te3hpurp
    • Premium Supporter

    te3hpurp Retired Team Member

    Joined:
    September 23, 2008
    Messages:
    904
    Likes Received:
    182
    Gender:
    Male
    Occupation:
    Senior Software Architect
    Location:
    Rovaniemi
    Ratings:
    +229 / 0
    Home Country:
    Finland Finland
    Show System Specs
    Hi.

    Well you dont need internet constsntly. Only for the time to clone repisitory.

    After that there is local copy in your computer which you can use. You cant do any harm cos you dont have rights to push anything back to repisitory.

    Br,
     
    • Agree Agree x 2
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Okay.

    It's reasonable.
    What te3hpurp is true. Git doesn't need internet access unless you're updating (pulling or pushing or in some way accessing the remote repository). However you should be aware that Visual Studio will need to download more stuff (NuGet packages) when you first try to build the code. So, you will need internet access for that part too.
     
  5. ratata

    ratata Portal Member

    Joined:
    December 30, 2011
    Messages:
    9
    Likes Received:
    2
    Gender:
    Male
    Occupation:
    Developing software.
    Location:
    Lund
    Ratings:
    +3 / 1
    Home Country:
    Sweden Sweden
    Hello folks

    First of all, thank you for all the job you have put in to make this work. I and my family are so happy with our system. However, since a couple of days there's something strange going on. After rebooting the system and trying to watch a TV program, MP just says "No available TV tuner". The system won't fire up for watching TV with less than opening the TV tuners CI menus and then to close them again. After that the weather is fine and everything is back to normal again. I have tried altering all the settings I can think of but no luck so far. This wouldn't be a problem if the system didn't reboot every morning, but it does. Hints on what to try?

    ratata
     
    • Missing System Logs and/or Specs Missing System Logs and/or Specs x 1
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hi ratata

    Sorry, no idea at this stage. Log files might enable us to give you some hints.
     
  7. Lasse H

    Lasse H New Member

    Joined:
    October 24, 2012
    Messages:
    4
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 2
    Home Country:
    Sweden Sweden
    Hi..
    First i want thank you guys for great job your doing here..(y)..
    I have been using Mediaportal since 2010. My setup today is win 7 and tbs 5881, MP 1.18.
    The problem is that channel change take long time, 20 - 25s, i have noticed that when using the preview function in TvServer setup its almost instant.

    regards
    Lasse H
     
    • Missing System Logs and/or Specs Missing System Logs and/or Specs x 1
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    @Lasse H
    Same as for ratata - it's not possible to help you without log files to show us where the delay is.
     
  9. micko

    micko Portal Pro

    Joined:
    May 27, 2006
    Messages:
    258
    Likes Received:
    24
    Ratings:
    +51 / 0
    Home Country:
    Finland Finland
    Show System Specs
    Hi guys,
    It seems that patch is still needed for the latest MediaPortal 2.1.1 Release. Could you please provide the updated patch
     
  10. ratata

    ratata Portal Member

    Joined:
    December 30, 2011
    Messages:
    9
    Likes Received:
    2
    Gender:
    Male
    Occupation:
    Developing software.
    Location:
    Lund
    Ratings:
    +3 / 1
    Home Country:
    Sweden Sweden
    Of course, how stupid of me. :) Anyway, I took a look myself at the logfiles and found the error. Somewhere in the database an error to the reference to the tuner cards had been written. I couldn't find an easy way to clear that out but since I always keep several backups of the entire C drive it was easy to restore the latest backup to check if that solved the problem, and yes, it did. So case closed, but thank you anyway. Especially for your work with the patches.

    Best regards
    ratata
     
  11. Lasse H

    Lasse H New Member

    Joined:
    October 24, 2012
    Messages:
    4
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +0 / 2
    Home Country:
    Sweden Sweden
    Here are my log files..

    Looking at TVService.log using preview function in TV setup
    [2017-11-20 17:43:20,900] [Log ] [21 ] [DEBUG] - card: Tuner locked: True
    [2017-11-20 17:43:20,901] [Log ] [21 ] [INFO ] - **************************************************
    [2017-11-20 17:43:20,901] [Log ] [21 ] [INFO ] - ***** SIGNAL LEVEL: 85, SIGNAL QUALITY: 49 *****
    [2017-11-20 17:43:20,901] [Log ] [21 ] [INFO ] - **************************************************
    [2017-11-20 17:43:20,901] [Log ] [21 ] [DEBUG] - card: tuned user: setuptv subchannel: 0
    [2017-11-20 17:43:20,902] [Log ] [21 ] [INFO ] - user:setuptv add
    [2017-11-20 17:43:20,902] [Log ] [21 ] [INFO ] - card2:setuptv 9 0
    [2017-11-20 17:43:20,902] [Log ] [21 ] [INFO ] - Controller: delete timeshift files C:\timeshift\live9-0.ts
    [2017-11-20 17:43:20,903] [Log ] [21 ] [INFO ] - Controller: epg stop
    [2017-11-20 17:43:20,904] [Log ] [21 ] [INFO ] - card: StartTimeShifting 9 C:\timeshift\live9-0.ts
    [2017-11-20 17:43:20,905] [Log ] [21 ] [INFO ] - card: CAM enabled : True
    [2017-11-20 17:43:20,905] [Log ] [21 ] [INFO ] - subch:0 SetTimeShiftFileName:C:\timeshift\live9-0.ts
    [2017-11-20 17:43:20,905] [Log ] [21 ] [INFO ] - Set video / audio observer
    [2017-11-20 17:43:20,905] [Log ] [21 ] [INFO ] - subch:0 SetTimeShiftFileName fill in pids
    [2017-11-20 17:43:20,906] [Log ] [21 ] [INFO ] - subch:0-0 tswriter StartTimeshifting...
    [2017-11-20 17:43:20,906] [Log ] [21 ] [INFO ] - card: WaitForFile - waiting _eventAudio & _eventVideo
    [2017-11-20 17:43:22,115] [Log ] [3 ] [INFO ] - PID seen - type = Video
    [2017-11-20 17:43:22,116] [Log ] [3 ] [INFO ] - audioVideoEventHandler Video
    [2017-11-20 17:43:22,182] [Log ] [3 ] [INFO ] - PID seen - type = Audio
    [2017-11-20 17:43:22,182] [Log ] [3 ] [INFO ] - audioVideoEventHandler Audio
    [2017-11-20 17:43:22,183] [Log ] [21 ] [INFO ] - card: WaitForFile - video and audio are seen after 1,277073 seconds
    [2017-11-20 17:43:22,186] [Log ] [21 ] [INFO ] - user:setuptv card:9 sub:0 add stream:C:\timeshift\live9-0.ts.tsbuffer

    And when using MediaPortal as client..
    [2017-11-20 17:53:51,205] [Log ] [18 ] [DEBUG] - card: Tuner locked: True
    [2017-11-20 17:53:51,206] [Log ] [18 ] [INFO ] - **************************************************
    [2017-11-20 17:53:51,206] [Log ] [18 ] [INFO ] - ***** SIGNAL LEVEL: 86, SIGNAL QUALITY: 100 *****
    [2017-11-20 17:53:51,206] [Log ] [18 ] [INFO ] - **************************************************
    [2017-11-20 17:53:51,206] [Log ] [18 ] [DEBUG] - card: tuned user: HTPC subchannel: 0
    [2017-11-20 17:53:51,207] [Log ] [18 ] [INFO ] - user:HTPC add
    [2017-11-20 17:53:51,209] [Log ] [18 ] [INFO ] - card2:HTPC 9 0
    [2017-11-20 17:53:51,210] [Log ] [18 ] [INFO ] - Controller: epg stop
    [2017-11-20 17:53:51,210] [Log ] [18 ] [INFO ] - card: StartTimeShifting 9 C:\timeshift\live9-0.ts
    [2017-11-20 17:53:51,211] [Log ] [18 ] [INFO ] - card: CAM enabled : True
    [2017-11-20 17:53:51,211] [Log ] [18 ] [INFO ] - card: WaitForFile - waiting _eventAudio & _eventVideo
    [2017-11-20 17:54:06,555] [Log ] [Turbosight MMI handler] [DEBUG] - Turbosight: received MMI response Menu to message Null
    [2017-11-20 17:54:06,555] [Log ] [Turbosight MMI handler] [DEBUG] - Turbosight: response length = 268
    [2017-11-20 17:54:06,556] [Log ] [Turbosight MMI handler] [DEBUG] - Turbosight: menu
    [2017-11-20 17:54:06,556] [Log ] [Turbosight MMI handler] [DEBUG] - title = Viaccess Conditional Access
    [2017-11-20 17:54:06,556] [Log ] [Turbosight MMI handler] [DEBUG] - sub-title = Meddelande
    [2017-11-20 17:54:06,556] [Log ] [Turbosight MMI handler] [DEBUG] - footer = Tryck 'OK' för att bekräfta
    [2017-11-20 17:54:06,556] [Log ] [Turbosight MMI handler] [DEBUG] - # entries = 8
    [2017-11-20 17:54:06,557] [Log ] [Turbosight MMI handler] [DEBUG] - entry 1 = ID: 391 001
    [2017-11-20 17:54:06,557] [Log ] [Turbosight MMI handler] [DEBUG] - entry 2 = För att se den här kanalen
    [2017-11-20 17:54:06,557] [Log ] [Turbosight MMI handler] [DEBUG] - entry 3 = krävs ett programkort från
    [2017-11-20 17:54:06,557] [Log ] [Turbosight MMI handler] [DEBUG] - entry 4 = Boxer. Har du redan ett
    [2017-11-20 17:54:06,557] [Log ] [Turbosight MMI handler] [DEBUG] - entry 5 = programkort, sätt i det i
    [2017-11-20 17:54:06,558] [Log ] [Turbosight MMI handler] [DEBUG] - entry 6 = mottagaren.
    [2017-11-20 17:54:06,558] [Log ] [Turbosight MMI handler] [DEBUG] - entry 7 = För ytterligare information gå
    [2017-11-20 17:54:06,558] [Log ] [Turbosight MMI handler] [DEBUG] - entry 8 = in på www.boxer.se/support
    [2017-11-20 17:54:08,067] [Log ] [5 ] [INFO ] - PID seen - type = Video
    [2017-11-20 17:54:08,067] [Log ] [5 ] [INFO ] - audioVideoEventHandler Video
    [2017-11-20 17:54:08,068] [Log ] [5 ] [INFO ] - video last seen at 2017-11-20 17:54:08
    [2017-11-20 17:54:08,068] [Log ] [5 ] [INFO ] - video last seen at 2017-11-20 17:54:08
    [2017-11-20 17:54:08,174] [Log ] [5 ] [INFO ] - PID seen - type = Audio
    [2017-11-20 17:54:08,175] [Log ] [5 ] [INFO ] - audioVideoEventHandler Audio
    [2017-11-20 17:54:08,175] [Log ] [18 ] [INFO ] - card: WaitForFile - video and audio are seen after 16,9639703 seconds
    [2017-11-20 17:54:08,175] [Log ] [5 ] [INFO ] - audio last seen at 2017-11-20 17:54:08
    [2017-11-20 17:54:08,176] [Log ] [5 ] [INFO ] - audio last seen at 2017-11-20 17:54:08
    [2017-11-20 17:54:08,177] [Log ] [18 ] [INFO ] - Controller: StartTimeShifting started on card:9 to C:\timeshift\live9-0.ts

    The MMI response complains about subscription card, but the card is in the cam and it works perfect in TVserver setup preview. I have tested different values for "wait for unscrambled signal", which not seems to make any difference.

    regards Lasse
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!