Teletext subtitles don't have different transmitted colors

Discussion in 'Television (MyTV frontend and TV-Server)' started by Vasilich, October 14, 2014.

  1. Vasilich
    • Team MediaPortal

    Vasilich Test Group

    Joined:
    August 30, 2009
    Messages:
    3,389
    Likes Received:
    608
    Gender:
    Male
    Occupation:
    Developer
    Location:
    Germany, Mayence
    Ratings:
    +1,171 / 2
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    MediaPortal Version: tested on 1.2.3, 1.9, 1.12, 1.13pre



    Description
    as nothing was changed in this area since 1.2.3 (the oldest version i still use), and i can reproduce this in 1.2.3, 1.9, 1.12 and 1.13, i assume this as a bug:
    in Europe for DVB there are 2 types of subtitles for TV: DVB subtitles , transmitted as bitmaps (similar to DVD bitmap subtitles), and teletext subtitles, transmitted over Teletext on pages that are declared in transport stream (so if in the stream declared that there are subtitles on page 150, then teletext for this page will have synchronous subtitles).
    teletext subtitles have defined small subset of colors (4 to 16) to distinct speech from different persons on one subtitle screen.
    In MP the teletext subtitles are always shown in white, though other software,that is able to extract subtitles, reads the color information for them, so i assume that the color information is present there, but not used somehow.
    In MP code there are some code pieces that reads color information for subtitles, but unfortunately i don't see any result of this code.
    Where should i look to get teletext subtitles in color?
    Or is it not possible with current subtitle renderer?

    Steps to Reproduce:
    tune to a DVB channel with teletext subtitles, and activate them

    PS i can upload short .TS samplefile if someone needs it.
     
    Last edited: November 10, 2015
    • Informative Informative x 2
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Vasilich
    • Team MediaPortal

    Vasilich Test Group

    Joined:
    August 30, 2009
    Messages:
    3,389
    Likes Received:
    608
    Gender:
    Male
    Occupation:
    Developer
    Location:
    Germany, Mayence
    Ratings:
    +1,171 / 2
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    ...corrected tested versions
     
  4. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,481
    Likes Received:
    4,700
    Ratings:
    +8,152 / 17
    Home Country:
    New Zealand New Zealand
    How are you activating/using the subtitles?
    There are 2 ways:
    1. Tick the "enable teletext subtitles" setting in MP Configuration. This way teletext subtitles comes via the MP player (TsReader).
    2. Enter the teletext section/page in the TV plugin and select the page which carries your subtitles. This way teletext (and subtitles) come directly from TV Server.

    If you use the first way I think the subtitle content and timing is okay but the colours are not shown.
    If you use the second way I think you'll see colours, but the subtitle updates may be slow or skipped/missing compared to the dialogue/talking.

    I can't help if you're using the first way, because that is the MP player code (which I'm not familiar with).
     
  5. Vasilich
    • Team MediaPortal

    Vasilich Test Group

    Joined:
    August 30, 2009
    Messages:
    3,389
    Likes Received:
    608
    Gender:
    Male
    Occupation:
    Developer
    Location:
    Germany, Mayence
    Ratings:
    +1,171 / 2
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    i use 1st way (because this way TVServer can recognize proper page number).
    Is there any chance to transfer the color information to MP player somehow? as i described above, after extracting teletext subtitles in an external program the MP shows the proper colors (taking these from generated *.srt file)
     
  6. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,481
    Likes Received:
    4,700
    Ratings:
    +8,152 / 17
    Home Country:
    New Zealand New Zealand
    I don't understand what you mean by that. As I said to you, TV Server has nothing to do with way #1. :confused:

    Sorry, like I said: I can't help you with this. I assume the missing colours are due to a bug or missing feature in the MP player.

    Sure. That's because there is nothing wrong with the teletext stream. The problem is in the MP player's handling of VBI/teletext data. As above: I assume the missing colours are due to a bug or the feature was never supported.
     
  7. Vasilich
    • Team MediaPortal

    Vasilich Test Group

    Joined:
    August 30, 2009
    Messages:
    3,389
    Likes Received:
    608
    Gender:
    Male
    Occupation:
    Developer
    Location:
    Germany, Mayence
    Ratings:
    +1,171 / 2
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    ok, then probably TsReader does it?
     
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,481
    Likes Received:
    4,700
    Ratings:
    +8,152 / 17
    Home Country:
    New Zealand New Zealand
    Yes, TsReader reads the available teletext services (including subtitle services) from the VBI/teletext stream.
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,481
    Likes Received:
    4,700
    Ratings:
    +8,152 / 17
    Home Country:
    New Zealand New Zealand
    Here you can find the code for the TV plugin's teletext decoder/renderer which supports teletext colours:
    https://github.com/MediaPortal/Medi...vPlugin/teletext/TeletextPageRenderer.cs#L649

    It seems that the equivalent code in the MP player is here:
    https://github.com/MediaPortal/Medi.../TeletextSubtitles/TeletextSubtitleDecoder.cs
    https://github.com/MediaPortal/Medi.../Player/TeletextSubtitles/TeletextMagazine.cs

    Based on this structure (which is populated in TeletextMagazine.cs), it looks like there is no support for text colour decoding or processing:
    https://github.com/MediaPortal/Medi...Core/Player/Subtitles/SubtitleRenderer.cs#L80

    In other words: it looks like this is not a bug; it's a request for a feature that has never been supported.
     
    • Like Like x 1
    • Informative Informative x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!