The Audio Renderer has an issue with some hardware / reference clock generation (1 Viewer)

Status
Not open for further replies.

legnod

MP Donator
  • Premium Supporter
  • September 24, 2011
    1,115
    323
    Stuttgart
    Germany Germany
    I will test it within the next days. I had some sync problems while using skip steps or after resuming a paused channel/Video but i am not sure if this is because the audio renderer...
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    I'm just watching a recording and it isn't really enjoyable :/
    Suddenly the sound starts to stutter and it is getting worse and worse until there is no sound anymore...
    if I skip back some seconds it is okay again, see the attached logs.
    Status quo in the logs:
    - the stutter began
    - skipped 1min back
    - paused
    - posted logs
    :)

    I have the highest quality selected in MPAR could that be a reason that the CPU (AMD X2) is not powerful enough?
     

    davidf

    Retired Team Member
  • Premium Supporter
  • April 3, 2006
    796
    348
    Scotland
    Scotland Scotland
    It ran out of data :(
    Your monitor is not at 50Hz which means that bad things happen on TV as it's streamed at 1.0x from your server (possibly same machine) but it won't work in that scenario... we do have a plan for that however, but it isn't done yet.

    It looks like your Monitor is at 48Hz, so not 100% sure why it broke (as it should be the other way which gives those symptoms).
     
    Last edited:

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    Thanks for the fast answer :)
    My Tv is @60Hz, but it also supports 50Hz and 24Hz and some more...
    And i was a watching a recording (was on the same machine); it is a singleseat setup

    Some days ago I tried the Refreshrate changer, but I just don't like it if by display changes the mode if I start to watch some movie etc :)

    What do you recommend until MPAR supports my scenario?

    For test reasons I will change the refreshrate to 50Hz and see what happens :)
     

    davidf

    Retired Team Member
  • Premium Supporter
  • April 3, 2006
    796
    348
    Scotland
    Scotland Scotland
    Unless your Monitor/TV is running at 50Hz I'd recommend not using MPAR for Live TV (A live source can't be manipulated in the same way other sources can). If your TV is at 50 then it depends on the exact refresh rate, even a little bit off can make the tsReaderBuffers run out over time. Movies on the otherhand are great, with dynamic refresh rate you only need 2 settings (if you don't like the switching) of 50 and 60 - MPAR will resample to get a better picture.
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    If your TV is at 50 then it depends on the exact refresh rate, even a little bit off can make the tsReaderBuffers run out over time
    I was watching a recording so it shouldn't run out of buffer or I'm wrong?


    Unless your Monitor/TV is running at 50Hz I'd recommend not using MPAR for Live TV
    I've changed the refresh rate to 50Hz and played the same recording again and now it looks better, there were three adjustments, but no stutter, will continue testing this evening while watching Tv :p
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Unless your Monitor/TV is running at 50Hz I'd recommend not using MPAR for Live TV
    I've changed the refresh rate to 50Hz and played the same recording again and now it looks better, there were three adjustments, but no stutter, will continue testing this evening while watching Tv :p
    01-03-2013 16:21:51.035 [12a8]----- Experimental noStopMod version -----
    01-03-2013 16:21:51.035 [12a8]---------- v0.0.70 XXX ------------------

    Does the TsReader.ax from 1.3.0 RC behave the same way? From TsReader.logs it is visible that the TsReader is trying to throttle the playback (not sure if it is caused by MPAR or TsReader itself).

    Also as a quick test you could rename that .ts file to .m2ts and let LAV splitter to be as source filter (if you have it installed). Just copy the renamed file under folder that is accessible from my videos and play from there.
     

    FreakyJ

    Development Group
  • Team MediaPortal
  • July 25, 2010
    4,024
    1,420
    Germany Germany
    Country flag
    @tourettes
    I've set my refreshrate back to 60Hz and renamed the recording to *.m2ts. Than I started the playback from within the videoplugin and had no issues :)
    I tried to simulate the exact behavior as before and it was working :)

    The Splitter&video-&audiodecoder were LAV
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F Audio render and font error in my logs General Support 2
    C ARC Audio Renderer Changer: wo kann man es konfigurieren? Video & DVD 15
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    Golf4 TV-Records werden als Audio-Files importiert ? Allgemeines Support- und Diskussionsforum 0
    W [solved] Incorrect audio being reported Moving Pictures 4
    404 [solved] Live TV...video and audio freeze General Support 20
    ninja 12 Audio dropouts with Dolby / DTS watch/edit Videos 12
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    T [solved] MP2 Switch off visualisation when listening to audio....PLEASE!!! General 23
    azzuro [fixed] [WIP MP2.3] - Audio files not imported to MP MediaPortal 2 18
    S Remote button to change audio and subtitle on / off General 10
    R [solved] Command / Shortcut for changing subtitles or audio Archive 5
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    Glith Audio out of sync after pause. Rewind 15sec gets it into sync again. MediaPortal 1 Talk 0
    joecrow No Audio after MP Start/Resume from Sleep General Support 0
    C Ability to browse videos and audio by folder General 2
    Lichloathe Offline audio content General 9
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Ralph Holmes Wrong audio source in TV General 1
    CyberSimian [Proposal] Audio description MediaPortal 1 10
    ge2301 [fixed] [MP2-807] Problem when switching player in PiP mode with audio files MediaPortal 2 32
    cladinshadows85 [solved] Audio playing mutiple times over video and crashing General 8
    H Live TV info OSD not displaying number of audio channels General Support 3
    T Moving Pictures...seem to have 'lost' ability to display Movie info. (eg Resolution/Audio) Moving Pictures 2
    Similar threads

























    Top Bottom