The Audio Renderer has an issue with some hardware / reference clock generation | Page 2

Discussion in 'Area 51 - Testing Area' started by tourettes, February 25, 2013.

Thread Status:
Not open for further replies.
  1. legnod
    • Premium Supporter

    legnod MP Donator

    Joined:
    September 24, 2011
    Messages:
    1,115
    Likes Received:
    275
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +303 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I will test it within the next days. I had some sync problems while using skip steps or after resuming a paused channel/Video but i am not sure if this is because the audio renderer...


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. FreakyJ
    • Team MediaPortal

    FreakyJ Development Group

    Joined:
    July 25, 2010
    Messages:
    4,021
    Likes Received:
    839
    Gender:
    Male
    Ratings:
    +1,424 / 1
    Home Country:
    Germany Germany
    I'm just watching a recording and it isn't really enjoyable :/
    Suddenly the sound starts to stutter and it is getting worse and worse until there is no sound anymore...
    if I skip back some seconds it is okay again, see the attached logs.
    Status quo in the logs:
    - the stutter began
    - skipped 1min back
    - paused
    - posted logs
    :)

    I have the highest quality selected in MPAR could that be a reason that the CPU (AMD X2) is not powerful enough?
     
  4. davidf
    • Team MediaPortal

    davidf Development Group

    Joined:
    April 3, 2006
    Messages:
    796
    Likes Received:
    310
    Occupation:
    Application Architect
    Location:
    Scotland
    Ratings:
    +336 / 0
    Home Country:
    Scotland Scotland
    Show System Specs
    It ran out of data :(
    Your monitor is not at 50Hz which means that bad things happen on TV as it's streamed at 1.0x from your server (possibly same machine) but it won't work in that scenario... we do have a plan for that however, but it isn't done yet.

    It looks like your Monitor is at 48Hz, so not 100% sure why it broke (as it should be the other way which gives those symptoms).
     
    Last edited: March 1, 2013
    • Like Like x 1
  5. FreakyJ
    • Team MediaPortal

    FreakyJ Development Group

    Joined:
    July 25, 2010
    Messages:
    4,021
    Likes Received:
    839
    Gender:
    Male
    Ratings:
    +1,424 / 1
    Home Country:
    Germany Germany
    Thanks for the fast answer :)
    My Tv is @60Hz, but it also supports 50Hz and 24Hz and some more...
    And i was a watching a recording (was on the same machine); it is a singleseat setup

    Some days ago I tried the Refreshrate changer, but I just don't like it if by display changes the mode if I start to watch some movie etc :)

    What do you recommend until MPAR supports my scenario?

    For test reasons I will change the refreshrate to 50Hz and see what happens :)
     
  6. davidf
    • Team MediaPortal

    davidf Development Group

    Joined:
    April 3, 2006
    Messages:
    796
    Likes Received:
    310
    Occupation:
    Application Architect
    Location:
    Scotland
    Ratings:
    +336 / 0
    Home Country:
    Scotland Scotland
    Show System Specs
    Unless your Monitor/TV is running at 50Hz I'd recommend not using MPAR for Live TV (A live source can't be manipulated in the same way other sources can). If your TV is at 50 then it depends on the exact refresh rate, even a little bit off can make the tsReaderBuffers run out over time. Movies on the otherhand are great, with dynamic refresh rate you only need 2 settings (if you don't like the switching) of 50 and 60 - MPAR will resample to get a better picture.
     
  7. FreakyJ
    • Team MediaPortal

    FreakyJ Development Group

    Joined:
    July 25, 2010
    Messages:
    4,021
    Likes Received:
    839
    Gender:
    Male
    Ratings:
    +1,424 / 1
    Home Country:
    Germany Germany
    I was watching a recording so it shouldn't run out of buffer or I'm wrong?


    I've changed the refresh rate to 50Hz and played the same recording again and now it looks better, there were three adjustments, but no stutter, will continue testing this evening while watching Tv :p
     
  8. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    01-03-2013 16:21:51.035 [12a8]----- Experimental noStopMod version -----
    01-03-2013 16:21:51.035 [12a8]---------- v0.0.70 XXX ------------------

    Does the TsReader.ax from 1.3.0 RC behave the same way? From TsReader.logs it is visible that the TsReader is trying to throttle the playback (not sure if it is caused by MPAR or TsReader itself).

    Also as a quick test you could rename that .ts file to .m2ts and let LAV splitter to be as source filter (if you have it installed). Just copy the renamed file under folder that is accessible from my videos and play from there.
     
  9. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Where in the log - I can't see any evidence of this ?
     
  10. FreakyJ
    • Team MediaPortal

    FreakyJ Development Group

    Joined:
    July 25, 2010
    Messages:
    4,021
    Likes Received:
    839
    Gender:
    Male
    Ratings:
    +1,424 / 1
    Home Country:
    Germany Germany
    @tourettes
    I've set my refreshrate back to 60Hz and renamed the recording to *.m2ts. Than I started the playback from within the videoplugin and had no issues :)
    I tried to simulate the exact behavior as before and it was working :)

    The Splitter&video-&audiodecoder were LAV
     
  11. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    I seem to have mixed up the pause that the seeking causes, my bad (been just too many years when I have gone thru the TsReader logs :)).
     
Loading...
Thread Status:
Not open for further replies.

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!