TSWriter deadlock potential fix. | Page 30

Discussion in 'Area 51 - Testing Area' started by DJBlu, December 21, 2012.

  1. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    To me it is a "no-brainer" - it should be included.
    Obviously I'm biased... :)
    As you say, even if the problem is not completely solved, the situation seems to be much better.


     
    • Like Like x 2
    • Agree Agree x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. nimrodel50

    nimrodel50 Portal Pro

    Joined:
    February 6, 2008
    Messages:
    67
    Likes Received:
    13
    Ratings:
    +27 / 0
    Home Country:
    Spain Spain
    I agree, it is much better and no regression appeared.
    Please add it to the new release.

    Thanks
     
    • Like Like x 2
  4. MaxT
    • Premium Supporter

    MaxT MP Donator

    Joined:
    December 9, 2009
    Messages:
    112
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    Russian Federation Russian Federation
    Hi everybody,

    Just installed 1.5 from 1.2... something and face the issue in question. Applied patches from this thread, issue is still in place.

    Steps taken: disable what should be disabled, clear logs, reboot, start MP & TV Configuration, run stress test on a group (I have 13 channels in that particular one, all 100% working) . Full tv server log attached. Error at [22:04:59,050] [Log ] [7 ] [INFO ] - Controller: Timeshifting failed ..... In TS writer there seems to something strange with threads - expected one does not appear after error takes place.

    PS: while testing with plugin enabled i tried to start recording, noticed an error in logs from the wery beginning of the recording, rebooted and then found out that recoding actually took place, ie i had two recorded files: before reboot and the one autostarted after reboot. Does this means that "disappeared thread" continued to record?

    What can I do to help tracing to the bottom of the issue?

    BR

    MaxT
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hello MaxT

    The reason is that TsWriter thinks the stream is scrambled:
    After that, each tune request is seeing:
    So it seems to me that TV Server stopped receiving any stream from the tuner driver. This could be related to the CAM.

    If you're able to reproduce again, try to see what happens if you remove and re-insert the CAM.

    mm
     
  6. MaxT
    • Premium Supporter

    MaxT MP Donator

    Joined:
    December 9, 2009
    Messages:
    112
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    Russian Federation Russian Federation
    Ok, will reproduce - its just a matter of time. Previously never tried to replug just CAM, restarting of tv service never helped and replug of USB card was nesessary.
     
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    What tuner are you using?
    Is it a TerraTec S7, TechnoTrend Connect S2-3650 CI, TechniSat SkyStar USB 2 HD CI... or is it a Twinhan, DigitalRise or Azurewave model?
     
  8. MaxT
    • Premium Supporter

    MaxT MP Donator

    Joined:
    December 9, 2009
    Messages:
    112
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    Russian Federation Russian Federation
    It is technisat USB 2 hd ci with latest driver from azurewave they have on their site.

    Ps: I was trying (not that hard though) to reflash it to terratec s7 or Elgato, to use more stable drivers, but only vid/pid change was not enough and never found native eeproms of those. Maybe sometimes will try again to change not only vid/pid, but manufacturer, etc. seems their drivers are checking something else.
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Okay.

    Hmmm, in the past I've seen that people have used TechnoTrend, Azurewave, Twinhan, TechniSat and TerraTec drivers interchangeably for certain products.
    Actually I've done the same for a TechniSat SkyStar S2 HD2 + CI, so I'm a bit surprised the driver ini file change doesn't work.

    In any case, the reason I asked about the tuner is because I know this behaviour is typical for those tuners. It has nothing to do with TsWriter, and AIUI doesn't matter which drivers or firmware you use. You can read this thread for some background:
    https://forum.team-mediaportal.com/threads/trouble-with-terratec-h7-and-cam.103398/

    Since this is nothing to do with a TsWriter deadlock I think it is best to stop the discussion here or move it to a different thread.
     
    • Thank You! Thank You! x 1
  10. MaxT
    • Premium Supporter

    MaxT MP Donator

    Joined:
    December 9, 2009
    Messages:
    112
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    Russian Federation Russian Federation
    OK, thank you very much!
    Will do home reading.

    BTW, what are most stable/reliable cards? Is it possible to have developers vision/comments on this in wiki?

    I am on x64 which requires signed drivers meaning that inf change is not possible :(
     
  11. mcraenz
    • Premium Supporter

    mcraenz MP Donator

    Joined:
    July 28, 2007
    Messages:
    647
    Likes Received:
    44
    Location:
    Auckland
    Ratings:
    +47 / 0
    Home Country:
    New Zealand New Zealand
    Show System Specs
    48 hours and all tuners still working correctly......
     
    • Like Like x 3
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!