Tswriter (1 Viewer)

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    Home Country
    United Kingdom United Kingdom
    Country flag
    Try the attached dll...

    (You should get lines like this - 'ConditionalAccess: WaitAfterDiSEqC setting xx ms' and 'SendDiseqcCommand: Wait after command xx ms' in TVService.log with xx = your 'WaitAfterDiSEqC' delay setting if it's working OK).

    Can you attach the logs and the 'dish.xml' file after you test it please.
     

    Attachments

    • TVE3_TBS_plus_DiSEqC_delays_3_MP121_15-12-18.zip
      199.4 KB · Views: 24
    Last edited:

    Normann

    MP Donator
  • Premium Supporter
  • November 21, 2018
    31
    4
    75
    Home Country
    Sweden Sweden
    Country flag
    That very line looks like this: "SendDiseqcCommand: Wait after command 10 ms", which not is the wished delay of 1000 ms.
     

    Attachments

    • dish.xml
      238 bytes · Views: 30
    • MediaPortalLogs_16_12_18__09_09.zip
      2.2 MB · Views: 25

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    Home Country
    United Kingdom United Kingdom
    Country flag
    Which folder is your 'dish.xml' file in please?

    TVService.log is saying 'ConditionalAccess: dish.xml - file not found' - it's looking in C:\ProgramData\Team MediaPortal\MediaPortal TV Server
     

    Normann

    MP Donator
  • Premium Supporter
  • November 21, 2018
    31
    4
    75
    Home Country
    Sweden Sweden
    Country flag
    The dish.xml is in C:\Program (x86)\Team MediaPortal\MediaPortal TV Server, I will move it over to C:\ProgramData\Team MediaPortal\MediaPortal TV Server and test.
     

    Normann

    MP Donator
  • Premium Supporter
  • November 21, 2018
    31
    4
    75
    Home Country
    Sweden Sweden
    Country flag
    Aha, this time I could get Euronews on LNB3 to start after BBC on LNB1. It required two tries though.
     

    Attachments

    • MediaPortalLogs_16_12_18__12_29.zip
      2.2 MB · Views: 24

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    Home Country
    United Kingdom United Kingdom
    Country flag
    Yes, it's loading the 'dish.xml' file correctly now:

    Code:
    [2018-12-16 12:16:03,586] [Log    ] [21       ] [INFO ] - ConditionalAccess: dish.xml - file loading
    [2018-12-16 12:16:03,602] [Log    ] [21       ] [INFO ] - ConditionalAccess: WaitAfterDiSEqC setting 1000 ms
     

    Normann

    MP Donator
  • Premium Supporter
  • November 21, 2018
    31
    4
    75
    Home Country
    Sweden Sweden
    Country flag
    Thank you!
    Can I upgrade to MP 1.21 from MP 1.21 pre when available, if I keep my dish.xml and my TVLibrary.dll
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    Home Country
    United Kingdom United Kingdom
    Country flag
    Probably 'yes', but I will be able to build a 'MP 1.21' version of the dll's with the changes included (after 1.21 is released).

    What value of 'WaitAfterDiSEqC' are you using now?
     

    Normann

    MP Donator
  • Premium Supporter
  • November 21, 2018
    31
    4
    75
    Home Country
    Sweden Sweden
    Country flag
    Starting with 1 sec I experienced some issue so thinking I set a long time to see and then decrease incrementally. For the time being I am at my first testing which is at 8 sec. Improvement from 1 sec but still sometimes have to restart channels to get them working. So, I figure there is another problem that the delay often covers???
    Attaching logs with the delay set to 8 sec.
     

    Attachments

    • MediaPortalLogs_17_12_18__10_31.zip
      2 MB · Views: 22

    Normann

    MP Donator
  • Premium Supporter
  • November 21, 2018
    31
    4
    75
    Home Country
    Sweden Sweden
    Country flag
    Value of "WaitAfterDiSEqC" is at 1 sec now. No improvement by prolonging it. There is still some issue now and then when starting a channel. It seems to happen when trying to start a channel on an other LNB then latest been used. I have logged a symptomatic situation: Watching CNBC on LNB2 and changing to Euronews on LNB3. It started working on the third try. Is it possible to get any usable data out of the logs concerning this?

    (Actually, I might have been wrong all along. There may be a better way to solv this problem than with the delay!!!)
     

    Attachments

    • MediaPortalLogs_19_12_18__16_13.zip
      1.9 MB · Views: 27
    • dish.xml
      190 bytes · Views: 25

    Users who are viewing this thread

    Similar threads

    Just to wrap this up I did eventually get MP2 installed, the above mentioned error was resolved once I uninstalled MP1. I then had firewall issues with MP2, the client could not see the server unless I turned the firewall off on the server, all rules seemed present and correct, so I eventually uninstalled MP2 as I needed a working...
    Just to wrap this up I did eventually get MP2 installed, the above mentioned error was resolved once I uninstalled MP1. I then had...
    I'm not quite sure what I've done, but somehow I seem to have broken our Mediaportal installation. I'm running it as a TV server...
    Replies
    6
    Views
    2K
    • Sticky
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: [MP1-5081] - WatchDog...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    0
    Views
    245
    In lieu of a likely modification to TV Setup module, I have devised my own workaround, using SQL. Here is a quick resume. Should be safe but make sure you have a backup before you try this! Simple scenario to demonstrate. 2 cards both on A/B diseqc switches. In each case A connects to LNB pointed at Satelite 1, and B to Sat 2...
    In lieu of a likely modification to TV Setup module, I have devised my own workaround, using SQL. Here is a quick resume. Should be...
    Started on: 2020-08-25 last update: 2020-08-25 Summary: Add the ability to sort or restrict channels by group in mapping dialog...
    Replies
    4
    Views
    507
    Today I did send a reminder to DD, since 09-2020 no news from them about new drivers. 3.0.2.211 x64 seems to work for me to, but DD told me, those where beta drivers, and some cards did have problems with them. Here you can find stable older drivers, Digital Devices Store But 3.0.3.224 did not work for me, so the latest stable...
    Today I did send a reminder to DD, since 09-2020 no news from them about new drivers. 3.0.2.211 x64 seems to work for me to, but...
    I recently upgraded my somewhat ancient 1.16 installation to the latest version, 1.25, and have a couple of problems, but the most...
    Replies
    16
    Views
    5K
    Just for your information: couldn't find the ns*.tmp file...
    Just for your information: couldn't find the ns*.tmp file...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    39
    Views
    2K
    Top Bottom