[Bug] TV Server configuration program stops responding when manually updating XMLTV EPG (2 Viewers)

greybox

MP Donator
  • Premium Supporter
  • January 23, 2009
    576
    93
    Canada Canada
    Country flag
    TV Server configuration program stops responding for a few minutes when manually updating the EPG via XmlTv plugin. It doesn't show hour glass, or "working" message, or something like that. The window just friezes - doesn't move, doesn't refresh. But then it unlocks itself and goes back to normal.

    Steps: Run the TV Server configuration program, go to properly configured and working XmlTv plugin, Mappings tab, Load/Refresh, Save, General, Force Import button, the window stops responding and no hour glass or anything for about 5 minutes (in my case - timing probably depends on the size of your database).
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    And this behaviour did not occur with the MP version you had installed before?

    I can not find anything inside the logs that XMLTV is run. I am quite sure that it should log the import process.... :confused:
     

    greybox

    MP Donator
  • Premium Supporter
  • January 23, 2009
    576
    93
    Canada Canada
    Country flag
    Honestly, it always worked like that. I think I even attempted to report it long time ago. Usually I don't care because XML update runs automatically in the background. But it becomes a little bit annoying when you do it manually. And my database is one analog provider, one digital and one satellite. Maybe being sluggish is normal, it is probabably a CPU intensive process, but we are definitely missing a progress indicator or at least a little hour glass icon. ;)

    Can you reproduce the issue at your end?
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    I am not using XMLTV at all. I use Clickfinder here.
    Not even sure about the setup of XMLTV to be honest..... :(
     

    Tgx

    Retired Team Member
  • Premium Supporter
  • January 22, 2008
    1,560
    1,115
    Italy Italy
    I can confirm this behaviour. This has been happening since before the release of Mediaportal 1.1.0. I do not remember the exact rc version though!
    If you wait for the xml importer to finish, the Tv setup starts responding again.

    Thanks

    Tgx
     

    greybox

    MP Donator
  • Premium Supporter
  • January 23, 2009
    576
    93
    Canada Canada
    Country flag
    infinite.loop: please check this set of logs, it is the latest one.
     

    jameson_uk

    Retired Team Member
  • Premium Supporter
  • January 27, 2005
    7,258
    2,528
    Birmingham
    United Kingdom United Kingdom
    Country flag
    This has been the case for a while (certainly 1.1 rcs)
    Is this a bug or new feature though? It does work but locks up configuration whilst running
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    Is this a bug or new feature though? It does work but locks up configuration whilst running
    If you ask me, then this is a bug since the main application "freezes" without an indication that something is done.

    Can you please mantis it?
    We need a proper import-progress indicator. :)
     

    greybox

    MP Donator
  • Premium Supporter
  • January 23, 2009
    576
    93
    Canada Canada
    Country flag
    Thanks everyone and special thanks to Chris! I didnt expect this to be taken so seriously! :D

    A little off-topic, but I noticed the dll in this release state version 1.1.5.0, not 1.2.0. It this something to be reported separately?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    toricred [solved] Configuring TV Server to use NAS General 1
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    O [solved] MP2.2.1 TV-Server Configuration wont start after initial installation General 10
    H MP2.2 client TV-Server configuration General 17
    splatterpop My optimized dvb epg configuration for tv server MediaPortal 1 Talk 0
    B Preview Channel in TV-Server Configuration not work Newcomers Forum 0
    K MP2 - V2.1 [MP2-763] Interface configuration for RTSP streaming server lost on every restart Older releases 6
    N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Television (MyTV frontend and TV-Server) 7
    N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Codecs, External Players 2
    A Keine Verbindung mit Kodi auf Server Allgemeines Support- und Diskussionsforum 10
    CyberSimian Unhandled exception in TV Server TV-Server 0
    Grisu002 Failed to startup - TV Server funktioniert nicht Allgemeines Support- und Diskussionsforum 0
    ajs [WiP] 5030: Add UHD Thumb size to TV Server MediaPortal 1 0
    T Client / Server slow channel-to-channel change (zapping) General Support 1
    T Server / client channel logo location Installation, configuration support 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    M TV Server can't tune to some DVB-S multiplexes while other software can General 0
    J TV Server setup question Newcomers Forum 0
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    I [solved] Connection to TV Server MySQL General Support 8
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    F After resume, TV Server connection screen is shown General Support 4
    R TV server crash with WintTV quadHD General 0
    R MP Server und Fileshare Einsteigerforum 4
    R [further infos missing] some movies freezing evry seconds Submit: Bug Reports 9
    Similar threads

























    Top Bottom