[solved] - Tv Server Fails to 'Preview' - Clients Fail to Display Tuned Channel

Discussion in 'Television (MyTV frontend and TV-Server)' started by nolanmedia, August 29, 2014.

  1. nolanmedia

    nolanmedia Portal Member

    Joined:
    April 8, 2012
    Messages:
    5
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Canada Canada
    Show System Specs
    Hi all, I've just rebuilt my TV server and had nothing but heartache... finally back to where I can scan for channels and am stumped at this: all channels scan fine but when I go to preview no window appears even though the Manual Control page indicates the tuner is time shifting. Clients are the same boat - appear to tune but nothing happens. Have performed a full clean and reinstall of MediaPortal with the same behaviour.

    PC Specs:
    MP 1.8
    XP Professional SP3 with all updates (aware not supported but still hoping)
    Dell 4600 P4 3.6
    3gb RAM
    Radeon 9550 AGP
    Hauppauge HVR - 1600 analog, QAM tuner



    Logs are attached. The nearest to errors I can find in these have not yielded me any answers when searched.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hello

    In case you aren't aware, "no support" means we don't make any commitment to help people who have problems running MP on it, or continue development (fixing, new features) in such a way that MP will continue to work on XP. With that being said, at this point MP does still work fine on XP (I can say this because I use XP myself) and I'm happy to try to help you. :)

    Here is the reason:
    Show Spoiler

    [2014-08-28 19:07:58,406] [Log ] [SetupTv ] [ERROR] - Exception :confused:ystem.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {B9559486-E1BB-45D3-A2A2-9A7AFE49B23F} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
    at SetupTv.Sections.Player.Play(String fileName, Form form)
    at SetupTv.Sections.FormPreview.ShowDialog(IWin32Window owner)
    at SetupTv.Sections.TvChannels.mpButtonPreview_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    It means that TsReader is not registered/installed. TsReader is the vital component that MediaPortal relies on to play live TV and recordings. If you don't have it installed then you're also not going to be able to preview.
    1. Did you install with admin privileges?
    2. Does this PC also have MediaPortal installed on it?
      • If yes, please check if there is a TsReader.ax in the MediaPortal install folder (typically C:\Program Files\Team MediaPortal\MediaPortal).
      • If no, please check if there is a TsReader.ax in the TV Server install folder (typically C:\Program Files\Team MediaPortal\MediaPortal TV Server).

    Can't speak for clients without log files from clients.

    Regards,
    mm
     
  4. nolanmedia

    nolanmedia Portal Member

    Joined:
    April 8, 2012
    Messages:
    5
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Canada Canada
    Show System Specs
    Thanks mm -
    I've had a chance to follow-up on this and unfortunately am no further.
    1. Installed dedicated server as admin and the Ts files are present.
    2. I did a full cleanup and reinstall of server & client package this time to see if that would make a difference. The log file is still showing the same error...

    Appreciate any further thoughts....
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    To be clear: this means TsReader.ax is present?
    If so, please do the following as administrator:
    1. Click start.
    2. Select "run...".
    3. Type "cmd" and click OK.
    4. Type cd "c:\Program Files\Team MediaPortal\MediaPortal" (ie. this should be the path to the folder where TsReader.ax is) and press enter.
    5. Type regsvr32 TsReader.ax.
    6. After step 5 there should be a success or fail message. Please take a screenshot of that and post it here.
    7. If step 5 is successful, try to reopen MediaPortal and/or TV Server configuration and try preview again.
    8. Post fresh log files after step 7 if it still fails.
    Thanks,
    mm
     
  6. nolanmedia

    nolanmedia Portal Member

    Joined:
    April 8, 2012
    Messages:
    5
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Canada Canada
    Show System Specs
    TsReader.ax is present in the MediaPortal folder. TsWriter.ax is present in the TvServer folder.
    Tried as instructed in the command line and failed with attached error displayed.
    Cheers -
     

    Attached Files:

  7. Vasilich
    • Team MediaPortal

    Vasilich Test Group

    Joined:
    August 30, 2009
    Messages:
    3,390
    Likes Received:
    608
    Gender:
    Male
    Occupation:
    Developer
    Location:
    Germany, Mayence
    Ratings:
    +1,172 / 2
    Home Country:
    Russian Federation Russian Federation
    Show System Specs
    your XP is 32bit, right?
     
  8. nolanmedia

    nolanmedia Portal Member

    Joined:
    April 8, 2012
    Messages:
    5
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Canada Canada
    Show System Specs
    Yep
     
  9. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
  10. nolanmedia

    nolanmedia Portal Member

    Joined:
    April 8, 2012
    Messages:
    5
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Canada Canada
    Show System Specs
    • Like Like x 1
  11. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    No problem - thanks for reporting back. Always good to hear a success report. :)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!