TVMosaic als Alternative für MP2 (3 Viewers)

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,845
    7,185
    Home Country
    Germany Germany
    Soweit ich mich erinnere klappt die Wiedergabe von LiveTV, EPG und das Planen von Aufnahmen. Zuletzt gab es noch ein kosmetisches Problem beim Senderwechsel, da konnte man den Hintergrund sehen. Das hatte ich im Skin Nereus korrigiert (schwarzer Hintergrund, dann erst VideoBrush).

    Durch die parallele Weiterentwicklung am SlimTv.Client sind ein paar neue Methoden nicht implementiert (6 Stück):
    1. public Task<AsyncResult<ISchedule>> CreateScheduleByTimeAsync(IChannel channel, string title, DateTime @from, DateTime to, ScheduleRecordingType recordingType)
    2. public Task<AsyncResult<ISchedule>> CreateScheduleDetailedAsync(IChannel channel, string title, DateTime @from, DateTime to, ScheduleRecordingType recordingType, int preRecordInterval, int postRecordInterval, string directory, int priority)
    3. public Task<bool> EditScheduleAsync(ISchedule schedule, IChannel channel = null, string title = null, DateTime? @from = null, DateTime? to = null, ScheduleRecordingType? recordingType = null, int? preRecordInterval = null, int? postRecordInterval = null, string directory = null, int? priority = null)
    4. public Task<bool> UnCancelScheduleAsync(IProgram program)
    5. public Task<AsyncResult<string>> GetRecordingFileOrStreamAsync(IProgram program)
    6. public Task<AsyncResult<IList<IProgram>>> GetProgramsForScheduleAsync(ISchedule schedule)
    Dann habe ich MP2 gestartet und es wurde mir die Senderliste angezeigt. Nach Auswahl eines Programms hängt sich MP2 auf.
    Vielleicht liegt das an der Menge von Sendern.
    Das ist wahrscheinlich, der Absturz hatte mit einem DirectX "Device Hung" zu tun (Grafikkarte musste zurückgesetzt werden).

    Den PC in Standby geht auch nicht, das verhindert der TVmosaik-Server.
    Ich habe den TvMosaic-Server auf meinem PC installiert, verwende ihn aber gerade nicht (auch keine Aufnahmen). Bei mir fährt Windows ganz normal in den Standby, wie es in Windows Energieoptionen konfiguriert ist.

    MP2 braucht in der Form keinen Power-Scheduler, sondern teilt Windows nur mit, wenn es aktiv bleiben muss, z.B. für Aufnahmen. Damit kann Windows alle Power-Anforderungen der gestarteten Anwendungen auswerten und wenn keiner aktiv sein muss in den Standby wechseln.
     

    harryzwo

    Portal Pro
    July 25, 2006
    793
    85
    Home Country
    Germany Germany
    Aufnehmen geht nicht. Wenn ich in der EPG eine Sendung anklicke und auf Aufnahme klickt passiert nicht. Im der Aufnahmetimer-Ansicht steht auch nichts. Versuche ich eine erweiterte Aufnahme geht zwar der Dialog auf, ich kann aber keine Sendung timern.
    Nach powercfg verhindert der TVMosaic-server den Standby(wenn ich das richtig interpretiere). Ich habe ein Hardcopy beigefügt.
     

    Attachments

    • tvmosaic.png
      tvmosaic.png
      31.9 KB

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,704
    2,842
    Stuttgart
    Home Country
    Germany Germany
    Aufnehmen geht nicht. Wenn ich in der EPG eine Sendung anklicke und auf Aufnahme klickt passiert nicht. Im der Aufnahmetimer-Ansicht steht auch nichts. Versuche ich eine erweiterte Aufnahme geht zwar der Dialog auf, ich kann aber keine Sendung timern.
    Nach powercfg verhindert der TVMosaic-server den Standby(wenn ich das richtig interpretiere). Ich habe ein Hardcopy beigefügt.
    Bitte das vorhandene Plugin im MP2-Client Verzeichnis mit diesem überschreiben. Danach sollten Einzelaunahmen funktionieren.
     

    Attachments

    • SlimTv.TvMosaicProvider.rar
      59.3 KB

    harryzwo

    Portal Pro
    July 25, 2006
    793
    85
    Home Country
    Germany Germany
    Ich habe das installiert. Jetzt kann ich eine Aufnahme planen. Die wird auch an der Mosaic-Server weiter geleitet. Nur in den Aufnahmeplänen wird nichts angezeigt.
    Weiß jemand wo die Timeshiftdatei hingeschrieben wird?
     

    Attachments

    • Aufnahme01.png
      Aufnahme01.png
      589 KB
    • Aufnahme02.png
      Aufnahme02.png
      1.1 MB

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,704
    2,842
    Stuttgart
    Home Country
    Germany Germany
    Ich habe das installiert. Jetzt kann ich eine Aufnahme planen. Die wird auch an der Mosaic-Server weiter geleitet. Nur in den Aufnahmeplänen wird nichts angezeigt.
    Weiß jemand wo die Timeshiftdatei hingeschrieben wird?
    Mit der TVE3.X ist die in C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer denke ich.
    Mit dem TVMosaic Plugin weiß ich es auch nicht. Du könntest mal während laufendem Live-TV mit dem Taskmanager schauen wo gerade viel auf die Festplatte zugegriffen wird. Oder alternativ mal im TVMosaic Forum nachsehen, wenn es das noch gibt.
     

    harryzwo

    Portal Pro
    July 25, 2006
    793
    85
    Home Country
    Germany Germany
    Jetzt geht wieder etwas mehr.
    Ich kann eine erweiterte Aufnahme programmieren. Allerdings werden diese nicht in den Aufnahmeplänen angezeigt, Auch die Aufnahmen selbst werden unter REC nicht angezeigt. Auch wenn ich auf Live-TV gehe werden nicht die richtigen Sendungen angezeigt.
    Ich habe versucht das in einem kleinen Video festzuhalten.
     

    Attachments

    • tvmosaic.zip
      5.1 MB

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,704
    2,842
    Stuttgart
    Home Country
    Germany Germany
    Danke, das Video macht es sehr anschaulich. @morpheus_xx kann hoffentlich etwas dazu sagen. Vielleicht ist dieser Teil einfach noch nicht integriert, muss nicht einmal ein Bug sein.
    Bekommst du keine Sender Logos? Diese sollten eigentlich automatisch erkannt werden.
     
    Last edited:

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,704
    2,842
    Stuttgart
    Home Country
    Germany Germany
    Nein Senderlogos habe ich bis jetzt noch keine gesehen.
    Hast du die Einstellungen unten aktiviert? Ich kann die Logos bei mir sehen. Ich lasse bei mir meist den Kanalname weg und zeige nur das Logo, das ist übersichtlicher.

    1639822434099.png


    1639822464168.png


    Schaue mal im Ordner: C:\ProgramData\Team MediaPortal\MP2-Server\Logos\Tv-Flat-Default
    Die Logos sollten dort automatisch hineingeladen werden. Ich habe es gerade nochmal getestet, den Logo-Ordner geleert und nach dem Neustart des Clients wurde die Logos wieder neu geladen.
    Falls es bei dir nicht funktioniert, entpacke mal das angehängte Archiv dort hinein und teste noch einmal.
     

    Attachments

    • Tv-Flat-Default.rar
      1 MB

    Users who are viewing this thread

    Similar threads

    Hi. Na ja, wenn ich so ein Programm schon selbst geschrieben habe, dann nutze ich das Programm natürlich auch selbst. Von daher bin ich da wohl nicht ganz unparteiisch. Wenn du Media-Buddy mal ausprobieren möchtes, den Link gibt es in meiner Signatur. Obwohl ein Ausstatten mit lokalen Metadaten grundsätzlich das mit Abstand Beste...
    Hi. Na ja, wenn ich so ein Programm schon selbst geschrieben habe, dann nutze ich das Programm natürlich auch selbst. Von daher...
    Hallo zusammen, ich hatte vor längerer Zeit das MP1 genutzt und dann eine Weile ausgesetzt. Derzeit baue ich einen HTPC zusammen...
    Replies
    3
    Views
    255
    Verkauft
    Verkauft
    Verkauft wird ein kompletter HTPC bestehend aus: OrigenAE S10V Gehäuse in schwarz ASUS STRIX Z270G Intel Celeron G3930 mit...
    Replies
    1
    Views
    144
    Wenn ich dich richtig verstehe, dann willst du nur EPG in MP2 haben, oder? Ich bin mir nicht sicher was du da programmieren willst. Probiere mal den EPGBuddy. Suche im Forum danach und du findest einen eigenen Thread dazu mit Anleitung. VDR sagt mir leider nichts. Kann ich dir leider nicht sagen. Schaue mal, dass du den letzten...
    Wenn ich dich richtig verstehe, dann willst du nur EPG in MP2 haben, oder? Ich bin mir nicht sicher was du da programmieren willst...
    Hallo, ich nutze seit vielen Jahren Linux VDR und überlege einen Umstieg auf MediaPortal. MP 2 läuft gerade auf einem Testsystem...
    Replies
    1
    Views
    356
    Hallo alle zusammen. Ich habe den Fehler nun endlich ausfindig gemachen. Die MP2 trifft keine Schuld. So wie es aussieht "blockiert" das CAM Modul die Tuner, weil sie "zugewiesen" sind. Obwol kein Modul enthalten ist, versuchen die Karten wohl darüber ein Signal zu erhalten oder zu entschlüssen. Dies schlägt fehl und blockiert so den...
    Hallo alle zusammen. Ich habe den Fehler nun endlich ausfindig gemachen. Die MP2 trifft keine Schuld. So wie es aussieht...
    Hallo. Ich habe ein Problem mit meiner TV Karte und eurer Software. Aus irgendeinen Grund findet die MP2 beim Sendersuchlauf keine...
    Replies
    6
    Views
    582
    Hallo! Danke für die Rückmeldung! Habe mit MP3 Playlist getestet, hat reibungslos funktioniert. Serie habe ich leider nicht. Ich habe nun die Audiodateien neu verbunden, diesmal habe ich Netzwerkpfad vom Server (\\SERVER\AUDIO\") statt das direkte Mapping wie "D:\Audio" verwendet. Nun wird nicht mehr jeder 2. Song übersprungen. Wow...
    Hallo! Danke für die Rückmeldung! Habe mit MP3 Playlist getestet, hat reibungslos funktioniert. Serie habe ich leider nicht. Ich...
    Hallo! ich habe ein Problem, dass bereits im Forum zu einer recht alten Version (2018) bereits einmal diskutiert wurde. Wenn ich...
    Replies
    7
    Views
    617
    Top Bottom