MP2 - V2.4.1 MP2 - V2.4 TVMosaic Provider for MP2 (3 Viewers)

AdHu86

Portal Member
January 14, 2022
41
50
Berlin
Home Country
England England
I installed the updated version. To avoid trouble I cleaned all settings prior.
As explained I added the TVMosaic share again and scheduled recordings. What can I say, everything was recorded and automatically visible under recordings! (y)
I didn’t try to watch a video while it’s still recording.
I can also confirm, that ma jam recordings do not work and also the sliding indicators on start and end do not appear. Two times I faced also black screens with only audio.
 

Brownard

Development Group
  • Team MediaPortal
  • March 21, 2007
    2,083
    1,614
    Home Country
    United Kingdom United Kingdom
    In logs I see several deadlocks related to Workflow Manager
    I've fixed this, it turned out to be a real deadlock, this also fixes the long delay I was seeing when showing the TV player's OSD when playback was first started.
    I can also confirm, that ma jam recordings do not work
    What's a "ma jam" recording? ;)
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,977
    3,124
    Stuttgart
    Home Country
    Germany Germany
    I've fixed this, it turned out to be a real deadlock, this also fixes the long delay I was seeing when showing the TV player's OSD when playback was first started.
    Was the deadlock only related to TVMosaic or in general? If in general we should also merge the fix into the WIP2.4.1 branch.
    I believe I saw the issues also with TVE3.X.
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,083
    1,614
    Home Country
    United Kingdom United Kingdom
    Was the deadlock only related to TVMosaic or in general? If in general we should also merge the fix into the WIP2.4.1 branch.
    I believe I saw the issues also with TVE3.X.
    It was a general issue, I think it was just more likely when using TvMosaic due to a difference in timings. I'll merge it in to 2.4.1 along with the PluginManager fix.
     

    Timhoh1234

    Portal Pro
    September 29, 2015
    234
    72
    Home Country
    Germany Germany
    Sorry for the delay, I was busy last days.
    I can also confirm the changes are working, good job! I’ve also black tv image sometimes, but it’s random. Let me know, if logs help or I can delivery something else.
    I didn’t try manual recordings, so no statement about it possible from my side.
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,135
    1,507
    Home Country
    Germany Germany
    Looking good for me too, well done.
    A couple of questions though which could be down to my unfamiliarity with MP2, firstly is there a simple way to stop a recording that is in progress and secondly delete a recording? The sub menu does not offer either option, see screenshot. In MP1 I both stopping the recording and deleting a recording can be actioned via a press on the record button.

    del.jpg
     
    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,135
    1,507
    Home Country
    Germany Germany
    I needed to do a clean install of the latest version, update bombed out trying to write to the Registry, quite common for me. Just noticed Online videos is missing again in this version.:(
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,977
    3,124
    Stuttgart
    Home Country
    Germany Germany
    firstly is there a simple way to stop a recording that is in progress
    Context menu on the related EPG entry or schedule offers an option to cancel the recording. I believe pressing the recording button can also work. If you are watching another channel it should offer the options "stop current recording, record this program and stop the other, ...". But I do not record besides for testing by myself, so I'm not expert.

    secondly delete a recording?
    I've an option in the context menu of recordings:
    1656443989045.png

    I think you didn't enter credentials correctly, then the option is not shown. MP2 needs full access to the share.
     

    Users who are viewing this thread

    Top Bottom