MP2 - V2.4.1 MP2 - V2.4 TVMosaic Provider for MP2 (4 Viewers)

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    2,135
    1,507
    Home Country
    Germany Germany
    @joecrow I have now implemented deleting TvMosaic recording files. I cannot reproduce the missing delete option for other media though, that seems to be present and correct here.
    I can confirm that deleting TV Mosaic recordings is now working.(y) Regarding the delete option missing from other media, sorry that may be my mistake. On retesting with the MP 2.4 release version I have found that some movies and vids in my collection also do not offer the delete option, seems neither version will offer to delete image files (.iso). I have a number of movies etc. in .iso format which unfortunately I must have picked for the test with the TV Mosaic version but not for the MP 2.4 release in my earlier test.:oops:
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,974
    3,123
    Stuttgart
    Home Country
    Germany Germany
    @Brownard, in German forum the user @harryzwo reported not being able to get a connection between client and TVMosaic server. The IP-address field reamins always empty, also after entering something and going back to the same settings. I had the same issue before and solved it be removing all my settings. For him even this does not help. The error logs just say:
    [2022-06-29 10:31:36,147] [11629 ] [35 ] [ERROR] - TvMosaic: Could not initialize connection. Status: STATUS_CONNECTION_ERROR;

    Do you have any idea?
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,974
    3,123
    Stuttgart
    Home Country
    Germany Germany
    For TVMosaic I see currently a very good progress. The onlyopen issues coming to my mind are:
    • Missing recording indicator (blinking red dot and start/stop)
    • Partly black image with only audio (Could be a difficult point, because seems not systematic) @Brownard did you never face it? If not, I can offer my PC for debugging and I can also do tests with GraphStudio if needed
    • Partly the connection from client to TVMosaic server is not possibe (the entered IP-address is not kept and the field remains empty). For my removing everything and reinstalling helped, for another user it did also not help
    • EDIT: Context menu options to stop recordings are missing.
     
    Last edited:

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,135
    1,507
    Home Country
    Germany Germany
    Also agree, but let's leave the problems occuring independently from TVMosaic out here, we can address them to the general "TV-Rework", which is in progress.

    Not sure if you are aware that in the TVE version there is a Stop Recording option, see attached screenshot so the issues does seem to be a TV Mosaic only one.

    epg.jpg
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,974
    3,123
    Stuttgart
    Home Country
    Germany Germany
    Not sure if you are aware that in the TVE version there is a Stop Recording option, see attached screenshot so the issues does seem to be a TV Mosaic only one.

    View attachment 210440
    That was also what I remembered and mentioned, but couldn’t try to verify myself in the end. Good to know, it means something isn’t really working only in TVMosaic branch.
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,083
    1,614
    Home Country
    United Kingdom United Kingdom
    @Brownard, in German forum the user @harryzwo reported not being able to get a connection between client and TVMosaic server. The IP-address field reamins always empty, also after entering something and going back to the same settings. I had the same issue before and solved it be removing all my settings. For him even this does not help. The error logs just say:
    Looking at the logs it looks like that on at least some of the occasions the MP2 Client wasn't connected to the MP2 Server, the TvMosaic settings are stored on the MP2 server so if the server isn't connected the settings will be empty/won't update on the client. They are stored on the server so that any recordings shares located on the server have access to the settings, however there's probably room for improvement here by keeping a local copy of the settings on the client because technically the TvMosaic client doesn't need the MP2 Server to work.
     

    Users who are viewing this thread

    Top Bottom