MP2 - V2.4.1 MP2 - V2.4 TVMosaic Provider for MP2 (4 Viewers)

Brownard

Development Group
  • Team MediaPortal
  • March 21, 2007
    2,134
    1,476
    Home Country
    United Kingdom United Kingdom
    Logs attached. All files are existing as in your screenshot:
    Thanks, I think I found it, for client debug builds the plugin was being built as x86 rather than AnyCPU so was copied to the wrong directory, (bin/x86/Debug as in your screenshot when it should be bin/Debug) so it was not being loaded by the Client. It should work OK in Release builds, or pull the solution changes I just pushed and build again.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,948
    2,979
    Stuttgart
    Home Country
    Germany Germany
    Thanks, I think I found it, for client debug builds the plugin was being built as x86 rather than AnyCPU so was copied to the wrong directory, (bin/x86/Debug as in your screenshot when it should be bin/Debug) so it was not being loaded by the Client. It should work OK in Release builds, or pull the solution changes I just pushed and build again.
    Playback starts now, but I have the next issue. I hear the sound of the recording, so something is playing, but no video. Additionally the "pause" icon is always shown and no progress and further infos in player controls.

    I cleaned and rebuild the solution already, no change. Error logs are empty and nothing suspicious in client logs. Same for release and debug builds.

    Screenshot while I play a recording and hear audio:
    Unbenannt.jpg


    Edit: If you have any idea and there is something to check by myself, let me know.
     
    Last edited:

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,134
    1,476
    Home Country
    United Kingdom United Kingdom
    Playback starts now, but I have the next issue. I hear the sound of the recording, so something is playing, but no video. Additionally the "pause" icon is always shown and no progress and further infos in player controls.
    Yes the current player was a hack, though I was still getting video. I've pushed some changes which include a better player which seems to work properly and you should now get thumbnails. You'll need to remove the share and reimport so the recordings get the correct mime type for the player. If you still don't get video I'll need a full debug log.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,948
    2,979
    Stuttgart
    Home Country
    Germany Germany
    Yes the current player was a hack, though I was still getting video. I've pushed some changes which include a better player which seems to work properly and you should now get thumbnails. You'll need to remove the share and reimport so the recordings get the correct mime type for the player. If you still don't get video I'll need a full debug log.
    That was a step further, but one issue remains.
    Thumbnails of recordings appear now. The player controls are also visible now.
    But I still can just hear audio and do not see video. Live-Tv and other recordings work normally.
    Unbenannt.jpg


    Logs attached
     

    Attachments

    • Log.rar
      58 KB

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,948
    2,979
    Stuttgart
    Home Country
    Germany Germany
    @Brownard
    Unfortunately I found also another issue. I've 3 grouped "manual recordings". I still can not play those at all, message is again "no player ...".
    Related client logs attached.
    Unbenannt.jpg
     

    Attachments

    • ClientError.log
      40 KB
    • Client.log
      495.1 KB

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,134
    1,476
    Home Country
    United Kingdom United Kingdom
    Thanks, it's a bit strange as no video tracks are detected for this first file, and those other files just cause the source filter to throw an unknown error. Can you manually paste the stream links in your web browser, which should cause the files to be downloaded (I get an mpeg file), and see if they play OK in another player to rule out TvMosaic breaking them somehow when streaming..
    This is your no video link
    This is one of your error links
    (Right click and click copy link address as the forum truncates the link text)

    If you can, try and avoid VLC player as it doesn't use DirectShow like MP2 does, best would be to import the files into MP2 and try in there but worth testing on Windows Media Player or the windows 'Films & TV' player first.
     

    ge2301

    Lead Design MP2
  • Team MediaPortal
  • January 11, 2014
    7,948
    2,979
    Stuttgart
    Home Country
    Germany Germany
    Thanks, it's a bit strange as no video tracks are detected for this first file, and those other files just cause the source filter to throw an unknown error. Can you manually paste the stream links in your web browser, which should cause the files to be downloaded (I get an mpeg file), and see if they play OK in another player to rule out TvMosaic breaking them somehow when streaming..
    This is your no video link
    This is one of your error links
    (Right click and click copy link address as the forum truncates the link text)

    If you can, try and avoid VLC player as it doesn't use DirectShow like MP2 does, best would be to import the files into MP2 and try in there but worth testing on Windows Media Player or the windows 'Films & TV' player first.
    I tried playback with WMP and also imported them into MP2 as normal videos, they are playing without issues.
    I also removed 2/3 files to see, if "grouping" or recordings has an effect, but same result. Anything else I can try or deliver? In case debugging on my system is faster, we can also do it quickly, but in 20 minutes I've to leave.
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,913
    7,276
    Home Country
    Germany Germany
    Thanks @Brownard and @ge2301 for your work (y)
    I had started implementing a basic listing of recordings via API, but I got not so far as I hoped (no time). Your approach does better integrate with MP2's media library.
    I will go through the list of open issues and try to help, like moving settings to server side...
     

    Brownard

    Development Group
  • Team MediaPortal
  • March 21, 2007
    2,134
    1,476
    Home Country
    United Kingdom United Kingdom
    @ge2301 could you upload one of your recordings that doesn't play? Looks like you've got a small 1 min one that shouldn't be too big.
     

    Users who are viewing this thread

    Similar threads

    • Sticky
    Good job, nice release as usual (y)
    Good job, nice release as usual (y)
    We are proud to present MediaPortal 2.4 MediaPortal 2.4 is a full-blown media center software that addresses most common user...
    Replies
    5
    Views
    2K
    • Sticky
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: New: Improvement /...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    0
    Views
    287
    Sorry for the late reply Nope, but I haven't given up... just moved it asside for the moment. I like MP1 but suppor for it is flagging, MP2 is a contender but compared to the flexibility of MP1 (especially in terms of video file naming) it seems to be much more rigid (I may have read the documentation wrong). I don't feel like...
    Sorry for the late reply Nope, but I haven't given up... just moved it asside for the moment. I like MP1 but suppor for it is...
    I have been a relatively happy user of MP1 for quite a while. My setup is a dedicated HTPC connected to my TV, a TV capture device...
    Replies
    3
    Views
    990
    We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common user requirements out of the box. Aside from its support for Live TV and Radio, it offers a complete media server for music, movies, and TV shows. Info is automatically downloaded from various sources to...
    We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common...
    We are proud to present MediaPortal 2.3.1 MediaPortal 2.3.1 is a full-blown media center software that addresses the most common...
    Replies
    0
    Views
    2K
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me over the edge for sure.;)
    It is looking and working very well now and I am almost at the point of switching my HTPC to MP2, madvr would definitely push me...
    We are proud to present MediaPortal 2.3 MediaPortal 2.3 is a full-blown media center software that addresses the most common user...
    Replies
    4
    Views
    3K
    Top Bottom