TvServer won't create database (MySQL)

Discussion in '1.0 RC1 and SVN Builds' started by Valk, April 19, 2008.

  1. Valk

    Valk Portal Pro

    Joined:
    February 25, 2006
    Messages:
    302
    Likes Received:
    93
    Ratings:
    +138 / 0
    Home Country:
    Australia Australia
    Show System Specs
    Using 1.0 RC1 Refresh the setupTv.exe deletes the old TvLibrary correctly (which means it connects fine) but doesn't create the database properly.

    I'm using a remote server for my database (linux MySQL server) with and without case sensitivity. Not been case sensitive worked with the older svn builds.

    the only logs generated are by tv.log.

    2008-04-19 11:50:23.484375 [1]: ---- start setuptv V0.9.1.18808----
    2008-04-19 11:50:23.500000 [1]: ---- check connection with database ----
    2008-04-19 11:50:23.828125 [1]: ---- check if database needs to be updated/created ----
    2008-04-19 11:50:23.875000 [1]: ---- create database ----
    2008-04-19 11:50:23.921875 [1]: Exec SQL: DROP DATABASE IF EXISTS TvLibrary;CREATE DATABASE IF NOT EXISTS TvLibrary;USE TvLibrary;

    If you let SetupTv.exe run it eventually times out and closes.

    I decided to try anyway and manually ran the last query in the log and found it ran without warning or error.



    Anyone got any ideas?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. rtv
    • Team MediaPortal

    rtv Retired Team Member

    Joined:
    April 7, 2005
    Messages:
    3,622
    Likes Received:
    301
    Occupation:
    CTO at ES2000
    Location:
    Osnabruck
    Ratings:
    +301 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Maybe your installation has been INNODB (no drop because of Key constraints) or the database was still in use?
     
  4. Valk

    Valk Portal Pro

    Joined:
    February 25, 2006
    Messages:
    302
    Likes Received:
    93
    Ratings:
    +138 / 0
    Home Country:
    Australia Australia
    Show System Specs
    In the end I just looked at the source and manually ran the SQL script, worked in the end so i'll just leave it at that since no one else seems to have issues.
     
  5. rebreather

    rebreather Portal Pro

    Joined:
    December 10, 2006
    Messages:
    60
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Denmark Denmark
    Hi.
    Been sitting here all day and tried to get RC1 to work but no luck.
    When i open up tvserver conf. i just get the error say "Failed to create the database"
    Tried to install 18566 again but get the same fail there. Also tried to reinstall SQL sever again.
    Any goor ideas??????

    Thanks
    Lars
     
  6. Gent32m

    Gent32m Portal Member

    Joined:
    December 23, 2007
    Messages:
    31
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Belgium Belgium
    Hi,

    I had also this problem (but it was not on linux)

    jonaskp posted me a solution that worked !

    Did you have SQL server installed before? Because there used to be a bug where it couldnt create the database, because it was already there, even if you uninstalled SQL server. If youre using MSSQL, try going to:
    C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data and delete TVlibrary and tvlibrary_log.

    Then Try again.
     
    • Like Like x 1
  7. Paranoid Delusion
    • Team MediaPortal

    Paranoid Delusion Moderation Manager

    Joined:
    June 13, 2005
    Messages:
    13,062
    Likes Received:
    1,481
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Cheshire
    Ratings:
    +1,482 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  8. rebreather

    rebreather Portal Pro

    Joined:
    December 10, 2006
    Messages:
    60
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Denmark Denmark
    Thanks a lot.
    Deleted the files and are up running again.

    Thanks

    Lars
     
  9. BuUrMaN
    • Premium Supporter

    BuUrMaN MP Donator

    Joined:
    July 21, 2007
    Messages:
    28
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Netherlands Netherlands
    Thx, worked for me also!!
     
  10. Hojou

    Hojou Portal Pro

    Joined:
    January 10, 2007
    Messages:
    69
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Denmark Denmark
    I get the same error when trying to install.

    No databases - except the system databases when i go look with the enterprise manager.

    I get the same error, no matter which of the three database options i pick (mssql, mysql, and existing mssql). With the existing mssql i even Test the connection which runs green and i still get that error.
     
  11. rtv
    • Team MediaPortal

    rtv Retired Team Member

    Joined:
    April 7, 2005
    Messages:
    3,622
    Likes Received:
    301
    Occupation:
    CTO at ES2000
    Location:
    Osnabruck
    Ratings:
    +301 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Well since we know it is fixed in SVN it would be nice if you either:
    - test the lastest snapshot or
    - provide us with logs so we can see you're suffering from the same issue..
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!