TvServer won't create database (MySQL) (1 Viewer)

Valk

Portal Pro
February 25, 2006
302
108
Australia Australia
Using 1.0 RC1 Refresh the setupTv.exe deletes the old TvLibrary correctly (which means it connects fine) but doesn't create the database properly.

I'm using a remote server for my database (linux MySQL server) with and without case sensitivity. Not been case sensitive worked with the older svn builds.

the only logs generated are by tv.log.

2008-04-19 11:50:23.484375 [1]: ---- start setuptv V0.9.1.18808----
2008-04-19 11:50:23.500000 [1]: ---- check connection with database ----
2008-04-19 11:50:23.828125 [1]: ---- check if database needs to be updated/created ----
2008-04-19 11:50:23.875000 [1]: ---- create database ----
2008-04-19 11:50:23.921875 [1]: Exec SQL: DROP DATABASE IF EXISTS TvLibrary;CREATE DATABASE IF NOT EXISTS TvLibrary;USE TvLibrary;

If you let SetupTv.exe run it eventually times out and closes.

I decided to try anyway and manually ran the last query in the log and found it ran without warning or error.

Anyone got any ideas?
 

rtv

Retired Team Member
  • Premium Supporter
  • April 7, 2005
    3,622
    301
    Osnabruck
    Germany Germany
    Maybe your installation has been INNODB (no drop because of Key constraints) or the database was still in use?
     

    Valk

    Portal Pro
    February 25, 2006
    302
    108
    Australia Australia
    In the end I just looked at the source and manually ran the SQL script, worked in the end so i'll just leave it at that since no one else seems to have issues.
     

    rebreather

    Portal Pro
    December 10, 2006
    60
    0
    Denmark Denmark
    Hi.
    Been sitting here all day and tried to get RC1 to work but no luck.
    When i open up tvserver conf. i just get the error say "Failed to create the database"
    Tried to install 18566 again but get the same fail there. Also tried to reinstall SQL sever again.
    Any goor ideas??????

    Thanks
    Lars
     

    Gent32m

    Portal Member
    December 23, 2007
    31
    1
    Belgium Belgium
    Hi,

    I had also this problem (but it was not on linux)

    jonaskp posted me a solution that worked !

    Did you have SQL server installed before? Because there used to be a bug where it couldnt create the database, because it was already there, even if you uninstalled SQL server. If youre using MSSQL, try going to:
    C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data and delete TVlibrary and tvlibrary_log.

    Then Try again.
     

    Hojou

    Portal Pro
    January 10, 2007
    69
    0
    Denmark Denmark
    I get the same error when trying to install.

    No databases - except the system databases when i go look with the enterprise manager.

    I get the same error, no matter which of the three database options i pick (mssql, mysql, and existing mssql). With the existing mssql i even Test the connection which runs green and i still get that error.
     

    rtv

    Retired Team Member
  • Premium Supporter
  • April 7, 2005
    3,622
    301
    Osnabruck
    Germany Germany
    I get the same error when trying to install.

    No databases - except the system databases when i go look with the enterprise manager.

    I get the same error, no matter which of the three database options i pick (mssql, mysql, and existing mssql). With the existing mssql i even Test the connection which runs green and i still get that error.
    Well since we know it is fixed in SVN it would be nice if you either:
    - test the lastest snapshot or
    - provide us with logs so we can see you're suffering from the same issue..
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom