[confirm] - tvservice dying very often | Page 2

Discussion in 'MediaPortal 1.1.0 RC 1 & 2' started by dingo, March 2, 2010.

  1. vvulture
    • Premium Supporter

    vvulture MP Donator

    Joined:
    June 3, 2006
    Messages:
    477
    Likes Received:
    6
    Gender:
    Male
    Occupation:
    Electronic Security Technician
    Location:
    Sydney
    Ratings:
    +7 / 1
    Home Country:
    Australia Australia
    Having same problem here. Initial install of RC1 was ok for days on end..., but last couple of days TV Service has been locking up. Only remedy is to shutdown and restart server.
    I know i am using WHS and it is not supported, but WHS is likely not the cause... All has been ok until the last few days.

    cheers

    Logs attached.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. dingo
    • Premium Supporter

    dingo MP Donator

    Joined:
    October 2, 2006
    Messages:
    81
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Norway Norway
    Hello again! As vvulture I also had a perfect system running for a while. Anyhow. I have replaced your file and still same problem same procedure. I start tvservice on server and then start tvfine on client. I can change channel and all is well. When I then stop tv with stop button and close mediaportal I am not able to start mediaportal again because tvservice has died.

    New logs with system running the edited file attatched :)

    - dingo
     
  4. vgallego65
    • Premium Supporter

    vgallego65 MP Donator

    Joined:
    January 26, 2006
    Messages:
    171
    Likes Received:
    7
    Ratings:
    +7 / 0
    Home Country:
    Spain Spain
    Hello I am also having the same kind of problem related here. I always had tvservice working properly but with new version rc1 is impossible to get it working.
    I have made a total fresh installation of mediaportal including a fresh installation of windows 7. I am about to drive me crazy.

    logs attached.
     
  5. olivvvv

    olivvvv Portal Pro

    Joined:
    April 20, 2009
    Messages:
    114
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    France France
    same for me.

    sometimes, i have tvserver lost.
     
  6. ARE2

    ARE2 Portal Pro

    Joined:
    May 9, 2008
    Messages:
    166
    Likes Received:
    8
    Location:
    Germany
    Ratings:
    +9 / 0
    Home Country:
    Poland Poland
    Hi,

    seems that I have similar problems in a multiseat environment.

    Yesterday e.g. I was watching TV on a client (Single) and then stopped/turned TV of on it and in this moment TVService on server died an killed the whole machine that moment :( This happens quiet randomly, but I realised that turning of CI (Hauppauge) in tv server config (so no cam is used) and switching it of from usb/power seems to cure the problem!?

    Will try to provide Logs later when I'm back at home.


    Regards
    ARE2
     
  7. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    10,946
    Likes Received:
    4,712
    Ratings:
    +6,752 / 11
    Home Country:
    Germany Germany
    Show System Specs
    AW: Re: tvservice dying very often

    question: did you place the interface.dll also inside MediaPortal folder ?! (not only tvserver!)

    strange thing that it crashes always after the TT callback. I've put this critical calls into a try/catch. please test this tvlibrary.
     

    Attached Files:

    • TVLibrary.zip
      File size:
      30.6 KB
      Uploaded:
      March 3, 2010
      Views:
      99
  8. dingo
    • Premium Supporter

    dingo MP Donator

    Joined:
    October 2, 2006
    Messages:
    81
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Norway Norway
    Yes I put it on both server and client. My server does not run mediaportal so I have no mediaportal folder there
     
  9. vgallego65
    • Premium Supporter

    vgallego65 MP Donator

    Joined:
    January 26, 2006
    Messages:
    171
    Likes Received:
    7
    Ratings:
    +7 / 0
    Home Country:
    Spain Spain
    I have test both library dll posted without success. The same problem remain and tv works properly the first time and after exit from mediaportal the second time you attempt to start television mediaportal crashes.
     
  10. porky996t
    • Premium Supporter

    porky996t MP Donator

    Joined:
    May 21, 2008
    Messages:
    1,013
    Likes Received:
    75
    Gender:
    Male
    Occupation:
    Chartered Surveyor
    Location:
    Bolton, Lancashire, England
    Ratings:
    +82 / 0
    Home Country:
    England England
    Show System Specs
    Just a quick note to say that I see to be having the same problems as noted above. If MP is left a while and I then go into the TV Guide and choose a channel it just locks up. I have to Ctrl+At+Del to get Task Manager up so I can reboot.
     
  11. dingo
    • Premium Supporter

    dingo MP Donator

    Joined:
    October 2, 2006
    Messages:
    81
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Norway Norway
    I have been testing alot now .. Havn't had a crash since installing this library, however for each time I start mediaportal again it adds 1,5sec before tuning channel on first tune. Other tunings is normal.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!