TVService (EPG grabbing when idle) preventing Standby | Page 2

Discussion in '1.2.x' started by doveman, January 11, 2012.

  1. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    If you look at my second post, you'll see that I identified this as a fault in the EPG grabber. Disabling the part of MP that causes the problem isn't really a solution.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Is it possible to schedule EPG grabbing for a specific time, or was this just something that someone suggested? If it is possible, this might help.

    At the end of the day, it is hard to tell whether this is a bug or not. The TV server is busy. You wouldn't want it going to sleep while someone was watching TV on a network client, or recording, and EPG grabbing is essential for the TV to work correctly.

    Mark
     
  4. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I don't think there's an EPG scheduling feature yet. There seems to be several bugs anyway:

    Doing "EPG update when idle" even when this is disabled.

    Setting "Kernel Legacy Caller", preventing standby, when updating the EPG and not clearing it when EPG grabbing finishes.
     
  5. NeefSimpel

    NeefSimpel New Member

    Joined:
    June 9, 2009
    Messages:
    2
    Likes Received:
    1
    Gender:
    Male
    Occupation:
    System administrator
    Location:
    Zoetermeer
    Ratings:
    +1 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hi all,

    I just want to check what the status is on this I see the post saying "Confirm" but what does this mean?

    Since MP 1.2.2 came out I have this issue, and I can confirm that the "Kernel Legacy Caller" is there. If I change the function "EPG grabbing while idle" It disappears. And the machine is going to standby again.

    Would be nice to see this gets resolved. I managed to reinstall my HTPC already 2 time, before I figured out it was MP causing it. At first I was looking at system drivers.

    Edwin
     
  6. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Just bumping this. Would be nice to have it acknowledged as a bug at least, as it's never going to get fixed otherwise.
     
  7. frankytv

    frankytv Portal Pro

    Joined:
    November 17, 2009
    Messages:
    56
    Likes Received:
    4
    Occupation:
    Programmer - Hardware developer
    Ratings:
    +4 / 0
    Home Country:
    Germany Germany
    Show System Specs
    This standby problem bothers me every day :(
     
  8. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I will put this into mantis, even though I have not been able to confirm it.
     
    • Like Like x 1
  9. doveman

    doveman Portal Pro

    Joined:
    February 12, 2008
    Messages:
    2,326
    Likes Received:
    166
    Ratings:
    +182 / 3
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  10. nimrodel50

    nimrodel50 Portal Pro

    Joined:
    February 6, 2008
    Messages:
    67
    Likes Received:
    13
    Ratings:
    +27 / 0
    Home Country:
    Spain Spain
    this happens to me also, if I disable the epg when idle the computer goes to sleep normaly otherwise never goes to sleep.
     
  11. elliottmc
    • Premium Supporter

    elliottmc Retired Team Member

    Joined:
    August 7, 2005
    Messages:
    14,927
    Likes Received:
    4,011
    Gender:
    Male
    Location:
    Cardiff, UK
    Ratings:
    +5,503 / 13
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!