[solved] Umsteiger MP1 zu MP2 (2 Viewers)

rbo

Portal Pro
May 1, 2007
398
23
Ludwigsburg
Germany Germany
Country flag
Hallo zusammen,

ich habe am letzten Wochenende mal wieder den Schritt gewagt, parallel zu meiner produktiven MP1 Installation, MP2 zu installieren.
Die Forumsbeiträge habe ich immer überflogen und war jetzt der Meinung, 2.2.2 könnte mal wieder ein Versuch wert sein.
Die letzten Versuche waren mehr oder weniger nur ein 'Reinschnuppern'.

Gleich vorneweg, großes Lob an die MP2-Entwickler!!!

Ich bin echt begeistert, wie man mit eigentlich wenig Aufwand diese Parallelinstallation hinbekommt. Dazu habe ich mir eine kleines Batch geschrieben, welches mir erlaubt mit einem Doppelklick die eine oder die andere Installation zu aktivieren.

Bei der Umstellung habe ich mich zuerst mit dem LiveTV und dem neuen TV-Server (besser MP2-Server) beschäftigt.
Das war, wegen der Ähnlichkeit zu MP1, keine größere Herausforderung. Alles in Allem (Sendersuch und -sortierung, EPG) war ich nach ca. einer Stunde durch.

Die Einrichtung des MP2-Client (Single-Server), war dann der erste große Unterschied zu MP1. Allerdings, wenn man das Wiki und die einschlägigen Umstiegsthreads (vielen Dank an Lehmden!) aufmerksam durchliest, auch gut machbar. Ich konnte also eine weiter halbe Stunde später schon fernsehen.
Meine erster Eindruck zum LiveTV in MP2: sehr smooth!
Es fühlt sich alles etwas stimmiger an, mehr wie 'richtiges Fernsehen'. Ich kanne es nicht besser erklären ist auch nur mein persönlicher Eindruck. Durch den Import meines Aufnahme-Schedulers, waren auch meine geplanten Aufnahmen schon integriert (und laufen auch perfekt!).

An die Radio-Funktion muss ich mich aber erst gewöhnen. Der direkte Einstieg in MP1 hat mir da doch besser gefallen. Vielleicht schaue ich mir aber auch das Webradio Plugin mal genauer an.

Angespitzt durch die schnellen Ersterfolge, machte ich mich dann an die Einbung meiner größeren Medienansammlung (ca. 1000 Filme, diverse Serien und vor allem meine, mir wichtige, CD/MP3 Sammlung). Hier stolperte ich als erstes über die notwendige Anmeldung an meiner NAS, was mir fast einen halben Tag kostete. Unter MP1 habe ich einfach UNC-Pfade den jeweiligen Medien zugewiesen und eingebunden. Jetzt wurden diese Verzeichnisse in MP2 nicht erkannt. Nach der Anmeldung war es dann sofort möglich die jeweiligen Verzeichnisse in der Medienbibliothek auszuwählen.

Hierzu vielleicht ein Tipp:
Wenn man den Menüpunkt für die 'Netzwerk Zugangsdaten' vor die 'Medienquellen-Konfiguration' gesetzt hätte, hätte ich mir leichter getan. Ich bin einfach der Reihe nach vorgegangen und habe dann erst einmal auf meiner NAS nach den Freigaben gesucht. :)

Danach war es dann wirklich easy.
Was folgte, war eine gefühlte Ewigkeit warten, bis die Mediendaten gescannt waren. Was aber zu erwarten war und kein Kritikpunkt ist!

Am nächsten Morgen dann der bange Blick, hat MP2 alles gefunden...
Und hier konnte man sehen, wo die Prioritäten gesetzt sind: Filme und Serien waren auf Anhieb vorhanden, inklusive aller FanArts und Beschreibungen. Ok, hier habe ich die gewisse Vorarbeit (nfo-Files usw.) geleistet.

Bei meiner CD-Sammlung war ich dann echt enttäuscht. Trotz peinlichst genau getaggter Files nichts. Keine FanArt oder Beschreibungen. Hier musste ich dann in verschiedenen Threads lesen, dass doch noch einiges an Arbeit vor mir liegt. Da hatte ich schon erwartet, dass zumindest die integrierten Albumcover der MP3-Files irgendwie angezeigt werden...
Die Bibliotheksansicht hat nicht einmal die verschiedenen Alben der Interpreten getrennt, sondern die Titel alle nacheinander aufgelistet. Da vermute ich mal, dass ich mir die verschiedenen Ansichten genauer ansehen muss.
Ich hoffe nur, dass sich hier noch was tut. So wie es gerade ist wäre das sogar ein K.O.-Kriterium für mich!

Nach ein paar Tagen kann ich aber sagen, MP2 läuft sehr stabil und gefällt mir auch vom Handling her. Ich muss zwar meine Fernbedienung in manchen Punkten umprogrammieren, aber das ist nicht das Problem.

Mit dem Standby habe ich noch meine Probleme. In MP1 konnte man ja den PowerScheduler so einstellen, dass er das System nie in den Standby schickt, außer wenn er im Home-Bildschirm von MP1 ist. Gibt es so etwas in MP2 auch?
Ich habe den PS jetzt mal so eingestellt, dass er alles Windows überlässt (Windows 10 Pro 1903) und da kommt es immer mal vor, dass ich ins Wohnzimmer komme und er Rechner schläft, obwohl ich das nicht möchte.

Also, wenn es hier irgendwelche Tipps für einen Neueinsteiger gibt, immer gerne!
Danke schon mal!

Ciao
Ralf
 

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Die Bibliotheksansicht hat nicht einmal die verschiedenen Alben der Interpreten getrennt, sondern die Titel alle nacheinander aufgelistet. Da vermute ich mal, dass ich mir die verschiedenen Ansichten genauer ansehen muss.
    Das Stichwort lautet "Filter" im Kontext-Menü. Die Darstellung hat mehrere Ebenen, welche du aber erst einmal selbst festlegen musst. Also z. B. Toplevel-Filter=Album-Interpret in der Raster-Ansicht, im nächsten Level dann Filter=Album in Ansicht=Poster gefolgt von Titel als Liste.

    Trotz peinlichst genau getaggter Files nichts. Keine FanArt oder Beschreibungen. Hier musste ich dann in verschiedenen Threads lesen, dass doch noch einiges an Arbeit vor mir liegt. Da hatte ich schon erwartet, dass zumindest die integrierten Albumcover der MP3-Files irgendwie angezeigt werden...
    Dann waren vermutlich die Lade-Optionen nicht richtig definiert. Wenn auch nichts automatisch runtergeladen wurde, hast du keine Import-Einstellungen vorgenommen. Überprüfe deine Musikimport-Settings.

    Ich habe den PS jetzt mal so eingestellt, dass er alles Windows überlässt
    Das ist der Standard und bewusst so angelegt. Du kannst aber natürlich auch die anderen Optionen des PS nutzen und z.B. den Client selbst als Ausschluss-App eintragen, so dass der PC nie in den Standby geht.
     

    rbo

    Portal Pro
    May 1, 2007
    398
    23
    Ludwigsburg
    Germany Germany
    Country flag
    Das Stichwort lautet "Filter" im Kontext-Menü. Die Darstellung hat mehrere Ebenen, welche du aber erst einmal selbst festlegen musst. Also z. B. Toplevel-Filter=Album-Interpret in der Raster-Ansicht, im nächsten Level dann Filter=Album in Ansicht=Poster gefolgt von Titel als Liste.
    Musste gerade die Medien nochmals neu einrichten. Mit den Erfahrungen der Erstinstallation scheint es jetzt zu funktionieren. Der Filter war definitiv das Stichwort!

    Dazu gleich eine Frage:
    Werden mehrere Unterverzeichnisse, die man z.B. in Audio 'gruppiert' immer in einer Bibliothek angezeigt?
    Das ist wahrscheinlich mein Problem beim ersten Medienscan gewesen. Ich habe unter Musik auf der NAS zwei Ordner, die ich gerne in MP2 abbilden würde, nämlich meine MP3-Sammlung und eine flac-Sammlung mit meinen 'Sahnestückchen'.

    Dann waren vermutlich die Lade-Optionen nicht richtig definiert. Wenn auch nichts automatisch runtergeladen wurde, hast du keine Import-Einstellungen vorgenommen. Überprüfe deine Musikimport-Settings.
    Bin diese Einstellungen nochmals durchgegangen. Sieht jetzt zumindest besser aus. Was mir noch nicht ganz klar ist, was es bedeutet die FanArts lokal oder auf derm Server zu speichern. Ich habe jetzt mal beides angehakt.

    Das ist der Standard und bewusst so angelegt. Du kannst aber natürlich auch die anderen Optionen des PS nutzen und z.B. den Client selbst als Ausschluss-App eintragen, so dass der PC nie in den Standby geht.
    Das wird noch eine Herausforderung. Ich war es gewohnt, mit meiner Harmony mit einem Klick alles auszumachen. Mache ich das in der jetztigen Einstellung, dann wird auch der MP2-Server in den Standby versetzt, ob eine Aufnahme läuft oder nicht.
    Da werde ich noch etwas an meinen Harmony-Einstellungen machen müssen.

    Dazu auch noch eine Frage:
    Ich habe das TV-Movie Pro Abo und unter MP1 wurden die EPG-Daten immer täglich upgedatet und über das TV-Movie Plugin in MP1 eingepflegt.
    Das scheint jetzt nur noch manuell zu funktionieren. Wie geht ihr da vor?
     

    rbo

    Portal Pro
    May 1, 2007
    398
    23
    Ludwigsburg
    Germany Germany
    Country flag
    Wir empfehlen stattdessen den EPG-Buddy: bessere Daten, aber keine Kosten für Abo.
    Ok, das war mir neu. Werde ich mir anschauen. :)

    Bei meinen Serien habe ich noch eine Frage:
    Meine 'Tatorte' werden nicht erkannt. Ich habe sie so abgelegt:
    z.B.: \\<nas>\serien\Tatort\s2019\Tatort.s01e1078.Lessing.08.Der.höllische.Heinz.mkv

    Leider findet der Importer keine Folgen.
    (Habe mir aber da das Wiki noch nicht angesehen...)
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,615
    2,385
    Stuttgart
    Germany Germany
    Country flag
    nas>\serien\Tatort\s2019\Tatort.s01e1078.Lessing.08.Der.höllische.Heinz.mkv
    Ist es jetzt Season 2019 oder Season 1? Die Benennung von Ordner und Datei widersprechen sich. Ggf. ist das schon der Grund warum nichts gefunden wird. Die korrekte Benennung sollte sein: S2019E01.mkv, wenn ich auf TVDB nachsehe.
     

    rbo

    Portal Pro
    May 1, 2007
    398
    23
    Ludwigsburg
    Germany Germany
    Country flag
    Ist es jetzt Season 2019 oder Season 1?
    Es ist schon Season 2019.

    Die korrekte Benennung sollte sein: S2019E01.mkv, wenn ich auf TVDB nachsehe.
    Ok, dann hätte ich definitv ein wenig zu tun, alle Tatorte umbenennen... Dem MP-TVSerien von MP1 war das egal. Normalerweise bin ich auch immer bei TVDB auf der Suche nach der richtigen Benamsung.
    Ich werde es testen, danke schon mal!
     

    ge2301

    MP2 Design
  • Team MediaPortal
  • January 11, 2014
    6,615
    2,385
    Stuttgart
    Germany Germany
    Country flag
    Ok, dann hätte ich definitv ein wenig zu tun, alle Tatorte umbenennen...
    Probiere den neuen Import doch erst einmal mit einer umbenannten Episode, um sicher zu sein. Ich bin mir sicher, dass das der Grund der Probleme ist, aber ohne Log Files ist das weiterhin nur eine Vermutung ;)
     

    rbo

    Portal Pro
    May 1, 2007
    398
    23
    Ludwigsburg
    Germany Germany
    Country flag
    Probiere den neuen Import doch erst einmal mit einer umbenannten Episode, um sicher zu sein. Ich bin mir sicher, dass das der Grund der Probleme ist, aber ohne Log Files ist das weiterhin nur eine Vermutung
    Hat genau so funktioniert. Danke!
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    catalpa Umsteiger von MP1: Schwierigkeiten Allgemeines Support- und Diskussionsforum 17
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 0
    ajs MP2Web - MP1 compatibility MediaPortal 1 20
    T MadVR + LAV Filters, Perfect in MPC-BE, Bad in MP1 MediaPortal 1 Talk 12
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    framug [solved] Some changes/fix in MP1 configuration client and server Submit: code patches (MediaPortal/TV-Server/etc.) 14
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    C Streaming/transcoding MP2 vs MP1? General 1
    ajs [fixed] 5015: Improving the MP1 installer, providing nicer GUI :) MediaPortal 1 138
    C Streaming to clients over Wifi. MP1 or MP2? Newcomers Forum 0
    S Shortcuts MP1 My Recorded & TV Guide General 10
    azzuro [WiP] MP1-4999 - Big changes with many related change at once by Sebastiii MediaPortal 1 12
    ajs [Help Us!] MP1 X64 Version MediaPortal 1 20
    joecrow How about a Launcher plugin for MP1? MediaPortal 1 6
    wizard123 [solved] MP1 Build help MediaPortal 1 21
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    CyberSimian [fixed] MP1-4990 : Improve horizontal scrolling in the EPG MediaPortal 1 10
    azzuro [WiP] MP1-5019: Replace MySQL with MariaDB MediaPortal 1 40
    CyberSimian [solved] MP1-4976 Built-in skin variables for current date MediaPortal 1 8
    azzuro [Info] MP2 TVE inside MP1 repo MediaPortal 2 12
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    lisag Can I get MP1 to open in the Recorded TV screen? MediaPortal 1 Talk 2
    M MP1 stops responding after Starting Plugins General Support 14
    R Problem with MP1 and WifiRemote Skins and Plugins Installer (MPEI) 8
    M.Hulot [solved] Netflix und amazon Prime in MP1 möglich? TV / Streaming 6
    Similar threads

























    Top Bottom