Tools and other software Unable to install MP1 due to problems with my SQL 5.6, looking for alternative suggestions (1 Viewer)

GlamRockCowboy

Portal Pro
October 25, 2015
63
1
67
Fairview, TN (ca. 20 mi. SSW of Nashville)
United States of America United States of America
I used IOBit Uninstaller to uninstall MP 1, and as far as I can tell, all of the subdirectories MPSourcer mentioned are now gone. I have two internet security programs on my system: Windows Defender and IOBit Malware Fighter 4.2. The TV Server never installed. It was at that point in the installation process that the mySQL error occurred. As nearly as I can remember, the error message read, "start service exception--installation failed." Like an idiot, I did not run the installer with administrator privileges--next time, I will! This time around, I intend to stick with it to the bitter end! See you in 2 days!
 

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    I did not run the installer with administrator privileges
    OK, you then might return to MP2 as well, provided you are still interested in it. MP1 certainly does the job too.

    I have two internet security programs on my system: Windows Defender and IOBit Malware Fighter 4.2.
    It is not recommended to use two Anti Virus solutions on one machine, as they may start fighting each other at some point. Contrary to what many peple think, MS Defender has become a good solution. It uses the same anti-virus engine as a couple of other anti-virus solutions, comes for free and is already integrated into the system. If you prefer to use IOBit, I recommend to deactivate Defender.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I'm back. Can we have a status update on the installation please?
    If installation has failed please supply more detail - screenshots, log files, descriptions as appropriate - about how it has failed.
     

    GlamRockCowboy

    Portal Pro
    October 25, 2015
    63
    1
    67
    Fairview, TN (ca. 20 mi. SSW of Nashville)
    United States of America United States of America
    This is everything I've got concerning my latest attempt at installation. Curiously, the opening screen indicated that mySQL 5.6 was in fact installed, whereas in previous attempts it showed just the opposite! Considering the amount of background of background work Windows 10 seems to be constantly doing, I wonder if that might have some bearing on the problem.
     

    Attachments

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Argh, sorry - I missed your reply from earlier this week. It's past midnight now for me here in NZ, and I need to get to bed. However I'll take a look at everything in the morning and respond as soon as I can. Sorry again.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Okay, here we go...

    I think screenshot 1 in your earlier reply is the telling one. It clearly shows that the installation issue is related to MySQL, and more specifically: the fact that the MySQL service can't start. Screenshot 3 is just a side-effect of that. If MySQL hasn't started, TV Server won't be able to connect to it.

    Unfortunately the fail-to-start error itself is very light on detail. However based on past reports and experience I would speculate the problem is due to:
    1. Another version of MySQL already installed and running on the system.
    2. Remnants of an old MySQL install not properly cleaned out.
    3. Installer not run with admin privileges.
    4. Over-zealous security software preventing MySQL from doing what it needs to do.
    HTPCSourcer has provided instructions for cleanly removing MySQL, so that should rule out (1) and (2). I note that I would not trust or rely on IOBit Uninstaller. Also, it's a common mistake to not delete c:\ProgramData\MySQL. ProgramData is a system/hidden folder, so people often [wrongly] assume that we're talking about Program Files. We're not. ProgramData and Program Files are not the same. If you made this mistake, this could well be the cause of your problems.

    You also said that you're now running the installer with admin privileges, so that should rule out (3).

    Finally, (4) is another distinct possibility. Disclaimer: I have no experience with IOBit software, and I'm inclined to distrust security software because it has caused more problems for me than it's solved.

    More information could possibly be gleaned by deeper investigation - for example, by attempting to start the MySQL service manually and/or examining the MySQL log files etc. However I'm not sure if it's practical to go down that route. Investigation is "non-linear" (ie. what you do next depends on what you find), which makes it difficult or very time-consuming for us to provide instructions. Further we're starting to get into very technical territory. It would be significantly easier for me to investigate myself if you're willing to allow me to access your PC via TeamViewer (free download for personal use, no installation required). Obviously that requires you to trust me. I'd fully understand if you don't want to do this... but please consider it and let me know.


    If you don't want to give me access (or I fail to solve the problem), you could have one more crack at using MySQL.

    Prior to attempting the install you should:
    1. Uninstall MediaPortal, including TV Server.
    Use the full product cleanup option. This does not uninstall MySQL, so...

    2. Uninstall any and all versions of MySQL you have installed.
    Use the Windows add/remove software function please. If the uninstaller offers you choices, choose the most comprehensive removal/clean-up option(s).

    After uninstalling, manually check and remove the folders HTPCSourcer listed on page 1. Don't forget ProgramData is not the same as Program Files.

    Note if you have other programs that also use a MySQL database (you should know if this were the case) then this would break them, so don't just blindly follow this instruction.

    Please don't use IOBit Uninstaller this time.

    When it comes time to try the install again, make sure you remember to run the installer with admin privileges. I'd also strongly recommend to temporarily disable all security software - including IOBit, Windows Defender and any others - before running the installer. It's up to you as to whether you're comfortable doing that or not. I'd simply reiterate that security software can and does cause installations problems sometimes, and this could be one of those occasions.

    If all else fails then trying SQL Server would be the last resort option.
     

    GlamRockCowboy

    Portal Pro
    October 25, 2015
    63
    1
    67
    Fairview, TN (ca. 20 mi. SSW of Nashville)
    United States of America United States of America
    I did all of that, and still no luck! I've downloaded TeamViewer, and will install it shortly. Given the distance between us, and the time difference, coordinating our joint efforts should be interesting, to say the least! Let me know how to proceed after you read this.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Given the distance between us, and the time difference, coordinating our joint efforts should be interesting, to say the least!
    I'm online now, so we could have a crack at this as soon as you've got TeamViewer running. Let me know if that's convenient for you.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    R [solved] Unable to delete single recording General 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    M Unable to map virtual sent keys in the input device management General 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    megahorst Unable to delete unseen recording while TV runs in the background 1.19 11
    doskabouter Installing mediaportal MediaPortal 1 3
    toricred x64 Bit Installer for 2.2.3 General 2
    F Problems with new install of MP2 Newcomers Forum 3
    C Can't install any extensions - DLL error Installation, configuration support 19
    joecrow 1.25.0 5031: Error on Install. Bugreports 24
    M MediaPortal2 TV Config Error on Install (0x80004005) General 7
    ajs [fixed] 5022: Improving the MPE Installer, providing nicer GUI :) MediaPortal 1 42
    Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
    ajs [fixed] 5015: Improving the MP1 installer, providing nicer GUI :) MediaPortal 1 138
    N No TV or EPG on fresh install General 0
    Similar threads

























    Top Bottom