Unable to play Recorded TV unless Live TV is watched first | Page 2

Discussion in '1.1.x and SVN Builds' started by Zepman, July 28, 2010.

  1. Zepman

    Zepman Portal Member

    Joined:
    July 28, 2010
    Messages:
    18
    Likes Received:
    2
    Ratings:
    +2 / 0
    Hey, that's OK. I made the mistake of not reading it thoroughly. ;)

    CONFIRMED! It's the MiniDisplay plugin. When the plugin is disabled, Recorded TV records will play without problems.

    It doesn't matter which settings the MiniDisplay plugin has. If it's enabled, the user will need to watch Live TV first on a MediaPortal restart before he can watch Recorded TV.

    Steps to reproduce (note: you will need a preconfigured MediaPortal 1.1.0 final TV Server!)

    1. Install MediaPortal 1.1.0 and the TV client final clean (no upgrade!) on a Windows 7 x64 system.
    2. Start MediaPortal configuration.
    3. Enable the MiniDisplay plugin.
    4. Configure the MiniDisplay plugin. If you normally don't use MiniDisplay because you don't have a supported device, use "Generic Serial Character VFD/LCD driver".
    5. Save and exit.
    6. Start MediaPortal.
    7. Try to play something from the 'Recorded TV' section. This will fail.
    8. Watch Live TV for a few seconds.
    9. Try to play something from the 'Recorded TV' section. This will succeed (as will any other further usage of the Recorded TV section).

    Thanks, arion_p, for giving this vital clue. :)

    I believe this is a bug. Could a moderator change the state of this thread?

    [edit]
    Made it more clear that this bug affects Windows 7 x64 with a clean MediaPortal 1.1.0 final installation.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. arion_p
    • Team MediaPortal

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
    What we are missing here is why does it happen for some people only.

    I also use MiniDisplay with iMon on a Win7 x64. When I first upgraded to RC2 I got the same error as you. I did an uninstall and reinstall and I've never had the issue again since then. In the mean time I have upgraded to RC4 and then to 1.1.0 final and still no issue. Of course I still use MiniDisplay.
     
  4. Zepman

    Zepman Portal Member

    Joined:
    July 28, 2010
    Messages:
    18
    Likes Received:
    2
    Ratings:
    +2 / 0
    So you first re-installed RC2 clean, then upgraded to RC4 and then to final. That's a very different situation.

    Try to install 1.1 final on a clean computer (hell, use a virtual machine). Use the steps I mentioned and the bug will occur. I have tested these steps on three different Windows 7 x64 systems. All systems suffer from the same bug. In contrast, a Windows XP x86 system is not affected by this bug.

    I will expand the steps required to reproduce this bug to make it clear that it always happens on a Windows 7 x64 installation with a fresh (not upgraded) MediaPortal 1.1.0 final installation.
     
  5. jameson_uk
    • Team MediaPortal

    jameson_uk Retired Team Member

    Joined:
    January 27, 2005
    Messages:
    7,258
    Likes Received:
    2,228
    Gender:
    Male
    Occupation:
    Data Warehousing Consultant
    Location:
    Birmingham
    Ratings:
    +2,403 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I can confirm this issue. I have a brand new Win7 x64 since 1.1 and have installed a very clean 1.1 :)

    Recorded TV works fine but if I enable Mini-display with the debug window option I can only play recorded TV once I have started live TV. Same error in logs
    Code (Text):
    1. 2010-07-28 23:47:54.604492 [Info.][MPMain(1)]: TSReaderPlayer: Exception while creating DShow graph Retrieving the COM class factory for component with CLSID {B9559486-E1BB-45D3-A2A2-9A7AFE49B23F} failed due to the following error: 800700c1.
    which after a quick scan of the registry appears to be the MP File Reader

    Arion can you comment on this before I add to Mantis
     
  6. arion_p
    • Team MediaPortal

    arion_p Retired Team Member

    Joined:
    February 7, 2007
    Messages:
    3,352
    Likes Received:
    1,447
    Occupation:
    Developer
    Location:
    Athens
    Ratings:
    +1,522 / 0
    Home Country:
    Greece Greece
    Show System Specs
    The issue is quite old as you know. We never had exact steps to reproduce at will and the error itself is very weird. MP File Reader A.K.A TsReader is obviously a valid executable image, since it gets loaded properly when starting live TV. Also both live TV and Recorded TV use the same code path to build and run the graph.

    Now we have new information, as it appears that disabling MiniDisplay solves the issue. I cannot even imagine how these could possibly be related but tests show they are.

    So considering the weirdness of the issue I don't think I have anything useful to add.:(
     
  7. Zepman

    Zepman Portal Member

    Joined:
    July 28, 2010
    Messages:
    18
    Likes Received:
    2
    Ratings:
    +2 / 0
    You will probably look back one day and laugh about the silliness of the problem and the solution.

    Just not today. ;)
     
  8. jameson_uk
    • Team MediaPortal

    jameson_uk Retired Team Member

    Joined:
    January 27, 2005
    Messages:
    7,258
    Likes Received:
    2,228
    Gender:
    Male
    Occupation:
    Data Warehousing Consultant
    Location:
    Birmingham
    Ratings:
    +2,403 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  9. chemelli
    • Team MediaPortal

    chemelli Retired Team Member

    Joined:
    September 28, 2006
    Messages:
    6,159
    Likes Received:
    1,126
    Gender:
    Male
    Occupation:
    Activation Manager - Cloud Services
    Location:
    Trento, Italy
    Ratings:
    +1,127 / 0
    Home Country:
    Italy Italy
    too bad I cannot reproduce and I'm a MiniDisplay user since the beginning...

    Simone
     
    • Like Like x 1
  10. jameson_uk
    • Team MediaPortal

    jameson_uk Retired Team Member

    Joined:
    January 27, 2005
    Messages:
    7,258
    Likes Received:
    2,228
    Gender:
    Male
    Occupation:
    Data Warehousing Consultant
    Location:
    Birmingham
    Ratings:
    +2,403 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    I have used Mini-Display for a long time on HTPC but that is on XP. Have udpated dev machine to Win7 x64 in last couple of weeks so OS install is very clean and MP 1.1 is about the only thing installed

    Just had a thought, my dev machine is client to tv server on XP box. Looks from logs that OP is running single seat though.

    Is odd as I can reproduce this totally that with this clean an install (I still have not actually installed any plugins or skins yet) I get the same error adding TSReader to graph. If I watch live TV first I do not get this error, if I disable mini-display I do not get this error.

    In Mantis I did link an old report of this from RC5 or 6 but they resolved it with a new install.

    Can not understand it but given how clean my system is and that I can reproduce it, there is an odd bug just hidden deep deep down. I will not attempt another install of MP as I guess I can reproduce this issue but is not causing me an issue as I do not use Mini-Display on here
     
  11. chemelli
    • Team MediaPortal

    chemelli Retired Team Member

    Joined:
    September 28, 2006
    Messages:
    6,159
    Likes Received:
    1,126
    Gender:
    Male
    Occupation:
    Activation Manager - Cloud Services
    Location:
    Trento, Italy
    Ratings:
    +1,127 / 0
    Home Country:
    Italy Italy
    I'm on Windows7 x64 and MP 1.1.0 and cannot reproduce :(

    There for sure msut be a special setting / step order to kill it but I cannot figure them out. :sorry:

    Simone
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!