Unable to play stream - again... (2 Viewers)

hucknallred

Portal Pro
February 21, 2012
75
21
54
United Kingdom United Kingdom
Country flag
Hi all

Long time user of MP. Just setting up a new server & testing a client.

TV server is all good & running OK. Fired up a client running 1.21.0 on another PC on the LAN. See the server fine, got the TV Guide up, select a channel & get unable to play stream 3.
I have had this before & LAV filters were the problem, checked this & they're fine.

Into the TSreader.log I go & find this when I tried to tune (My bold):

[2019-09-06 19:06:59,780] [15F2BC00] [ c98] - CRTSPClient::OpenStream(): create RTSP client, url = rtsp://TVSERVER2-PC:0/stream3.0
[2019-09-06 19:06:59,780] [15F2BC00] [ c98] - CRTSPClient::confused:tartBufferThread()
[2019-09-06 19:06:59,780] [15F2BC00] [ c98] - CRTSPClient::confused:tartBufferThread(): done
[2019-09-06 19:06:59,780] [15F2BC00] [2110] - CRTSPClient::ThreadProc(): thread started, thread ID = 8464
[2019-09-06 19:06:59,783] [15F2BC00] [ c98] - CRTSPClient::UpdateDuration(): RTSP DESCRIBE failed, result code = -10057, message = Bad port number
[2019-09-06 19:06:59,783] [15F2BC00] [ c98] - CRTSPClient::confused:hutdown()

Unless I'm mistaken, the streaming port number should be after the colon in the server address - 554?

Had a quick search I can't find anything port related with this problem?

Any ideas out there?

Cheers
 

CyberSimian

Test Group
  • Team MediaPortal
  • June 10, 2013
    2,105
    1,305
    Southampton
    United Kingdom United Kingdom
    Country flag
    Unless I'm mistaken, the streaming port number should be after the colon in the server address - 554?
    The port number is certainly 554 on my system. I don't know why your port number is different, but one might suspect that Windows 10 security has blocked that port for some reason. These pages in the Wiki might help:

    Streaming Server
    Firewall Settings

    -- from CyberSimian in the UK
     

    hucknallred

    Portal Pro
    February 21, 2012
    75
    21
    54
    United Kingdom United Kingdom
    Country flag
    I got it working. In TV server Streaming server settings I changed the IP address from auto to the server IP. Now it works & the TSreader log displays the ip address rather than the server hostname.

    CTsReaderFilter::Load() succeeded, file/stream: rtsp://192.168.0.199:554/stream4.0, isTimeshift:1, isUNC:0
     

    Users who are viewing this thread

    Similar threads
    OP Title Forum Replies Date
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    V Unable to stream : 10 General Support 0
    M Unable to map virtual sent keys in the input device management General 6
    W 1.25.0 Blu-ray disks that used to play are no longer playing Watch / Listen Media 2
    joecrow [solved] DVD won't play properly. General Support 3
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 26
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 2
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2

    Similar threads

    Top Bottom