Unable to play x264 after upgrading to 0.2.3.0

Discussion in 'General Support' started by hifire, December 7, 2007.

  1. hifire

    hifire Portal Member

    Joined:
    July 28, 2007
    Messages:
    28
    Likes Received:
    1
    Ratings:
    +1 / 0
    Playback was working fine before the upgrade. Here's the log

    Thoughts and suggestions?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. espiman

    espiman New Member

    Joined:
    December 5, 2007
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Spain Spain
    I have the same problem.

    My log ...

    Code (Text):
    1. 2007-12-08 01:38:41.224600 [ERROR][MPMain]: VideoPlayer9: Failed to render file -> vmr9
    2. 2007-12-08 01:38:41.988887 [ERROR][MPMain]: VideoPlayerVMR9: Exception while cleanuping DShow graph - Referencia a objeto no establecida como instancia de un objeto.    en System.Runtime.InteropServices.Marshal.ReleaseComObject(Object o)
    3.    en MediaPortal.Player.VideoPlayerVMR9.Cleanup()
    4. 2007-12-08 01:38:42.066876 [ERROR][MPMain]: PlaylistPlayer: *** unable to play - D:\Torrents\Surf's.Up.2007.BluRay.720p.x264.DUAL.By.HarmFul.mkv - skipping track!
    With Media Player Classic it works perfectly.

    Thanks in advance.
     
  4. uncertainty

    uncertainty Portal Pro

    Joined:
    September 29, 2007
    Messages:
    140
    Likes Received:
    2
    Location:
    NYC
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    I had the same issue performing an upgrade to 0.2.3.0 and any mkv file with embedded subtitles which played previously will not play. Check the mkv files you have referenced and see if they to have embedded text/subtitle files. Till a fix is available I've just remuxed the few mkv's that have trouble to remove the subtitles.

    Edit: Just an update, I reinstalled vsfilter (subtitle filter) and now any mkv with subtitles plays fine with 0.2.3.0
     
  5. Avigrace

    Avigrace Portal Pro

    Joined:
    December 13, 2005
    Messages:
    85
    Likes Received:
    3
    Occupation:
    Domain Administrator
    Ratings:
    +3 / 0
    Home Country:
    England England
    I also have this problem, tried reinstalling coreAVC and Halli but still nothing.
     
  6. Atarian

    Atarian Portal Member

    Joined:
    November 26, 2007
    Messages:
    16
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    Same problem here. I tried removing the subtitles from the mkv, and the file actually opens, but it only plays the audio with a black screen.
     
  7. riadmelb

    riadmelb Portal Pro

    Joined:
    July 9, 2006
    Messages:
    218
    Likes Received:
    7
    Location:
    Melbourne
    Ratings:
    +7 / 0
    Home Country:
    I'm having the same problem, 1080p mkv files don't play.

    riadmelb
     
  8. espiman

    espiman New Member

    Joined:
    December 5, 2007
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Spain Spain
    Thanks, this is the solution. Now plays OK. :D
     
  9. wewantphil

    wewantphil Portal Member

    Joined:
    October 29, 2007
    Messages:
    7
    Likes Received:
    0
    Ratings:
    +0 / 0
    reinstalling vsfilter did NOT fix the problem for me. I had to revert back to RC3 to get my mkv files to play again. Wish I knew more about mvk. ran the diag but didn't know how to interpret the results.
     
  10. Atarian

    Atarian Portal Member

    Joined:
    November 26, 2007
    Messages:
    16
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    United States of America United States of America
    That fix didn't help me either.
     
  11. hifire

    hifire Portal Member

    Joined:
    July 28, 2007
    Messages:
    28
    Likes Received:
    1
    Ratings:
    +1 / 0
    This problem when combined with my amp suddenly insisting on using prologic for everything left me feeling desperate. As a result I spent a couple hours trying anything to fix this problem. Eventually I got it working.

    I uninstalled everything related: ac3 filter, media portal, ffdshow, haali splitter, avc core and vsfilter. I made sure nothing played, not even xvid and mp3. I don't know if it was necessary but I unregistered the dshow filters for mpa and dscaler as well just to be thorough.

    I reinstalled everything, leaving MP for last and deselected the dscaler/mpa options. Now I can play x264, but avi files with mp3 audio play with no sound. Arg :( Maybe I need dscaler and mpa to play videos with mp3 audio that play fine in wmp11. What a nightmare.

    Edit: Nope, installing gabest mpa did not help. Still no mp3 audio.

    Dunno why, but sound was muted. I pressed M trying while playing a video with mp3 sound in an attempt to figure out which button stopped playback, and voila, sound. MP is back! :)

    Nope, that wasn't a double post. Even the mp forums are giving me a hard time!

    Anyway, I got mp3 sound back by pressing M during playback, this unmuted the sound. Seems like an odd default setting but who am I to judge...? MP is now working properly again!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!