Unable to watch tv and recordings from client

Discussion in 'Television (MyTV frontend and TV-Server)' started by mike1, November 20, 2013.

  1. mike1
    • Premium Supporter

    mike1 MP Donator

    Joined:
    September 7, 2012
    Messages:
    88
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I try to watch tv or recordings from a Client. Does not work.
    The logs show the try to watch a recording.
    It is strange to me that the log says the stream would be recognized as Radio.



    [2013-11-20 14:08:26,206] [Log ] [MPMain ] [INFO ] - TSReaderPlayer:play rtsp://MediaPC2:554/29045ACA
    [2013-11-20 14:08:26,226] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: GetInterfaces()
    [2013-11-20 14:08:26,296] [Log ] [MPMain ] [INFO ] - DirectShowUtils: First try to insert new audio renderer Default DirectSound Device
    [2013-11-20 14:08:26,450] [Log ] [MPMain ] [INFO ] - DirectShowUtils: Found audio renderer
    [2013-11-20 14:08:26,466] [Log ] [MPMain ] [DEBUG] - DirectShowUtils: added filter:Default DirectSound Device to graph
    [2013-11-20 14:08:26,505] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: Add TsReader to graph
    [2013-11-20 14:08:26,511] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: Open file: rtsp://MediaPC2:554/29045ACA
    [2013-11-20 14:08:36,830] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: Add codecs
    [2013-11-20 14:08:36,838] [Log ] [MPMain ] [DEBUG] - TSReaderPlayer: Stream is Radio

    I did two tests:
    - VLC can show the rtsp-stream.
    - I added the recording folder of the server as video folder to the Client -> the client plays the file correct.

    I did a complete uninstall and reinstall. Did not help.

    Any ideas?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    Hello Mike

    Problem is network or firewall related. Check the firewall on your server and client. I recommend to disable them for testing. If that helps, ensure MediaPortal.exe has an exception rule for public and private on the client; same for TvService.exe on the server.

    mm
     
  4. mike1
    • Premium Supporter

    mike1 MP Donator

    Joined:
    September 7, 2012
    Messages:
    88
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Was my first idea too.
    Both firewalls are disabled.
    I even reinstalled with enabled firewalls to allow MP to establish the rules and disabled afterwords...
     
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
  6. mike1
    • Premium Supporter

    mike1 MP Donator

    Joined:
    September 7, 2012
    Messages:
    88
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I tried wireless. but can check with calble tomorrow.
    and i will test without rtsp.
     
  7. mike1
    • Premium Supporter

    mike1 MP Donator

    Joined:
    September 7, 2012
    Messages:
    88
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    Show System Specs
    tested both - does not work.
    At least in "non rtsp" mode there is an error message in MP: "can not play ...."

    [2013-11-22 16:26:25,691] [Log ] [MPMain ] [INFO ] - Main: Activation request received
    [2013-11-22 16:26:54,123] [Log ] [MPMain ] [INFO ] - PlayRecording:\\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts - using rtsp mode:False
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: DLL Version : MediaInfoLib - v0.7.61
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Inspecting media : \\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Parse speed : 0.3
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: FrameRate : 0
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Width : 0
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Height : 0
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AspectRatio : widescreen
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: VideoCodec : [ ".png" ]
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Scan type :
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: IsInterlaced : False
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: VideoResolution : SD
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: VideoDuration : 0
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AudioRate : 0
    [2013-11-22 16:26:54,213] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AudioChannels : 0 [ "0.png" ]
    [2013-11-22 16:26:54,213] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AudioCodec : [ ".png" ]
    [2013-11-22 16:26:54,273] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: HasAudio : False
    [2013-11-22 16:26:54,273] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: HasVideo : False
    [2013-11-22 16:26:54,283] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: HasSubtitles : False
    [2013-11-22 16:26:54,283] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: NumSubtitles : 0
    [2013-11-22 16:26:54,283] [Log ] [MPMain ] [INFO ] - g_Player.Play(\\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts Recording)
    [2013-11-22 16:26:54,333] [Log ] [MPMain ] [INFO ] - TSReaderPlayer play:\\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts radio:False
    [2013-11-22 16:26:54,408] [Log ] [MPMain ] [INFO ] - g_Player: ended
    [2013-11-22 16:26:54,418] [Log ] [MPMain ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\DefaultWide\dialogOK.xml' is missing control id 11 (window property: btnYes)
    [2013-11-22 16:26:55,498] [Log ] [MPMain ] [INFO ] - Main: Deactivation request received
    [2013-11-22 16:27:59,636] [Log ] [MPMain ] [INFO ] - Main: Activation request received
    [2013-11-22 16:28:00,478] [Log ] [MPMain ] [INFO ] - Main: Deactivation request received
     
  8. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
  9. mike1
    • Premium Supporter

    mike1 MP Donator

    Joined:
    September 7, 2012
    Messages:
    88
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +8 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Yes, thank you, to make the recording path name shorter fixed the problem. Also live tv works with unc.
    Never the less - i would like to know the reason why rtsp does not work.
    What else could i test/try?
     
  10. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    I reckon it is a network latency issue or something like that. Using a wired connection with firewalls down should give you the best chance of success. The fact that VLC works tells you this is almost certainly an MP problem.

    @Owlsroost any ideas?
     
  11. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    The RTSP connection is being set up OK (as far as I can tell, but I'm not an expert on RTSP), but no data arrives (even after waiting 7 seconds) so I think something must be blocking the streaming UDP packets.

    Do you have antivirus with network traffic monitoring running (in case that might be blocking packets) ?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!