Unable to watch tv and recordings from client (1 Viewer)

mike1

MP Donator
  • Premium Supporter
  • September 7, 2012
    88
    8
    55
    Germany Germany
    I try to watch tv or recordings from a Client. Does not work.
    The logs show the try to watch a recording.
    It is strange to me that the log says the stream would be recognized as Radio.

    [2013-11-20 14:08:26,206] [Log ] [MPMain ] [INFO ] - TSReaderPlayer:play rtsp://MediaPC2:554/29045ACA
    [2013-11-20 14:08:26,226] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: GetInterfaces()
    [2013-11-20 14:08:26,296] [Log ] [MPMain ] [INFO ] - DirectShowUtils: First try to insert new audio renderer Default DirectSound Device
    [2013-11-20 14:08:26,450] [Log ] [MPMain ] [INFO ] - DirectShowUtils: Found audio renderer
    [2013-11-20 14:08:26,466] [Log ] [MPMain ] [DEBUG] - DirectShowUtils: added filter:Default DirectSound Device to graph
    [2013-11-20 14:08:26,505] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: Add TsReader to graph
    [2013-11-20 14:08:26,511] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: Open file: rtsp://MediaPC2:554/29045ACA
    [2013-11-20 14:08:36,830] [Log ] [MPMain ] [INFO ] - TSReaderPlayer: Add codecs
    [2013-11-20 14:08:36,838] [Log ] [MPMain ] [DEBUG] - TSReaderPlayer: Stream is Radio

    I did two tests:
    - VLC can show the rtsp-stream.
    - I added the recording folder of the server as video folder to the Client -> the client plays the file correct.

    I did a complete uninstall and reinstall. Did not help.

    Any ideas?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hello Mike

    Problem is network or firewall related. Check the firewall on your server and client. I recommend to disable them for testing. If that helps, ensure MediaPortal.exe has an exception rule for public and private on the client; same for TvService.exe on the server.

    mm
     

    mike1

    MP Donator
  • Premium Supporter
  • September 7, 2012
    88
    8
    55
    Germany Germany
    Was my first idea too.
    Both firewalls are disabled.
    I even reinstalled with enabled firewalls to allow MP to establish the rules and disabled afterwords...
     

    mike1

    MP Donator
  • Premium Supporter
  • September 7, 2012
    88
    8
    55
    Germany Germany
    I tried wireless. but can check with calble tomorrow.
    and i will test without rtsp.
     

    mike1

    MP Donator
  • Premium Supporter
  • September 7, 2012
    88
    8
    55
    Germany Germany
    tested both - does not work.
    At least in "non rtsp" mode there is an error message in MP: "can not play ...."

    [2013-11-22 16:26:25,691] [Log ] [MPMain ] [INFO ] - Main: Activation request received
    [2013-11-22 16:26:54,123] [Log ] [MPMain ] [INFO ] - PlayRecording:\\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts - using rtsp mode:False
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: DLL Version : MediaInfoLib - v0.7.61
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Inspecting media : \\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Parse speed : 0.3
    [2013-11-22 16:26:54,183] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: FrameRate : 0
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Width : 0
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Height : 0
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AspectRatio : widescreen
    [2013-11-22 16:26:54,193] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: VideoCodec : [ ".png" ]
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: Scan type :
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: IsInterlaced : False
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: VideoResolution : SD
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: VideoDuration : 0
    [2013-11-22 16:26:54,203] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AudioRate : 0
    [2013-11-22 16:26:54,213] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AudioChannels : 0 [ "0.png" ]
    [2013-11-22 16:26:54,213] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: AudioCodec : [ ".png" ]
    [2013-11-22 16:26:54,273] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: HasAudio : False
    [2013-11-22 16:26:54,273] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: HasVideo : False
    [2013-11-22 16:26:54,283] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: HasSubtitles : False
    [2013-11-22 16:26:54,283] [Log ] [MPMain ] [INFO ] - MediaInfoWrapper.MediaInfoWrapper: NumSubtitles : 0
    [2013-11-22 16:26:54,283] [Log ] [MPMain ] [INFO ] - g_Player.Play(\\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts Recording)
    [2013-11-22 16:26:54,333] [Log ] [MPMain ] [INFO ] - TSReaderPlayer play:\\MediaPC2\F\MediaPortal\Aufnahmen\Tatort - Einsfestival HD - 2013-03-10.ts radio:False
    [2013-11-22 16:26:54,408] [Log ] [MPMain ] [INFO ] - g_Player: ended
    [2013-11-22 16:26:54,418] [Log ] [MPMain ] [WARN ] - GUIWindow:OnWindowLoaded: 'C:\ProgramData\Team MediaPortal\MediaPortal\Skin\DefaultWide\dialogOK.xml' is missing control id 11 (window property: btnYes)
    [2013-11-22 16:26:55,498] [Log ] [MPMain ] [INFO ] - Main: Deactivation request received
    [2013-11-22 16:27:59,636] [Log ] [MPMain ] [INFO ] - Main: Activation request received
    [2013-11-22 16:28:00,478] [Log ] [MPMain ] [INFO ] - Main: Deactivation request received
     

    mike1

    MP Donator
  • Premium Supporter
  • September 7, 2012
    88
    8
    55
    Germany Germany
    Yes, thank you, to make the recording path name shorter fixed the problem. Also live tv works with unc.
    Never the less - i would like to know the reason why rtsp does not work.
    What else could i test/try?
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    I reckon it is a network latency issue or something like that. Using a wired connection with firewalls down should give you the best chance of success. The fact that VLC works tells you this is almost certainly an MP problem.

    @Owlsroost any ideas?
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,539
    5,037
    Cambridge
    United Kingdom United Kingdom
    Country flag
    The RTSP connection is being set up OK (as far as I can tell, but I'm not an expert on RTSP), but no data arrives (even after waiting 7 seconds) so I think something must be blocking the streaming UDP packets.

    Do you have antivirus with network traffic monitoring running (in case that might be blocking packets) ?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    P [solved] MP2 new install, 2 x hdhomerun tuners, client on same PC unable to view TV & recordings Newcomers Forum 8
    R [solved] Unable to delete single recording General 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    D Unable to install 1.22 on Win 10 Newcomers Forum 9
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    V Unable to stream : 10 General Support 0
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    M Unable to map virtual sent keys in the input device management General 6
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    porky996t Still Unable to play Live or Recorded TV General Support 4
    B Unable to play: Live3-0.ts issue General Support 7
    A Unable to play :stream 3 Television (MyTV frontend and TV-Server) 1
    badboyxx Unable to play BD-Iso watch/edit Videos 7
    Steve.Rayner61 TV "Unable to play" on Client - Working until Win 10 Server upgraded to Version 1803 Television (MyTV frontend and TV-Server) 5
    megahorst Unable to delete unseen recording while TV runs in the background 1.19 11
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    SpudR Forum Duplicate lines in 'Watched' Website/Forum/Wiki Feedback 2
    TLD Can not watch tv from remote clients Television (MyTV frontend and TV-Server) 19
    R Visual status of watched TV programs MediaPortal 1 Talk 2
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    K sudden complication watching recorded TV Newcomers Forum 6
    R [solved] Watching a record during recording stops sometimes 2.2 Archive 30
    Scheibes Automatischer Serienimport fehlerhaft (Share Watch) Allgemeines Support- und Diskussionsforum 18
    doskabouter Black screen while watching some iptv streams General Support 2
    Similar threads

























    Top Bottom