Updated plugin: Rar Mount 2 (1 Viewer)

sorling

Portal Member
January 27, 2008
11
0
Sweden Sweden
I just wanna say great work there jackjson, still dev this wounderful plugin.
How does it work with folders that have CD1, CD2 ? .. does it search for subs in "/../subs" (subtitles) too?

And it doesnt support rar'ed subfiles either?
Would be great if it supported movie.rar, /../subs/movie-subs-rar .. its just a request.

Once more big thanks for this plugin!

I get a strange error now.
2008-12-08 20:41:20 - Subtitle found: movie.sub
2008-12-08 20:41:20 - ERROR while copying subtitle! Please make sure the target folder exists: C:\
I tryed with C:\subtitles and some others too but i get the same error.
 

senilix

Portal Member
October 18, 2008
42
2
norway
Norway Norway
Update....

Hello again :)

I have been using rarmount2 for a while now!
and it has been working great :)

however after my latest upgade.
mediaportal-svn-12-07-2008--10-44-Rev21026.rar
it stoped working for me...

Any ideas..
from the "rarmount_debug.txt":
14.12.2008 20:22:26 - DEBUG - File ending is '.rar', will be looking for '.r00', '.r01', etc.
14.12.2008 20:22:27 - 13 RAR file(s) loaded successfully
14.12.2008 20:22:27 - NTFS file system initiated successfully
14.12.2008 20:22:27 - Listning for connection on port 32123
14.12.2008 20:22:29 - Accepted request from 127.0.0.1:1211
14.12.2008 20:22:29 - Connection to ImDisk lost
14.12.2008 20:22:30 - Settings saved
14.12.2008 20:22:30 - Application closed

error.log:
2008-12-14 20:22:29.669615 [ERROR][MPMain]: OnMessage exception:confused:ystem.IO.DirectoryNotFoundException: Could not find a part of the path 'M:\'.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.Directory.InternalGetFileDirectoryNames(String path, String userPathOriginal, String searchPattern, Boolean includeFiles, Boolean includeDirs, SearchOption searchOption)
at System.IO.DirectoryInfo.GetFiles(String searchPattern, SearchOption searchOption)
at System.IO.DirectoryInfo.GetFiles(String searchPattern)
at MediaPortal.Plugins.RarPlayerPlugin.MountRar(String filename)
at MediaPortal.Plugins.RarPlayerPlugin.Play(String strFile)
at MediaPortal.Player.g_Player.Play(String strFile)
at MediaPortal.Playlists.PlayListPlayer.FakePlayer.MediaPortal.Playlists.PlayListPlayer.IPlayer.Play(String strFile)
at MediaPortal.Playlists.PlayListPlayer.Play(Int32 iSong)
at MediaPortal.Playlists.PlayListPlayer.PlayNext()
at MediaPortal.GUI.Video.GUIVideoFiles.PlayMovieFromPlayList(Boolean askForResumeMovie, Int32 iMovieIndex)
at MediaPortal.GUI.Video.GUIVideoFiles.OnClick(Int32 iItem)
at MediaPortal.GUI.Video.GUIVideoBaseWindow.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
at MediaPortal.GUI.Video.GUIVideoFiles.OnClicked(Int32 controlId, GUIControl control, ActionType actionType)
at MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)


when i try from the cmd line, it works.
seems to me in the error.log, the file name is missing?

--------------------------------------
Okay.
I updated "ImDisk Virtual Disk Driver - Latest version 1.1.3 built 5 Dec 2008"
URL: Tools and utilities for Windows

and it works great....
:)

any news on the smbrar project?
 

KeNZoNr1

New Member
January 1, 2009
1
0
Sweden Sweden
problems

hello.
I just installed media portal and as a former xbox user im impressed. but.....
I´m havin problems with this rarmount.
I have done as said in readme file but every time i start a rar-file from MP it mounts M: the screen blinks and then nothing happens. :mad:
If I look in the root of Video folders in MP I can see M: and the file unpacked inside but if I click it nothing happens.
If I tab out to win I can see rarmount2 and it says connectec to IM-disk. The rarmount2.exe process is taking 99% cpu.
I´m running XP SP3
MP 1.0
Best regards
KeNZoNr1
 

Anthraxdk

Portal Member
February 19, 2008
14
0
Denmark Denmark
hello.
I just installed media portal and as a former xbox user im impressed. but.....
I´m havin problems with this rarmount.
I have done as said in readme file but every time i start a rar-file from MP it mounts M: the screen blinks and then nothing happens. :mad:
If I look in the root of Video folders in MP I can see M: and the file unpacked inside but if I click it nothing happens.
If I tab out to win I can see rarmount2 and it says connectec to IM-disk. The rarmount2.exe process is taking 99% cpu.
I´m running XP SP3
MP 1.0
Best regards
KeNZoNr1
If you wanna play packed movies then I recommend u use the Mplayer-pluging and the special version of mplayer that plays .rar-files try searching the forums for it :)
 

rehnmark

New Member
January 8, 2009
1
0
Sweden Sweden
Hi

Just want to say thanks for a great program!
I'm using it manually(via script that mounts the rar and plays it with Windows Media Player (ffdshow,reclock etc) and not with mediaportal, and it works really nice that way to.

/Rehnmark
 

tontsa

Retired Team Member
  • Premium Supporter
  • April 7, 2007
    108
    17
    Finland Finland
    Fixed the Play-method

    Hi,

    In the rarmount external player the Play-method always returns false erraneously.

    In the 1.0.0 release you don't see anything wrong due to the error is just logged.. but with upcomming 1.0.1 you need this patch cause we have added a dialog to Play if graph build fails.. say you have a missing codec.

    Without this patch rarmount always shows this "failed to play" dialog as the internal player tried to play the .rar due to rarmount returning false always.

    Included is the full .cs file and rebuilt rarplayer.dll.
     

    Attachments

    jackjson

    Portal Pro
    December 8, 2007
    70
    24
    Sweden Sweden
    I just wanna say great work there jackjson, still dev this wounderful plugin.
    How does it work with folders that have CD1, CD2 ? .. does it search for subs in "/../subs" (subtitles) too?

    And it doesnt support rar'ed subfiles either?
    Would be great if it supported movie.rar, /../subs/movie-subs-rar .. its just a request.

    Once more big thanks for this plugin!

    I get a strange error now.
    2008-12-08 20:41:20 - Subtitle found: movie.sub
    2008-12-08 20:41:20 - ERROR while copying subtitle! Please make sure the target folder exists: C:\
    I tryed with C:\subtitles and some others too but i get the same error.

    I'm not sure, but my guess is that you are running MediaPortal as a non-administrator. You must use a subtitle folder where the currently logged in user is allowed to write.


    Hi,

    In the rarmount external player the Play-method always returns false erraneously.

    In the 1.0.0 release you don't see anything wrong due to the error is just logged.. but with upcomming 1.0.1 you need this patch cause we have added a dialog to Play if graph build fails.. say you have a missing codec.

    Without this patch rarmount always shows this "failed to play" dialog as the internal player tried to play the .rar due to rarmount returning false always.

    Included is the full .cs file and rebuilt rarplayer.dll.

    Great work!
    I'll update my code.

    About SmbRAR, I've just got stared. I've created a simple server that can intercept and reply simple SMB/CIFS commands, but it's not even close to a working Samba-server.
    After a while I realized there's already a C# Samba-sever out there.
    Maybe I'll just build a RAR provider for this one:
    Suchwerk - Der Weg ist das Ziel

    Jack
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Golf4 Nach Windows-Updates läuft TV-Plugin nicht mehr Allgemeines Support- und Diskussionsforum 0
    Terra LAVFilter Plugin cannot be updated (MP1.23) MediaPortal 1 Plugins 10
    V [solved] Startup Crash if Video Folders not online/accessible. (default videos plugin) General Support 10
    J Update .NET framework? Improvement Suggestions 0
    G Update von MediaPortal Installationsprobleme? 0
    morpheus_xx [Evaluate] Update to VS 2019? MediaPortal 2 4
    B MPEM update list never completes. General Support 0
    JJDoherty Updated DTT frequencies for Ireland... Submit: EPG-Grabbers and tuningdetails 1
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    R [solved] Files moved to new location - Easy way to update database? My TVSeries 7
    M.Hulot Moving Pictures lässt sich nach Windows-Update nicht mehr öffnen Plugins & Erweiterungen 1
    R Files moved to different location - Easy way to update database? Moving Pictures 2
    k12158 [solved] Kein direkter Wechsel von TV-Kanal zu TV-Kanal mehr nach Update? Allgemeines Support- und Diskussionsforum 16
    ajs Mediaportal update to .Net 4.6.2+ MediaPortal 1 13
    Mr6686 [solved] Titan skin broken since update to 1.23 Installation, configuration support 6
    B TV-Server Auto-Update mptvdb after x hours General Support 0
    TLD Windows 10 1903 feature update General Support 3
    azzuro [Pending] Update MP1 to VisualStudio 2019 MediaPortal 1 36
    A Problem Windows 10 64 bit prof. Update auf Version 1903(gelöst) Installationsprobleme? 0
    T No TV after updating Windows 10 to latest Version 1903 / OS build 18362.175 (logs attached) General Support 2
    M [solved] Updated Swedish translation for MP 1.24 Submit: Localization of MediaPortal and DeployTool 0
    framug 1.22.0 BasicHome Editor settings for DefaultWide HD skin not kept when update 1.22 3
    Neoculture Bulk file name update My TVSeries 6
    HTPCSourcer [Evaluate] MP2-Updates do not remove the GUID of previous installs MediaPortal 2 13
    Rob Hexenmeister [solved] Latests Media Handler - Skinning an updating window or control Fanart Handler 26
    Similar threads

























    Top Bottom