Various questions

Discussion in 'General' started by raffe, May 5, 2017.

  1. raffe

    raffe Portal Pro

    Joined:
    March 28, 2008
    Messages:
    212
    Likes Received:
    35
    Ratings:
    +45 / 0
    Show System Specs
    It is probably something I have done wrong, but I can't get MP2 to work as well as MP1. I really would like it to, as I like the idea of a central database. My first problem is scraping my movies and TV-series. I have four network sources with movies (around 3000 movies) and two network sources of TV-series (around 400 TV-series and 10000 episodes). The import never completes for neither movies or TV-series, for a while it tries and counts up but then it get stuck. But even if MP2 says it has found, say 400 Action movies, when I choose category Action MP2 say it cant show the category (something about built the view, of course, I can not access the computer right now to see the correct message). Smaller things are that it is much slower than MP1 (it's a new computer), every time I choose something in the menu I have to wait, and wait. I also have a strange broken sound every time I hover over a choice in the main menu, in the background I hear a blip that I think I should hear. So when I cant import everything, and what I can import I cant see, it's hard for me to use MP2 ;-) So, what am I doing wrong?


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. TheMerovingian
    • Premium Supporter

    TheMerovingian MP Donator

    Joined:
    September 18, 2004
    Messages:
    324
    Likes Received:
    13
    Location:
    Kaufbaire
    Ratings:
    +20 / 0
    Home Country:
    Germany Germany
    Show System Specs
    You will need to upload logs. No help without it.
     
  4. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Hello @raffe ,

    As @TheMerovingian pointed out, please upload complete logs. Regarding your comments there are a couple of things to consider. The main difference between MP1 and MP2 is that the later downlaods all (and even more) information that MP1 is collecting across a multitude of different plugins in one go. While it does so, the importing process leads to heavy activity on the system, especially if you have defined all your shares, i.e. movies, series, music in parallel, which leads to all imports taking place simulataneously. While the importer process is active, the system responsiveness is affected.

    For a fair comparison betwen MP1 and MP2 you should analyze what steps need to happen with MP1. Note that whatever you do, the different media types will not be loaded simultaneously. YOu will need to subsequently load the info for movies, series, music etc. separately. Note also that fanart is downlaoded separately, probably using the FanartHandler plugin. One other thing to note is that when choosing the MP2 online sources to look up, less is actually more. For example MusicBrainz is terribly slow. Lastly as long as the importer is running the database can be in a in-between state.

    Can't tell without logs. If problems persists you might want to consider to start all over again in a controled manner. Deleting the C:\ProgramData\Team MediaPortal\... folders of MP2 puts you to a clean start. If you'd like to go down this path, then simply stop the MP2 Server service, delete/rename the MP2 folders in ProgramData, restart the server service and then redo your settings. Then set your online source selection - again, less sources speed up things. After that add one share only, e.g. start with the movies and let the iporter run. Note that a full import consists of two runs, but at least for movies you'll already have a fair collection of informaiton upon the first cycle.
     
  5. raffe

    raffe Portal Pro

    Joined:
    March 28, 2008
    Messages:
    212
    Likes Received:
    35
    Ratings:
    +45 / 0
    Show System Specs
    OK, I have tried to import two more times, but it still don't want to go to 100% (last time only to 47% overall) and it still say "This view could not be built" when I try so see what movies it has found. Here are som logs. FYI, I have no problems with making a clean install again, this is just a MP2 test computer
     
    Last edited: May 7, 2017
  6. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Errors in the log, particularly when loading movies from 192.168.222.247/Public/Filer/_Film_o_Musik/_Filmer_TV-serier_RippadDVD-samling/Filmer. Maybe one file is not read in correctly. The log contains messages like
    What kind of files are you holding there?

    OK, then please close the client, stop the server using the small try icon menu, then delete the folder c:\ProgramData\Team MediaPortal and start the server again.
    Then start the client and setup your system from scratch, i.e. language and online sources. Then add just one (1) of your different shares and try the import. The goal is to narrow down the source of the problem.
     
  7. raffe

    raffe Portal Pro

    Joined:
    March 28, 2008
    Messages:
    212
    Likes Received:
    35
    Ratings:
    +45 / 0
    Show System Specs
    In that folder I have movies (avi, mp4, mkv), .imdbid.txt files (imdb ID), .nfo files (imdb info), .WatchStatus.xml, .cover.jpg, .fanart.jpg and subtitles (sub, srt). I also had some .zip files with subs, but I have now deleted them.

    I have now deleted c:\ProgramData\Team MediaPortal . It was over 5,7 GB big and had over 87.000 objects!

    I restart PC. I start MP2, I change to Englush (US). I enabled Trakt.

    And now I try to add only the above folder as a movie media source. I choose "Network neighborhood", I get rotating balls, but I never come past them and after 10 min I think MP2 has crashed. It is not responsive, and nothing happens anymore for 10 minutes. I collect No_1 loggs. I see it says "check your internet connection and the status of Online TV Database - An open directory of television shows for HTPC software". On the same computer I test to surf to thetvdb.com, and I do so without problems.

    I restart the PC. Start MP2. And now I try again to add only the above folder as a movie media source. I choose "Network neighborhood", I get rotating balls. It is a Intel Core i7-2670QM @ 2,20GHz and 8 GB RAM with 64-bit Win 10 pro. When I check with Explorer it has no problems finding network shares. After 10 min waiting, I guess it has gotten stuck again. But this time the balls are still rotating. I collect No_2 loggs.

    I will now give up this installation and will try to totally uninstall MP2 and then reinstall it. I will post what happens...
     
  8. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Did you define server credentials for tne network access?

    This is completely independent of MediaPortal. The server is running under a different user context than Explorer, which shows access using your personal logon info. You need to set access rights in the respective MP2 server settings dialogue.

    No need to.
     
  9. raffe

    raffe Portal Pro

    Joined:
    March 28, 2008
    Messages:
    212
    Likes Received:
    35
    Ratings:
    +45 / 0
    Show System Specs
    I have now tried this
    1. I uninstall MP2 from control panel.
    2. I restart PC
    3. I search the computer after files with "portal" in the name.
      1. I delete C:\ProgramData\Team MediaPortal
    4. I search the registry after keys with "portal" in the name.
      1. I delete {D3DD4C59-D3A7-4B82-9727-7B9203EB67C0} (MediaPortal IPTV Source Filter)
      2. I delete {42714946-3757-4B29-86FB-9DC74ECC6EFD} (CyberLink MPEG Muxer Property Page, C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins\SlimTv.Service3\PDMpgMux.ax)
      3. I delete {7F2BBEAF-E11C-4D39-90E8-938FB5A86045} (PDR MPEG Muxer, C:\Program Files (x86)\Team MediaPortal\MP2-Server\Plugins\SlimTv.Service3\PDMpgMux.ax)
      4. I delete 5987326e_0 ({2}.\\?\hdaudio#func_01&ven_10ec&dev_0889&subsys_104d5f00&rev_1000#{6994ad04-93ef-11d0-a3cc-00a0c9223196}\singlelineouttopo/00010001|\Device\HarddiskVolume3\Program Files (x86)\Team MediaPortal\MP2-Client\MP2-Client.exe%b{00000000-0000-0000-0000-000000000000})
    5. I restart PC
    6. I download a new fresh MP2.1 and install Client and Server
    7. I start MP2, I change to English (US). I enabled Trakt. I give server credentials for the network access.
    8. And now I try to add only the above folder as a movie media source. I choose "Network neighborhood". I choose manual input and add \\192.168.222.247\Public\Filer\_Film_o_Musik\_Filmer
    9. I choose "Share watcher" and then "Video - Movie"
    10. I go to Media sources overview, it now say "Importing".
    11. After a while it says nothing, so I go to Videonav - Movies. There it says <No items to display>
    12. I close down MP2 and restart the PC
    13. I click on ReImport, it says Importing... And after 5 minutes it starts count %. After 10 minutes it comes too 100%.
    14. I go to Videonav - Movies. There it says <No items to display>
    15. I make new logs to post here
     
    Last edited: May 8, 2017
  10. ge2301
    • Team MediaPortal

    ge2301 MP2 Design

    Joined:
    January 11, 2014
    Messages:
    6,216
    Likes Received:
    1,565
    Gender:
    Male
    Occupation:
    Automotive Industry
    Location:
    Stuttgart (But living abroad)
    Ratings:
    +2,355 / 2
    Home Country:
    Germany Germany
    I can not see any movie added from the logs. It should look like:
    [2017-04-26 01:07:38,164] [969261 ] [71 ] [INFO ] - Refreshed media item bc822d5d-2644-446b-862f-9eab3fc45e70 (Vikings - S04E16 - Crossings.mkv) (14 ms)

    In your case I see MP2 only trying to import subtitles. There is not even one ending like *.mkv, *.mp4, *.avi in the server logs. Which format do your videos have?
     
  11. HTPCSourcer
    • Team MediaPortal
    • Administrator

    HTPCSourcer MP2 Product Manager

    Joined:
    May 16, 2008
    Messages:
    10,745
    Likes Received:
    1,125
    Gender:
    Male
    Ratings:
    +2,408 / 22
    Home Country:
    Germany Germany
    Show System Specs
    Hello raffe,

    A few comments:

    The manual imput is possible, but should not be necessary. The log shos that you rhosts are found - you simply need to wait a little bit until they get displayed rather than entering the path.

    Please don't restart the PC in between. Importer jobs might still be running. There should be (and is) no need to restart the PC.

    In the log I can see that you've named your movie subtitle files in the following way:
    Warm Bodies (2013) (Warm.Bodies.2013.(7.1ComedyHorrorRomance).BDRiP.MP3.XViD-SANTi.Swedish.srt

    What is the file name of the orignial movie? I remember a problem with filenames of this kind where a user had named his files in a siilar manner and the importer got confused trying to identify long file descriptions. Ideally your movies wouold be named in the format Moviename (Year).ext

    So to nail this down I propose that you
    • remove the share
    • create a new subdirectory on your NAS
    • copy one or two movies to this new subdirectory
    • rename movies into the format name (year)
    • define this subdirectory as a new share
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!