Version 0.2.0.0 Beta (1 Viewer)

Symphy

Retired Team Member
  • Premium Supporter
  • August 25, 2007
    501
    151
    Groningen
    Home Country
    Netherlands Netherlands
    Country flag
    This is a very specific request, rather than the norm, it really shouldn't get coded into anything except as an option. EDIT: Sorry that sounded crappy, I meant to say 'maybe' :)
    At least the value of 120 should be variable, but all 5.1 and 7.1 setups include a LFE, so it's not that far off the norm :)
    I'd say there should be VST plugins available for multichannel upmixing. However the plugin currently does not support VST's with diferent number of input/output channels, and that may become a problem. Might be worth looking into.

    Symphy, any more thoughts on the possibility of adding FFDSHOW audio? This would solve a lot of configurable issues like the above, plus give all the wonders of EQ, resampling, mixing etc.
    Problem is, there is currently no proper way to combine Directshow stuff with BASS audio... at least not that i know of.

    Symphy
     

    sique

    MP Donator
  • Premium Supporter
  • November 25, 2007
    21
    0
    Stord
    Home Country
    Norway Norway
    Country flag
    What exactly do you want to do with it? As it is now the LFE channel is simply feeded with a full-range left/right mix.
    Do you want to cut away frequencies above 120 Hz or so?
    Yes! I would like :
    • to remove the frequencies below 120Hz on right / left channels
    • to send only these frequencies towards the LFE

    VST plugins should have accesss to all output channels. What kind of outputdevice are you using
    Note that upmixing only works when using a 5.1 or 7.1 outputdevice, not when directly steering S/PDIF! The latter would require a AC3 or DTS encoder, which is not present.
    I'm not sure what situation applies to you, a logfile will make things clear.
    I use (in 5.1) the analogical outputs of Terratec Aureon firewire 7.1.
    I am going to take out a logfile...

    Thank you for your help!
    Regards,

    In Foobar2000 I use foo_dsp_xover to obtain this (foo_dsp_xover), maybe it's possible to add support for foobar2000 plugins? :) Or maybe there's already a VST-plugin that can do the same?
     

    anvandarnamn

    Portal Pro
    February 15, 2007
    84
    3
    37
    Home Country
    Sweden Sweden
    hi !

    thanks for a great plugin!

    I only have one problem, one kind of irritating,,,

    I have a g35 motherboard connected through hdmi to my receiver, using vista i have selected 7.1 speakers. Everything works like a charm, but when i am using this audio plugin the board still outputs 7.1 channels, i would like it to output 2channels only... (need that to decode HDCDs and play bitperfect...)

    If i select only 2channels in vista audio settings, it does exactly what i want , but then i need to change it back to 7.1 when watching movies...
    is there any way to have the plugin to take exclusive control over the audio device and only send as many channels of sound as the source i am playing has...

    i have tried both asio and windows device, both of them sends 7.1 lpcm to the receiver (only 2 channels active though)

    Thanks!

    Best Regards
    Daniel
     

    iolaus

    Portal Member
    January 18, 2008
    12
    0
    Home Country
    United States of America United States of America
    Cool! We just beat BASS :cool:

    Did I mention:

    love010.gif

    You make me blush phunqe! :D

    ...what about implementing Wasapi?...
    As soon as i have a Vista development environment available here, i'll look into it. But i'm afraid that's not gonna happen real soon.

    Regards,
    Symphy

    Anything we could do to help out on this front? Perhaps donations are in order? I'd be very excited for WASAPI exclusive mode in Media Portal.
     

    Symphy

    Retired Team Member
  • Premium Supporter
  • August 25, 2007
    501
    151
    Groningen
    Home Country
    Netherlands Netherlands
    Country flag
    Everyone,
    Sorry i have been absent for the last 5 weeks or so... been quite busy with things other then MP. The good news is my vacation has started, so i'll try to answer all new posts and release 2.0.0 final in the next few days.

    Symphy
     

    anvandarnamn

    Portal Pro
    February 15, 2007
    84
    3
    37
    Home Country
    Sweden Sweden
    hi !

    thanks for a great plugin!

    I only have one problem, one kind of irritating,,,

    I have a g35 motherboard connected through hdmi to my receiver, using vista i have selected 7.1 speakers. Everything works like a charm, but when i am using this audio plugin the board still outputs 7.1 channels, i would like it to output 2channels only... (need that to decode HDCDs and play bitperfect...)

    If i select only 2channels in vista audio settings, it does exactly what i want , but then i need to change it back to 7.1 when watching movies...
    is there any way to have the plugin to take exclusive control over the audio device and only send as many channels of sound as the source i am playing has...

    i have tried both asio and windows device, both of them sends 7.1 lpcm to the receiver (only 2 channels active though)

    Thanks!

    Best Regards
    Daniel

    Anything we could do to help out on this front? Perhaps donations are in order? I'd be very excited for WASAPI exclusive mode in Media Portal.

    seems like the answer to my problems is WASAPI . When using the latest version of the foobar2000 player and its Wasapi-plugin it takes exclusive control over the sound and outputs as many cannels as the source at the correct samplerate. To bad the foobar plugin for mediaportal doesnt work with this version....
    So... :D , Symphy, what about implementing WASAPI support? :oops::p

    as said before, maybe donations are in order?

    Nice to see that you are back symphy! was a bit worried that you had left us.. :eek:

    thanks for a great plugin!
     

    Symphy

    Retired Team Member
  • Premium Supporter
  • August 25, 2007
    501
    151
    Groningen
    Home Country
    Netherlands Netherlands
    Country flag
    seems like the answer to my problems is WASAPI . When using the latest version of the foobar2000 player and its Wasapi-plugin it takes exclusive control over the sound and outputs as many cannels as the source at the correct samplerate. To bad the foobar plugin for mediaportal doesnt work with this version....
    So... :D , Symphy, what about implementing WASAPI support? :oops::p

    as said before, maybe donations are in order?

    Nice to see that you are back symphy! was a bit worried that you had left us.. :eek:

    thanks for a great plugin!

    WASAPI is slowly surrounding me... WHAA!! :D

    But seriously. I cannot promise anything yet on new major features. Why that is you'll findout soon. (No worries, i won't be leaving this project:))

    Symphy
     

    trevor

    Portal Pro
    October 17, 2006
    1,600
    950
    Chelmsford
    Home Country
    United Kingdom United Kingdom
    Hi Symphy,

    Thanks for your efforts in PureAudio. It's an incredible plugin!
    I do still have the following issue on Vista as mentionned in this topic:

    https://forum.team-mediaportal.com/...g-asio-all-svns-since-17453-a-35928/index4.ht

    Is there any news around a possible fix?

    Thanks! :D

    Are you using the PureAudio.mpi from the 1st post in this thread?

    I had that problem originallyand the MPI version in the reporistry (0.1.3.0) still causes that. The 'Version 0.2.0.0 Beta' on the 1st post is what I currently use and all works like a charm. Have to get the ASIO4ALL config right but have not troubles...

    Trevor
     

    Users who are viewing this thread

    Top Bottom