[fixed] VolumeHandler problems (1 Viewer)

arion_p

Retired Team Member
  • Premium Supporter
  • February 7, 2007
    3,373
    1,626
    Athens
    Greece Greece
    Country flag
    I am not really sure what is going on here, but it appears as if the mixer device disappears after resume from stand by. When the issue happens, can you open the volume control of Windows and change the volume? (I bet the speaker icon in the icon tray has disappeared :confused:)
     

    lordie

    MP Donator
  • Premium Supporter
  • December 19, 2007
    65
    5
    Prague
    Czech Republic Czech Republic
    Country flag
    I am not really sure what is going on here, but it appears as if the mixer device disappears after resume from stand by. When the issue happens, can you open the volume control of Windows and change the volume? (I bet the speaker icon in the icon tray has disappeared :confused:)
    Well, it is not exactly so. The MP is able to control volume after stand by. But then when I perform steps described above like video dialog open or DVD playback (but here dialog is opened too), volume can't be controled anymore. BUT just within MP, I tried to switch to window mode and volume control of Windows worked fine!
     

    Seidelin

    Retired Team Member
  • Premium Supporter
  • August 14, 2006
    1,755
    652
    Kgs. Lyngby
    Denmark Denmark
    Country flag
    You can try the attached dialogs.dll (just replace the one in plugins\windows folder). It should fix your issue. It is a build of current code, so if it works with this one, the bug is already fixed for RC3.
     

    lordie

    MP Donator
  • Premium Supporter
  • December 19, 2007
    65
    5
    Prague
    Czech Republic Czech Republic
    Country flag
    You can try the attached dialogs.dll (just replace the one in plugins\windows folder). It should fix your issue. It is a build of current code, so if it works with this one, the bug is already fixed for RC3.
    Unfortunatelly provided dll doesn't work (no dialog is displayed anymore).
     

    The Doctor

    MP Donator
  • Premium Supporter
  • December 24, 2007
    180
    14
    Netherlands Netherlands
    Country flag
    ok, here my logs. I guess the logs are a bit long `cause it covers the whole weekend until now. I could not control volume anymore after watching tv for some time and then playing a ripped CD in the .flac coding. It all happend at the end of the logs.
     

    lordie

    MP Donator
  • Premium Supporter
  • December 19, 2007
    65
    5
    Prague
    Czech Republic Czech Republic
    Country flag
    Hi,

    it seems that (at least on my system) the problem is caused by minidisplay plugin. When I disabled it, volume can be controlled all the time...
    I just hope the issue will be really solved in RC3 (and looking forward it :) )
     

    Seidelin

    Retired Team Member
  • Premium Supporter
  • August 14, 2006
    1,755
    652
    Kgs. Lyngby
    Denmark Denmark
    Country flag
    MrHipp reimplemented parts of the fix and included some workarounds to fix it. It was believed to be working, but perhaps not completely on all systems. Create a proper bug report, and if you get no response on that send me a PM, and I will make sure to take a look.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 12
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24-1.26 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    geotwticher [solved] Fatal Error 0x80070643 during MP2 installation General 7
    Top Bottom