WASAPI Music Playback Problem with MiniDisplay Equalizer Enabled (1 Viewer)

Pirppuli

MP Donator
  • Premium Supporter
  • July 19, 2008
    63
    44
    Helsinki
    Finland Finland
    MediaPortal Version: 1.6.0

    Description
    Hi,

    I have a problem with WASAPI music playback & Intel HD4000 HDMI audio. When trying to play back track, after a few (~10) seconds, the rest of the track is played back at what seems like 10 times the normal speed.

    WASAPI music playback has never functioned properly for me with MP. Previously, I have tried it on the same hardware with MP1.4 and MP1.5 on Win 7 x64 & many different display driver versions.

    Logs attached.

    -P.

    Steps to Reproduce:
    Select WASAPI with Intel(R) Display Audio sound device in MP music player settings. Play a track. After a few (~10) seconds, the rest of the track is played back at what seems like 10 times the normal speed.

    Edit:
    Thread title edited to fit later findings.
     
    Last edited:

    Pirppuli

    MP Donator
  • Premium Supporter
  • July 19, 2008
    63
    44
    Helsinki
    Finland Finland
    As a side note: I have no problems using WASAPI with MPAR so on my setup this problem is isolated to music playback.

    Can someone either confirm the same issue with Intel HDMI audio or report that they have it working fine?

    @Sebastiii: Have you made any progress yet? :)
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    I can't really test but can you play with the buffer ? (set it to 0.5/0.6 or something ?) :)
     

    Pirppuli

    MP Donator
  • Premium Supporter
  • July 19, 2008
    63
    44
    Helsinki
    Finland Finland
    Doies this happen with every file?
    Yes, it does. Well, I haven't had the patience to try every music file I have, but random mp3 and flac tracks from different albums all have the same problem. These same tracks play fine fine with the default BASS engine.

    I'd like to get WASAPI working to be able to configure Windows for multichannel audio and get the proper 2-channel output when playing music. Plus, I'm currently tracking down issues with MP and Stereo Tool DSP (Winamp DSP stutters with BASS playback during crossfade; VST crashes frequently on track change). I have no DSPs activated currently nor did I have any when producing the logs earlier.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    X Music : WASAPI only plays one track then stops General Support 1
    Alberto83 The little non-definitive guide to video WASAPI General 8
    Riki73R Wasapi Exclusive for video with Gustard U12 General 2
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    horned_reaper [Music] 5012: Start current music track from the beginning Improvement Suggestions 21
    horned_reaper [solved] 5012: Restart current music track General Support 13
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper [solved] Music playback hangs General Support 58
    globaldonkey Music Database Error Listen Music 1
    joecrow Music on Headphones Listen Music 7
    2BitSculptor MP 1.23.. music stops playing General Support 6
    Sarxas What Music Are You Listening To? OffTopic 0
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    G [fixed] [MP2-786] Party Music Player can only play playlists with less than 1000 items 2.2 Archive 7
    KlausWirn Music crash Bass crash no change to play music Installation, configuration support 2
    BlueMax1916 [confirm] Music: Every 2nd track skipped MediaPortal 2 30
    N Music player help Listen Music 4
    N How to shuffle all my music, and how to sort by album artist General 4
    R MP 2.2 client spielt audio-titel kurz an und springt dann zum nächten Allgemeines Support- und Diskussionsforum 9
    joecrow Music: Fade Out not working 1.20 Pre Release 0
    M Music playback stops after certain files 1.19 0
    E [Pending] Handling Multifile Cue Submit: code patches (MediaPortal/TV-Server/etc.) 56
    K Flickering live TV playback Newcomers Forum 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    Similar threads

























    Top Bottom