xbmc (Frodo) with pvr functions (1 Viewer)

matejdro

Portal Pro
May 28, 2010
361
16
Slovenia Slovenia
With regular TSReader it says "Timed out while waiting for buffer file".
With TSReader and RTSP turned on, it says "PVR Client has no RTSP Support" :(

Also, is there a way to order channels in XBMC? They are in random order instead of in order set in MP TV Server.
 

SciDoctor

Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    With regular TSReader it says "Timed out while waiting for buffer file".
    With TSReader and RTSP turned on, it says "PVR Client has no RTSP Support" :(

    Also, is there a way to order channels in XBMC? They are in random order instead of in order set in MP TV Server.
    RTSP doesn't work/not supported.

    The timeout you are getting may be a slow network, increase the timout in XBMC

    My settings below incl channel order.


    client tv settings.JPG tv settings.JPG
     
    Last edited:

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,108
    3,694
    Lehmden
    Germany Germany
    Country flag
    Hi
    With regular TSReader it says "Timed out while waiting for buffer file".
    Same here. And if you look at the XBMC logs you see an error in path. There is a \\ before timeshift-buffer filename (D:\Timeshift\\llive2-0.ts.tsbuffer) but this has to be a single \ only.
    The timeout you are getting may be a slow network, increase the timout in XBMC
    No, the amount did not matter at all, as tsreader gets wrong path. Timeshift is started on TV Server but buffer file is not accessible due the error in path...

    Those having problems, could it be firewall problems?
    No local firewall running here (only to Internet in router) so this is definitely not the case.
     

    matejdro

    Portal Pro
    May 28, 2010
    361
    16
    Slovenia Slovenia
    Apparently, reading ts files is on XBMC side, not on TvServerXBMC as SciDoctor said.

    Code:
    ERROR: AddOnLog: MediaPortal PVR Client: Failed to open file 'C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live6-0.ts.tsbuffer' as '\live6-0.ts.tsbuffer'
    This error I get on XBMC. Of course it cannot work, because TV Server is on another PC.
     

    SciDoctor

    Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    I see you are both using W7 I use VISTA 32/64. MS SQL server.

    I have used host name and ip address both wrk fine on clients.

    Where are the logs for XBMC ? I couldn't find them, do I have to enable logging. Found them
     
    Last edited:

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,108
    3,694
    Lehmden
    Germany Germany
    Country flag
    Hi.
    The logs are at C:\Users\"The Username you use"\Appdata\Roaming\XBMC
    But this is for Win7. Did not know if there is another path in Vista, never used XBMC on Vista at all. Logs are always on in XBMC. But there is a "Debug Mode" with more details in Log. This can be activated in XBMC Settings
     

    SciDoctor

    Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    LOCAL CLIENT

    21:04:08 T:4676 INFO: AddOnLog: MediaPortal PVR Client: Channel stream URL: rtsp://192.168.2.1/stream13.0, timeshift buffer: D:\\live13-0.ts.tsbuffer
    21:04:08 T:4676 INFO: AddOnLog: MediaPortal PVR Client: Creating a new TsReader...
    21:04:08 T:4676 NOTICE: AddOnLog: MediaPortal PVR Client: CTsReader::Open(D:\\live13-0.ts.tsbuffer)
    21:04:08 T:4676 DEBUG: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() Trying to open D:\\live13-0.ts.tsbuffer
    21:04:08 T:4676 INFO: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() D:\\live13-0.ts.tsbuffer.
    21:04:08 T:4676 DEBUG: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile: OpenFile(D:\\live13-0.ts.tsbuffer) succeeded.
    21:04:08 T:4676 DEBUG: PVRFile - XFILE::CPVRFile::Open - playback has started on filename pvr://channels/tv/All TV channels/47.pvr
    21:04:08 T:4676 DEBUG: CDVDInputStreamPVRManager::Open - stream opened: pvr://channels/tv/All TV channels/47.pvr

    NETWORK CLIENT

    21:15:32 T:2260 INFO: AddOnLog: MediaPortal PVR Client: Channel stream URL: rtsp://192.168.1.64/stream2.0, timeshift buffer: D:\\live2-0.ts.tsbuffer
    21:15:32 T:2260 INFO: AddOnLog: MediaPortal PVR Client: Creating a new TsReader...
    21:15:32 T:2260 NOTICE: AddOnLog: MediaPortal PVR Client: CTsReader::Open(D:\\live2-0.ts.tsbuffer)
    21:15:32 T:2260 INFO: AddOnLog: MediaPortal PVR Client: CTsReader:TranslatePath D:\\live2-0.ts.tsbuffer -> \\HTPC-PC\D\live2-0.ts.tsbuffer
    21:15:33 T:2260 DEBUG: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() Trying to open \\HTPC-PC\D\live2-0.ts.tsbuffer
    21:15:33 T:2260 INFO: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile() \\HTPC-PC\D\live2-0.ts.tsbuffer.
    21:15:33 T:2260 DEBUG: AddOnLog: MediaPortal PVR Client: FileReader::OpenFile: OpenFile(\\HTPC-PC\D\live2-0.ts.tsbuffer) succeeded.
    21:15:33 T:2260 DEBUG: PVRFile - XFILE::CPVRFile::Open - playback has started on filename pvr://channels/tv/All TV channels/40.pvr
    21:15:33 T:2260 DEBUG: CDVDInputStreamPVRManager::Open - stream opened: pvr://channels/tv/All TV channels/40.pvr
     

    Lehmden

    Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,108
    3,694
    Lehmden
    Germany Germany
    Country flag
    Hi.
    Just did some further testing. Tonite TSreader is working in multiseat. Also I did not change a single item on XBMC...
    BUT I've upgraded to latest MP 1.3 Beta Build from 2012-12-06. Now multiseat Live TV is working in XBMC again.

    Maybe tomorrow it's broken again ;)
     

    joxen

    MP Donator
  • Premium Supporter
  • May 14, 2008
    146
    14
    stockholm
    Sweden Sweden
    disable auto ip in streming server settings in mptvserver then it is working for me .
     

    Holzi

    Super Moderator
  • Team MediaPortal
  • April 21, 2010
    7,930
    2,234
    Ba-Wü
    Germany Germany
    Country flag
    I tried to move a post from @wouter1971 here but failed thats why I repost it:

    @Holzi: We disagree on the Quality part. But that's another subject.

    1) Videoplayback is still not silkysmooth and in xbmc it is.
    2) Codec hell is also still an issue in MP. No codec configuration in XBMC and HD audio engine.
    3) MP starting up takes ages.

    Those are key elements of the user (and WAF) experience.

    But let's continue here Vergleich XBMC 12 (Frodo) Beta mit MediaPortal 1.3 Beta
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom