xmltv not automatically importing TVguide.xml if located on a network drive (1 Viewer)

VdR

MP Donator
  • Premium Supporter
  • October 17, 2006
    612
    16
    Belgium
    Netherlands Netherlands
    TV-Server Version: 1.0 RC3
    MediaPortal Version: 1.0 RC3
    MediaPortal Skin: MP Gold 1366x768 1.0 RC3
    Windows Version: XP professional SP3
    CPU Type: Intel P4 530 3.0 GHz HT (S775)
    HDD: WD 500 GB SATA 7200 RPM + 3x WD USB2.0 500 GB (on remote server)
    Memory: 1 GB (2 x 512 MB) Hynix DDR400 Dual Channel
    Motherboard: ASUS PTGD-LR
    Video Card: ATI Radeon X300SE 128 MB
    Video Card Driver:
    Sound Card: Realtek Intel High Definition Audio (7.1) 24 bits / 96 kHz
    Sound Card AC3: S/Pdif coaxial to Logitech Z5500
    Sound Card Driver:
    1. TV Card: BlackGold GDI
    1. TV Card Type: DVB-T
    1. TV Card Driver:
    2. TV Card: BlackGold GDI
    2. TV Card Type: DVB-T
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: MPV
    MPEG2 Audio Codec: MPA
    h.264 Video Codec:
    Satelite/CableTV Provider: none
    HTPC Case: HP Z522
    Cooling: Cooler Master KDH-5067K
    Power Supply:
    Remote: HP MCE remote
    TV: Samsung LE32R41B
    TV - HTPC Connection: Sub-D

    PROBLEM:

    The tvguide.xml file is not automatically imported if the file is located on a shared network drive (e.g. \\gx270\xmltv).

    A forced import of the same file (import button in TVserver config) works fine. Which suggest all settings are OK. An automatic import of the same file works fine (if relocated to a local drive and the path in TVserver config is adjusted accordingly).

    Can someone confirm this behaviour?

    This is important to me, because this network drive is on the only PC in the network that runs 24/24 and that is destined to become the TV server. My HTPC is not running 24/24 and is not password protected and can therefore not run a schedule to create the tvguide.xml file. I have not found a good work arround apart from the forced import (cumbersum).

    VdR

    PS
    This is a copy of the message under bug reports MP, I suppose it belongs here under TVserver
     

    VdR

    MP Donator
  • Premium Supporter
  • October 17, 2006
    612
    16
    Belgium
    Netherlands Netherlands
    I thought I had found a work around for this problem by using the third (remote) tab in the TVserver setup. If I put the path to the TVguide.xml file on the network drive here and use the 'get it' button it copies the file without a problem. But unfortunately, again if left to the schedule it fails. Same problem.

    I have attached the TVserver_tv.log file.

    If you look at 2009-01-02 10:19:58, you see the succesfull forced ('get it' button) download from [SetupTV].

    2009-01-02 10:19:58.656250 [SetupTv]: HTTP URL detected.
    2009-01-02 10:19:58.656250 [SetupTv]: initiating download of remote file from \\gx270\xmltv\TVguide.xml
    2009-01-02 10:19:59.140625 [SetupTv]: File downloaded.

    If you look at 2009-01-02 10:22:59, you see the failed download from [4] (access denied).:mad:

    2009-01-02 10:22:59.515625 [4]: HTTP URL detected.
    2009-01-02 10:22:59.515625 [4]: initiating download of remote file from \\gx270\xmltv\TVguide.xml
    2009-01-02 10:22:59.515625 [4]: File transfer is in progress. Waiting...
    2009-01-02 10:22:59.515625 [24]: Download failed: (Access to the path '\\gx270\xmltv\TVguide.xml' is denied.).

    VdR
     

    jestermgee

    Portal Pro
    February 23, 2008
    129
    0
    In a house
    I can certainly confirm this.

    My TV card is in my HTPC machine which is on all the time BUT I don't want importers and scrappers running on the machine so I offload this to my downloading server which is also online 24/7. The XML file is created on the remote machine and it never imported automatically. As you said, manually importing works fine. I even created a batch to delete the file before it was updated in case the issue was because the file create date never changed.

    So it seems like a remote path issue then?

    I do have a quick, dirty solution that will work... Copy the xml file to the Media Portal machine. Use a simple batch file to copy the file either on a schedule or when you launch MP. Should work. Alternatively, get your EPG grabber to write the file to the MP machine.
     

    VdR

    MP Donator
  • Premium Supporter
  • October 17, 2006
    612
    16
    Belgium
    Netherlands Netherlands
    Thank's, now I don't feel such a fool anymore ...

    Yes, that's the workaround I use now.

    BUT

    I can't pull the file from the HTPC, because I can't run a schedule on that machine (no P/W). Therefore I push the file from the server and that fails if the HTPC happens to be on standby at the scheduled time ...

    Now that I'm typing this ... I think it should be possible to have IRserver run a batch to pull the file everytime the HTPC comes out of standby, just like it blasts my amplifier to wake up. I will have to check that possibility.

    VdR

    Unfortunately.

    Although IRserver can do this in principle, it doesn't work. The batch execution can be programmed and linked to the event, the test button works, but IRserver doesn't actually react to the PC suspend and PC resume events.

    It is also not working for the the amplifier blasting, this is still one of the open issues on my HTPC.

    Back to square one.

    I see two big weaknesses of MP; integrated IR control and blasting (the standard implementation is incomplete and the IRserver plugin is not ready) and integrated power scheduling (again a combination of standard functions and plugins that certainly for multi seat doesn't seem to work well).

    VdR
     

    Nitram

    Portal Member
    August 11, 2007
    14
    0
    I have the same probs....

    is there some way to load a copy batch file after standby/hibernate?

    there is a field for some code to run before epg importing in xlmtv/tv3, is there an possibility?


    /Nitram
     

    chemelli

    Retired Team Member
  • Premium Supporter
  • September 28, 2006
    6,159
    2,264
    46
    Milano, Italy
    Italy Italy
    Country flag
    Do you know that a service is running with a limited account ( local system account ) that has no grant over network ?
    Try running it with the users you log usualy on to the desktop ;)

    Simone
     

    VdR

    MP Donator
  • Premium Supporter
  • October 17, 2006
    612
    16
    Belgium
    Netherlands Netherlands
    Nitram,

    I understand the issue, but I'm not sure how you plan to solve it. Let me know if you succeeded (and how).

    Thx.

    VdR
     

    Nitram

    Portal Member
    August 11, 2007
    14
    0
    It worked to set the user as "me" whit network rights :D:

    so I call this problem solved

    nevermind the other stuff

    /Nitram
     

    VdR

    MP Donator
  • Premium Supporter
  • October 17, 2006
    612
    16
    Belgium
    Netherlands Netherlands
    Nice that you solved it.

    But you lost me. :oops:

    What do you mean with 'set the user'? Did you logon to windows with that user? Does the user has to be set for the HID service as per your screen shot (where do I find that then)?

    thx.

    VdR
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    framug No color in TVGuide when XMLTV without DVB EPG MediaPortal 1 Talk 59
    B xmltv - cannot import tvguide.xml australia Installation, configuration support 0
    geotwticher TV Guide EPG Grabber for Australia 2020 RIP freepg.tv General 4
    P Timeshifting in XMLTV General 2
    C Can the XmlTv Plugin handle 600+ channels? General 3
    JJDoherty 1.22.0 XMLTV not raising the following OnImportEpgPrograms event... 1.22 0
    lacanox XMLTV not writing the tv schedule Electronic Program Guide 3
    A [solved] XmlTv not importing programs General 8
    dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
    T No data available using xmltv and mc2xml xmlTV 2
    W XMLTVImport duplicate item error xmlTV 5
    J Schedules Direct - XmlTV Plugin xmlTV 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    vapourEyes Automatically Re-Tune Periodically Improvement Suggestions 1
    vapourEyes Automatically Tune to Strongest Duplicate Channel Improvement Suggestions 102
    W [solved] [FIXED] Survivor season 40 not automatically matching My TVSeries 1
    G Switch to new channel at begining of program automatically Feature Requests 0
    C How do I get MediaPortal to separate recording files by channel and month? General 2
    H MP1.21F video database scan, can it be scheduled to automatically run in background General Support 5
    Steve.Rayner61 Online Videos - Automatic Updates fails 'Automatic update disabled. Check your internet connection' OnlineVideos 10
    greybox 1.20 final does not update video duration automatically 1.20 10
    greybox 1.20 final does not update video duration automatically 1.20 Pre Release 1
    Lichloathe MP2 importing keyart instead of poster General 0
    P Recordings not showing up unless re-imported and not possible to delete General 0
    C Importer works super slow My TVSeries 5
    Similar threads

























    Top Bottom