1.16 Pre Rel. crashes after w10 update

Discussion in 'General Support' started by AL0104, March 15, 2017.

  1. AL0104

    AL0104 New Member

    Joined:
    March 15, 2017
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    Hello all,

    I wonder if anyone can help a not very tech-savvy user like me.
    MP 1.16 pre has been running perfectly on my PC, however Win 10 updated last night & since then MP crashes everytime when trying to access live TV or watch recordings.



    (The windows update were Windows 10 Version 1607 for x64-based Systems (KB4013418) & Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4013429))

    Event viewer shows the following two errors each time Mediaportal stops working -

    Log Name: Application
    Source: .NET Runtime
    Date: 15/03/2017 09:40:05
    Event ID: 1026
    Task Category: None
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: Media-PC
    Description:
    Application: MediaPortal.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: exception code c0000005, exception address 6E04346B

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name=".NET Runtime" />
    <EventID Qualifiers="0">1026</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-03-15T09:40:05.953977700Z" />
    <EventRecordID>12419</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Media-PC</Computer>
    <Security />
    </System>
    <EventData>
    <Data>Application: MediaPortal.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: exception code c0000005, exception address 6E04346B
    </Data>
    </EventData>
    </Event>

    AND

    Log Name: Application
    Source: Application Error
    Date: 15/03/2017 09:40:06
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: Media-PC
    Description:
    Faulting application name: MediaPortal.exe, version: 1.15.100.0, time stamp: 0x585d0f8d
    Faulting module name: CompPkgSup.DLL, version: 10.0.14393.953, time stamp: 0x58ba5a1f
    Exception code: 0xc0000005
    Fault offset: 0x0000346b
    Faulting process id: 0x1a90
    Faulting application start time: 0x01d29d6fec216826
    Faulting application path: C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.exe
    Faulting module path: C:\Windows\System32\CompPkgSup.DLL
    Report Id: e24fd279-9573-4fc9-97af-cf18685979e9
    Faulting package full name:
    Faulting package-relative application ID:
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-03-15T09:40:06.802301800Z" />
    <EventRecordID>12420</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Media-PC</Computer>
    <Security />
    </System>
    <EventData>
    <Data>MediaPortal.exe</Data>
    <Data>1.15.100.0</Data>
    <Data>585d0f8d</Data>
    <Data>CompPkgSup.DLL</Data>
    <Data>10.0.14393.953</Data>
    <Data>58ba5a1f</Data>
    <Data>c0000005</Data>
    <Data>0000346b</Data>
    <Data>1a90</Data>
    <Data>01d29d6fec216826</Data>
    <Data>C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.exe</Data>
    <Data>C:\Windows\System32\CompPkgSup.DLL</Data>
    <Data>e24fd279-9573-4fc9-97af-cf18685979e9</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    </EventData>
    </Event>

    Thanks, Al
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    Attach full log files please. :)
    Use the Watchdog tool with option 1 to start MP in debug mode, reproduce the problem, then attach the zip file produced by the Watchdog tool.
     
  4. AL0104

    AL0104 New Member

    Joined:
    March 15, 2017
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    Thanks very much. I've attached the log files as instructed
     
    • Thank You! Thank You! x 1
  5. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    I think the crash is happening because you haven't chosen/configured TV codecs (filters):
    [2017-03-15 10:58:16,542] [Log ] [MPMain ] [INFO ] - VMR9: added EVR Renderer to graph
    [2017-03-15 10:58:16,547] [Log ] [MPMain ] [DEBUG] - VMR9: Now active
    [2017-03-15 10:58:16,551] [Log ] [MPMain ] [DEBUG] - VMR9: Renderer successfully added
    [2017-03-15 10:58:16,562] [Error ] [MPMain ] [ERROR] - Failed filter: not found
    [2017-03-15 10:58:16,573] [Log ] [MPMain ] [DEBUG] - TSReaderPlayer: UpdateFilters Video done
    [2017-03-15 10:58:16,578] [Error ] [MPMain ] [ERROR] - Failed filter: not found
    [2017-03-15 10:58:16,586] [Log ] [MPMain ] [DEBUG] - TSReaderPlayer: UpdateFilters Audio done

    MP is trying to auto-load various codecs:
    [2017-03-15 10:58:16,715] [ cb6c4f8] [ e10] - audPin:CompleteConnect() ok, filter: LAV Audio Decoder, iPosition: 0
    [2017-03-15 10:58:16,829] [ cb6c4f8] [ e10] - audPin:CompleteConnect() ok, filter: MONOGRAM AAC Decoder, iPosition: 0
    [2017-03-15 10:58:16,888] [ cb6c4f8] [ e10] - audPin:CompleteConnect() ok, filter: Microsoft DTV-DVD Audio Decoder, iPosition: 1
    [2017-03-15 10:58:17,017] [ cb6c4f8] [ e10] - vidPin:CompleteConnect() ok, filter: LAV Video Decoder

    ...but this is error prone as you're finding out.
    You really ought to choose codecs in MP Config as shown here:
    TV Codecs - MediaPortal 1 - MediaPortal Wiki
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  6. AL0104

    AL0104 New Member

    Joined:
    March 15, 2017
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    It seems odd because I already have my codecs in MP config exactly as in the link you gave (i.e., all LAV Video Decoder except for Audio renderer).
    Also I don't understand why it is crashing now after months of working with no issues. I haven't changed any settings - the only thing that has changed was this win 10 update last night & now suddenly MP doesn't work.
     
  7. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,541
    Likes Received:
    4,752
    Ratings:
    +8,220 / 17
    Home Country:
    New Zealand New Zealand
    MP Config selects the LAV codecs as defaults the first time you view the settings... and that's why you saw what you saw. Prior to that, MP itself was not using the LAV codecs. Many people get confused by this.

    Let me put it another way: if MP had been using the LAV codecs, why would there be log entries mentioning "MONOGRAM AAC Decoder" and "Microsoft DTV-DVD Audio Decoder"? Answer is, there wouldn't be.

    I know it's confusing. If you're confused, you may just have to trust me.

    It's crashing because the update added, removed or changed codecs or codec dependencies that MP is or was trying as part of the auto-loading process that I mentioned.

    Changes outside MP - including Windows updates, driver updates, other software being installed or removed, and other things too - can affect MP. I've seen this sort of thing time and time again. MP get's the blame and bad press... but it's not our fault.
     
  8. AL0104

    AL0104 New Member

    Joined:
    March 15, 2017
    Messages:
    5
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +1 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Show System Specs
    Yes, this appears to be a problem entirely caused by win10 auto updates. :censored:

    It now looks very much as if the update hadn't completed correctly & this has screwed up other applications, such as Mediaportal. After about 10 restarts, windows update attempted to install again & once completed, MP started working as before.

    Thanks very much for your help :)
    Al
     
  9. TheMerovingian
    • Premium Supporter

    TheMerovingian MP Donator

    Joined:
    September 18, 2004
    Messages:
    324
    Likes Received:
    13
    Location:
    Kaufbaire
    Ratings:
    +20 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Same problem here. After Win10 updates no live-TV.
    Now restarting for the third time...
    and I just chose in the TV-section LAV everywhere... it stood there already

    installed 1.16pre over my existing installation

    SOLVED
    unfortunately still problems when tryging to play recorded tv
     
    Last edited: March 15, 2017
  10. loiscooper91

    loiscooper91 Portal Member

    Joined:
    April 2, 2013
    Messages:
    35
    Likes Received:
    13
    Gender:
    Male
    Ratings:
    +16 / 1
    Home Country:
    France France
    Same problem here too, after windows 10 update in the night
    no live tv
    restart 8 time.....no new update found, i reinstall 1.15 on my existing 1.15... no solved :(

    no idea... please help

    i try to install 1.16 pre released....
     
  11. spachti

    spachti Portal Pro

    Joined:
    July 27, 2005
    Messages:
    373
    Likes Received:
    34
    Location:
    Bible Belt
    Ratings:
    +100 / 10
    Home Country:
    United States of America United States of America
    Seems to be related to this:
    Windows Media Foundation Bug in Cumulative update KB3216755 windows 10

    Quote


    This dll is causing problems with other media software - PowerDVD, DVB Viewer, Power Media Server and even Windows Media Player. Opening a folder containing MPEG2 files crashes dllhost/COM Surrogate. Even the .953 cumulative update of March 14th 2017 contains this problem - CompPkgSup.dll has been updated. The only way to fix my problem was to replace the new file with the version from the .693 build.

    Over at the DVB Viewer forum, there are even more complaints.
     
    • Agree Agree x 3
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!