1.16 Pre Rel. crashes after w10 update

loiscooper91

Portal Member
April 2, 2013
35
8
44
Thank for your fast answer
I am in my work (france ^^) , i post you this screenshot in 9h, when i come back to my home.
Big thanks MM
 

termsaka

New Member
March 16, 2017
1
1
45
Hi, I am with everyone, my media portal is crash after update window 10 yesterday.

And This what solver problem

1. Go to Control Panal - > Programs and Features - > View installed update and unistall "Security Update for Microsoft Windows (KB4013429)" [This Update is problem]
2. After Restart, you can media portal will work agian, Then follow below.
3. Download This File "Show or hide updates" tool from this link http://download.microsoft.com/download/f/2/2/f22d5fdb-59cd-4275-8c95-1be17bf70b21/wushowhide.diagcab
4. Then open this file "wushowhide' and then click "next" - > Hide updates - > Find (KB4013429) in Box and Check it. - > click "next" - > with until something it fix.
5. and That it. Problem Solve. [No. 4 is for prevent window 10 auto update this file in future.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    @termsaka
    Skipping updates is not recommended.
    It shouldn't be necessary to do this to avoid the problem. Just configure MP to use non-Microsoft codecs.
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,538
    113
    Cambridge
    Country flag
    Seems to be related to this:
    Windows Media Foundation Bug in Cumulative update KB3216755 windows 10

    Quote

    This dll is causing problems with other media software - PowerDVD, DVB Viewer, Power Media Server and even Windows Media Player. Opening a folder containing MPEG2 files crashes dllhost/COM Surrogate. Even the .953 cumulative update of March 14th 2017 contains this problem - CompPkgSup.dll has been updated. The only way to fix my problem was to replace the new file with the version from the .693 build.

    Over at the DVB Viewer forum, there are even more complaints.
    There is a discussion of the Win 10 update issue on the Plex forum - PMS Closing immediately after launch - which includes links to download an older version of CompPkgSup.dll if you need it.

    As mm1352000 suggests, the update seems to be causing a problem only with Microsoft codecs - I got the latest Win10 updates on my HTPC yesterday, and TV is working OK using LAV codecs.
     

    ste7e

    New Member
    March 16, 2017
    1
    1
    Just to add my 2c

    The reason I failed to fix this (despite reading the fix that eventually worked for me early on), was because I didn't realise something...

    The problem (for me) was as has been said many times in this thread, my configuration hadn't had the codecs explicitly set. So, although the config tool was showing LAV for all the codes, MP was trying to load all codec including the problematic MS ones.

    Now, I got this so I went in to the config tool. Went to the codec page and allowed it to set the default of LAV and clicked OK to write that back to the config. Restarted and still had the problem.

    What I didn't twig to, though, was that I needed to do the same ON EACH CODEC TAB! There are a number of tabs for the codecs - I had only done the first. So, I just paged through each tab to allow it to set the codec to LAV and clicked OK. Restarted the service and all worked.

    I have my TV back :)

    Thanks all for the help.
     

    TheMerovingian

    MP Donator
  • Premium Supporter
  • September 18, 2004
    324
    18
    Kaufbaire
    Country flag
    Just set every codec to LAV (as it already stood there).
    Went to TV-Setup to check whether I can preview a channel..
    Unknown error.
    Looked if the tvservice is running... it was not.
    Startet the tvservice
    Tried to preview again.
    TV-Setup crashed.

    Restarted my PC -> everything worked fine...
     
    Last edited:

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,541
    113
    Country flag
    Went to TV-Setup to check whether I can preview a channel..
    TV Server Config's preview function doesn't use MP settings.
    Test with MP and a normal DVB tuner. You'll find that it works.
    If you want to make preview work as well (IMHO unnecessary), you'll have to manually configure the DirectShow merits of the LAV and Microsoft codecs to ensure TV Server Config uses the LAV codecs and avoids the Microsoft codecs.

    Looked if the tvservice is running... it was not.
    This looks like a completely separate problem. Start a new thread please, and describe the source of these HTTP streams (eg. SAT>IP tuner, FritzBox, DVBViewer).
     

    loiscooper91

    Portal Member
    April 2, 2013
    35
    8
    44
    Re hi
    ok so i screenshot lav audio config for MM that you ask me
    i try before to put all codec to other codec on MP config tool..i click on OK
    i restart MP config, and put all codec to LAV filter, and click OK to write it (all tab !)

    tv live crash always...
    i add a new watchdog after put lav on default codec

    my screenshot for MM lav audio config

    upload_2017-3-16_17-28-45.png
    upload_2017-3-16_17-29-36.png





    upload_2017-3-16_17-29-8.png

    upload_2017-3-16_17-29-22.png



    Another thing. i put ON the LAV tray icon
    Video and series Working good. i have the @ tray icon LAV video and audio
    When i put TV, the 2 LAV tray icon appear, so TV use the lav filter !!(audio and video)

    Do you think it's a pb with my lav audio filter config ?
     
    Last edited:
    Top Bottom