aMPdroid 1.1 (1 Viewer)

DieBagger

Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    36
    Austria
    Austria Austria
    Hi guys,

    I want to give you a quick update on what's going on... There's progress but it's slow due to me not having much time atm. Also a big problem is that noone is working on MpExtended either so I had to do some work on the backend side of things too. So if any devs are interested in continuing the project that would be great.

    Some of the things happening:
    a) I'v included the vlc engine as internal media player which is working great (can play a lot more formats than the android media player)
    b) Thrown away lots of legacy code since the project became un-manageble. Sorry to say that this will mean the end of support for devices < 4.0 :(
    c) The sections menu can be configured by the user (the homescreen too)
    d) New design with navigationdrawer and some other nice stuff (transparent actionbar, etc.)

    Here are some screenshots from the current dev version:
    device-2014-09-13-131738.png device-2014-09-13-131656.png device-2014-09-13-131835.png device-2014-09-13-132125.png device-2014-09-13-131936.png

    Oh well, some teasing:
    device-2014-09-13-132813.png

    I won't give any ETA, it's currently still unstable and some of the stuff is plain missing (e.g. remote control).

    Hope that will put your minds at rest a little bit.
     

    powermarcel10

    Retired Team Member
  • Premium Supporter
  • November 30, 2010
    2,839
    898
    32
    Groningen
    Netherlands Netherlands
    This sounds great @DieBagger.

    Thanks a lot for the status update. Great to see all this stuff.

    One question; Will there be good subtitle support? When I'm watching movies on my tablet using Ampdroid, no subtitles are loaded.Even when I try to select the right one in the app, nothing happend.

    Cheers,
    Marcel
     

    Fafnir

    MP Donator
  • Premium Supporter
  • November 19, 2006
    203
    44
    39
    Germany Germany
    Country flag
    Also a big problem is that noone is working on MpExtended either so I had to do some work on the backend side of things too. So if any devs are interested in continuing the project that would be great.
    Hi @DieBagger,

    Thanks for the update.
    Your lines make me scared, that Mpextended could be discontinued...
    but there is life in the project, because there is a beta software out.

    Can you also bring a little light in here?

    Regards Fafnir.
     

    DieBagger

    Retired Team Member
  • Premium Supporter
  • September 11, 2007
    2,516
    1,276
    36
    Austria
    Austria Austria
    Thanks for the update.
    Your lines make me scared, that Mpextended could be discontinued...
    but there is life in the project, because there is a beta software out.

    Can you also bring a little light in here?
    Yes MpExtended needs a developer... I'm not able to do much work on MPExtended since I prefer spending my rare spare time on aMPdroid... I did prepare the beta release but only because it was needed for the iOS app.
     

    mascot

    Portal Pro
    November 20, 2007
    182
    6
    Sweden Sweden
    Ok, moved into a new appartment and now it's time to abuse that 1000/1000 mbit internet connection I've got..

    So, I've got the wifi remote working both on wifi and outside network on 3g connection on my Sony Z1. Now onto the streaming... "plugin not availble on server" is all I'm getting. Latest version of aMPdroid, latest version of MPextended and I also installed the webmediaportal sysem service for remote access from my laptop on the road.

    Forwarded 4322 and 8017 in my Asus router..

    Issues on wifiremote: Can't start mediaportal from android app (start mediaportal from system tray activated in mediaportal) and I can't change volume on the app when mediaportal is running..

    I'm running mediaportal 1.9.0.
     

    stevied20

    Portal Pro
    June 7, 2010
    54
    14
    Christchurch
    New Zealand New Zealand
    Is it working within your WiFi network?....is your ip address on HTPC fixed?.....mine ip used to jump around and cause probs...other than that firewall/network permissions could be the problem
     

    mascot

    Portal Pro
    November 20, 2007
    182
    6
    Sweden Sweden
    No, not within wifi network either. Tried turning off the firewall in windows + in router. Still same "plugin is not available on server" message in ampdroid.

    HTPC IP is static and 8017 + 4322 is forwarded to that IP on the router.
     

    mascot

    Portal Pro
    November 20, 2007
    182
    6
    Sweden Sweden
    Got it working now. It seems the username for authentication dont support åäö etc. special swedish keys.

    /edit Iäm only getting the movies from movingpictures though and not my tvseries (mytvseries)...

    and... nope, still only working inside my network.

    {"ApiVersion":4,"AvailableFileSystemLibraries":[{"Id":10,"Name":"MP Movie Shares","Version":"0.5.4.0"},{"Id":11,"Name":"MP Picture Shares","Version":"0.5.4.0"},{"Id":5,"Name":"MP Shares","Version":"0.5.4.0"},{"Id":9,"Name":"MP Music Shares","Version":"0.5.4.0"}],"AvailableMovieLibraries":[{"Id":3,"Name":"Moving Pictures","Version":"0.5.4.0"},{"Id":7,"Name":"MP MyVideo","Version":"0.5.4.0"}],"AvailableMusicLibraries":[],"AvailablePictureLibraries":[{"Id":8,"Name":"MP Picture Shares","Version":"0.5.4.0"}],"AvailableTvShowLibraries":[{"Id":6,"Name":"MP-TVSeries","Version":"0.5.4.0"}],"DefaultFileSystemLibrary":5,"DefaultMovieLibrary":3,"DefaultMusicLibrary":0,"DefaultPictureLibrary":0,"DefaultTvShowLibrary":6,"ServiceVersion":"0.5.4"}
     
    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom