Avallanche - No Fanart in MainScreen for Moving Pictures (1 Viewer)

gaz_0001

Portal Member
August 4, 2009
40
0
United Kingdom United Kingdom
Any ideas?

I have Avallanche installed with Moving Pictures and TV Series.

For TV Series the fan art is on the main screen but for moving pictures i have no fan art on the main screen.
 

Luca Brasi

MP Donator
  • Premium Supporter
  • November 14, 2007
    1,026
    119
    Germany Germany
    Country flag
    Same here... Sorry no idea why. I noticed that fanart handler config doesn't show any fanart for movpic but it's the same for tvseries.
     

    sweborn

    Extension Designer
    June 8, 2007
    303
    214
    Sweden Sweden
    Any ideas?

    I have Avallanche installed with Moving Pictures and TV Series.

    For TV Series the fan art is on the main screen but for moving pictures i have no fan art on the main screen.
    Are you talking about the background in basic home/movpic? If so, did you use this settings in Avallanche Editor?

    settings.png basichome.png
     

    Luca Brasi

    MP Donator
  • Premium Supporter
  • November 14, 2007
    1,026
    119
    Germany Germany
    Country flag
    Hi sewborn,
    sure, it's been set like that all the time. MovPic is showing some backgrounds which are meant for pictures I guess.
    screen_mmnote_20140828_090433.jpg screen_mmnote_20140828_090722.jpg screen_mmnote_20140828_090742.jpg
    I'll add my avalanche.xml
     

    Attachments

    sweborn

    Extension Designer
    June 8, 2007
    303
    214
    Sweden Sweden
    Hi sewborn,
    sure, it's been set like that all the time. MovPic is showing some backgrounds which are meant for pictures I guess.
    View attachment 154576 View attachment 154577 View attachment 154578
    I'll add my avalanche.xml
    Everything looks fine. What happens if you enable fanart handler in Titan GUI. Did it show the correct fanart i Titan BasicHome-Movpic?
    Edit: Can you try to delete all Avallanche skin files. Make a fresh Avallanche and Avallanche Addict installation. Also delete all cache files. And see if that helps.
     
    Last edited:

    Luca Brasi

    MP Donator
  • Premium Supporter
  • November 14, 2007
    1,026
    119
    Germany Germany
    Country flag
    What happens if you enable fanart handler in Titan GUI.
    It works fine in titan. I noticed that in the titan editor the item for movingpictures in the fanart setting is called movies not moving pictures like in avalanche editor.

    Can you try to delete all Avallanche skin files. Make a fresh Avallanche and Avallanche Addict installation. Also delete all cache files.
    Did that to no avail. After install without the addict theme Avallanche will show me some user defined pictures for movies which is fine as it is set in the editor like that. If I change that setting to movingpictures I will get the user defined backgrounds for Pictures again. From C:\ProgramData\Team MediaPortal\MediaPortal\thumbs\Skin FanArt\UserDef\pictures
    Btw my fanarthandler version is 3.1.0.0 if that is important...
     

    sweborn

    Extension Designer
    June 8, 2007
    303
    214
    Sweden Sweden
    I have now discovered what is wrong. It seems that the user defined backgrounds for pictures lies on top over movpic fanart. If you remove these pictures from the folder thumbs\Skin FanArt\UserDef\pictures the movpics fanart will be shown. I will take a look at BasicHome.FanartHandler_Big.xml and BasicHome.xml
     

    sweborn

    Extension Designer
    June 8, 2007
    303
    214
    Sweden Sweden
    I think the problem may lie in this line for user defined backgrounds for pictures "string.contains(#bgimage,pictures)", because even movingpictures contains the word picture. Hopefully the solution is to change the string to string.equals(#bgimage,pictures). Can you please try these two files and see if it works.
     

    Attachments

    Luca Brasi

    MP Donator
  • Premium Supporter
  • November 14, 2007
    1,026
    119
    Germany Germany
    Country flag
    Hey sweborn, nice! Thanks, it works with that!
    Problem solved :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom