BBC iPlayer (UK) (2 Viewers)

joecrow

Test Group
  • Team MediaPortal
  • August 9, 2012
    2,489
    1,835
    Home Country
    Germany Germany
    Sorry I must be doing something wrong but I do not see an option to "connect to graph" only "connect to remote graph" and when I try that I get the error shown in the attached screenshot.:oops:
    error.jpg
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,523
    2,874
    Nuenen
    Home Country
    Netherlands Netherlands
    Sorry, connect to remote graph is should be indeed. couldn't remember the exact wording
    I think you have to make sure to run the version with the same bitness as MP (so 32bit for MP1, ?? for MP2)
    And make sure you're registring the correct proppage.dll (don't know if both 32bit and 64bit can be registered (with regsvr32, run as admin) at the same time. I only use MP1 so only experience with the 32bit variant...
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,489
    1,835
    Home Country
    Germany Germany
    Same error with 32bit MP2 and 32 bit Graphstudio AND MP1 with 32bit Graphstudio! I found an old version of Graphstudio on the MP1 setup, no error with that but nothing appears to be happening!:confused:
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,489
    1,835
    Home Country
    Germany Germany
    Still no luck with Graphstudio but I have taken the following screenshots of the performance tag from Taskmanager and noted I believe a significant difference in the internet data received using LAV vs the MPURLsplitter. All 3 screenshots are from the same PC running MP2, as far as I can tell there is nothing untoward with the CPU,Mem. and GPU usage but a 10+ x greater amount of data received to play the same program (BBC News 1280x720) with the x86 version using the MPURLsplitter vs the x64 version with LAV does not seem right.
    The first screenshot below is for MP2 x64 using LAV, the 2nd one is MP2x86 using MPURLsplitter (playback stuttering) and the third is also with x86 but with the lower quality (960x540, no stuttering)stream for comparison
    MP2x64.jpgMP2x86.jpgMP2x86_960x540.jpg
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,523
    2,874
    Nuenen
    Home Country
    Netherlands Netherlands
    do you by any chance still have the mpurlsourcesplitter.log from the first screenshot?
    edit: and if there'sn that delay what i described earlier
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,489
    1,835
    Home Country
    Germany Germany
    As far as I can tell MP2 does not produce mpurlsourcesplitter.log, I have attached the full new log from a test done with the x86 MP2 and using the released version of mpurlsourcesplitter. I have subsequently tested further and have been able to play a local (ZDF) catchup program without stutter that consistently was close to 50 Mbits, i.e. even higher than the BBC, so it could be a limitation on my international throughput that is causing the stutter.
    Given the LAV seems to be a much more efficient method of playing content on the internet I do wonder if it might be better just to use that and only switch (automatically) to the mpurlsourcesplitter for downloads, would that be possible???
    Having said all that the BBC was OK at 1280x720 before the most recent change of source in OV and going back a long while ago used to work OK when I had only a 16 Mbit internet.
     

    Attachments

    • MediaPortal2-Logs-2021-05-10-15.05.57.zip
      319.4 KB

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,523
    2,874
    Nuenen
    Home Country
    Netherlands Netherlands
    I actually meant the mpurlsourcesplitter.log from the run where the HD was stuttering (in MP1).
    Given that georgius did do a lot of patching to ensure smooth operation in MP with less reliable sources (and not having issues myself with it) I'm quite reluctant to remove this in favor of LAV
     

    joecrow

    Test Group
  • Team MediaPortal
  • August 9, 2012
    2,489
    1,835
    Home Country
    Germany Germany
    Given that georgius did do a lot of patching to ensure smooth operation in MP with less reliable sources (and not having issues myself with it) I'm quite reluctant to remove this in favor of LAV
    It has served us well but MP2 have dropped it for both versions by default, although I would still like to see it available (automatically if possible) for OV downloads in both versions. I do not think there have been any OV complaints specific to MP2 so I don't see the use of the LAV splitter causing problems.
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    4,523
    2,874
    Nuenen
    Home Country
    Netherlands Netherlands
    Ok I misread things a bit.
    I meant the mpurlsourcesplitter.log from the stuttering run (on MP2 when mpurlsourcesplitter is used ( MP2x86 using MPURLsplitter in your case)
    Also something that is not supported by LAV is if the remote server needs some extra headers (referrer, cookies etc), and current progress.
    I really like/need those 2 options so from my perspective dropping MPUrlSourceSplitter would be a serious drop in functionality.
    Best I can do in the future is make it configurable in OV if you want to use MPUrlSourceSplitter or not
     

    Users who are viewing this thread

    Top Bottom