[WiP] - BD-J Feature | Page 5

Discussion in 'Area 51 - Testing Area' started by Sebastiii, March 20, 2016.

  1. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,527
    Likes Received:
    4,738
    Ratings:
    +8,205 / 17
    Home Country:
    New Zealand New Zealand
    If you provide log files then it may be possible for us to investigate as well.


     
    • Like Like x 1
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. SilentBob

    SilentBob Portal Pro

    Joined:
    January 1, 2011
    Messages:
    54
    Likes Received:
    38
    Ratings:
    +50 / 0
    Home Country:
    Germany Germany
    So finally I found the issue at my machine (not so much time between the soccer games ;))

    The LAV Settings are per User settings, and I do not know why, but for my MediaPortal User the checkboxes where disabled for h264.
    LAVFormatSettings.png
    After enabling the settings the issue was gone.

    Nonetheless now I am at some real issues, my default test BD (Guardians of the Galaxy) does not want to run, it starts with Language Selection, after that the short Marvel Flipbook Logo for their cinematic movies starts, but stops after a while (no sound is played)
    I also came further with the BD, then I hear sound. Up to now no Idea why this works sometimes but most times not.

    Other BD work quite good, I can use the menu and start the film. For one I am not able to start some specials.
    In some cases I already had MP crashes (when I am using the menu to heavy/nervous clicking)
    I also had a MP crash when shutting down with corrupt heap or memory.

    I will continue testing with debug log enabled (is it enough to enable MP debug log, or should i also enable special libbluray logging?)

    For a first shot it looks quite good, but it needs some improvements and stabilization for future, but better than no BDJ support ;)
     

    Attached Files:

    • Thank You! Thank You! x 1
  4. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,264
    Likes Received:
    6,218
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,224 / 9
    Home Country:
    France France
    Show System Specs
    Great :)
    Both log (MP and BD) can be nice :)
    I will try to update the branch soon (surely next weekend).
     
    • Like Like x 1
  5. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,264
    Likes Received:
    6,218
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,224 / 9
    Home Country:
    France France
    Show System Specs
    Added new installer in first post :)
    Updated against latest master code + libbluray (Tourettes repo) :)
     
    • Like Like x 2
  6. Andy Ford

    Andy Ford Portal Member

    Joined:
    February 28, 2012
    Messages:
    35
    Likes Received:
    8
    Gender:
    Male
    Ratings:
    +9 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Hi and thank you for eveyones work on this great feature.
    I just wanted to let you have some feedback.
    After installing the version '275833_MediaPortalSetup_1.15.0_2016-07-10-BD-J' I had great success with playback of all BD iso files on my system, with access to all menu features and the correct soundtrack/subtitles selected.
    I did encounter a problem when I enabled DVB Subtitles in MP Config/TV Radio/TV/Subtitle settings. If I enabled subtitles, MePo would crash when I tried to watch live tv. I realize that this is WIP and wasn't sure if you would expect that behaviour?
    I have now reverted to 1.15.0 Final and can enable/disable subtitles with no issues.
    As I'm really busy at the moment I'm afraid I don't have time to swap builds and supply logs, but if they would be useful I should be able to this sometime during next week.

    Andy
     
    • Like Like x 1
  7. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,264
    Likes Received:
    6,218
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,224 / 9
    Home Country:
    France France
    Show System Specs
    It seems to happen that tsreader.ax and/or dvbsub.ax wasn't updated during upgrade, it seems we have a general bug here !!!!
    So if you delete .ax before the upgrade, it should work :)
    Tsreader.ax need to be updated against the version on bdreader.ax (BD-J)

    .AX can be found in :
    C:\Program Files (x86)\Team MediaPortal\MediaPortal
    and/or
    C:\Program Files (x86)\Team MediaPortal\MediaPortal TV Server (when using Singleseat TV)

    So it shouldn't crash anymore :)
     
    • Like Like x 2
    • Agree Agree x 1
  8. Andy Ford

    Andy Ford Portal Member

    Joined:
    February 28, 2012
    Messages:
    35
    Likes Received:
    8
    Gender:
    Male
    Ratings:
    +9 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Thanks for the fast reply
    I will try your suggestions later...when wife has stopped watching TV :)
    and let you know how I get on

    Regards

    Andy
     
    • Like Like x 1
  9. Andy Ford

    Andy Ford Portal Member

    Joined:
    February 28, 2012
    Messages:
    35
    Likes Received:
    8
    Gender:
    Male
    Ratings:
    +9 / 0
    Home Country:
    Great Britain (UK) Great Britain (UK)
    Hi Sebastiii

    I followed your advice and deleted DVBSub3.ax and TsReader.ax and then re-installed version in first post.
    Now all is working perfectly :)

    Thank you again for your help in identifying and resolving the issue, it's really appreciated. Please let me know if I can help you with any testing/logs.

    Andy
     
    • Like Like x 2
    • Thank You! Thank You! x 1
  10. Wbunaarf
    • Team MediaPortal

    Wbunaarf Test Group

    Joined:
    December 9, 2005
    Messages:
    534
    Likes Received:
    89
    Location:
    Sweden
    Ratings:
    +98 / 0
    Home Country:
    Sweden Sweden
    Show System Specs
    I did some quick testing. The Force Awakens and An Unexpected Journey seems to work (though I couldn't return to the disc menu from MP's menu on the latter). On Minions no menus seems to be found and if I start playback it just plays one of the bonus features. Inside Out also doesn't seem to find any menus. I can start the movie but then I get a language selection overlay (not working). I tested the last two with the latest VLC nightly and there I got working menus on both.

    Perhaps I should add that I'm currently testing on an ATI3450 while waiting for a new card to replace a fried 6570...

    //W
     

    Attached Files:

    • Like Like x 1
  11. Blue Lightning

    Blue Lightning Portal Member

    Joined:
    October 8, 2011
    Messages:
    49
    Likes Received:
    26
    Ratings:
    +43 / 0
    Home Country:
    Australia Australia
    Show System Specs
    I've tested this on my desktop (I don't want to mess with my actual HTPC), and it works. The Phantom Menace (B), and "Spoofs and Documentaries" (region B) (both from the Star Wars Saga collection), and The Force Awakens (A/B/C multiregion, I assume it's running as region B). Their BD-J menus work (compared to not having menus at all in the current Mediaportal). I checked a non-BD-J Bluray and it continues to work normally as in the current Mediaportal.
    MediaPortalSetup_1.15.0_2016-07-10-BD-J, TvServer not installed (only Client and LAV filters), Windows 7 SP1 64bit, and I installed Java 8u101 (both 32 and 64bit).
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!